import rubygem-rspec-mocks-3.7.0-4.el8
This commit is contained in:
commit
7bd0589b2d
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
||||
SOURCES/rspec-mocks-3.7.0.gem
|
||||
SOURCES/rubygem-rspec-mocks-3.7.0-full.tar.gz
|
2
.rubygem-rspec-mocks.metadata
Normal file
2
.rubygem-rspec-mocks.metadata
Normal file
@ -0,0 +1,2 @@
|
||||
ba57acddaf6cea7c70250fef45a8727ecec1961e SOURCES/rspec-mocks-3.7.0.gem
|
||||
85feb66ca146e970358aa1cf9a521ab724d70d81 SOURCES/rubygem-rspec-mocks-3.7.0-full.tar.gz
|
66
SOURCES/rspec-mocks-3.7.0-test-ruby-25.patch
Normal file
66
SOURCES/rspec-mocks-3.7.0-test-ruby-25.patch
Normal file
@ -0,0 +1,66 @@
|
||||
From 871eb31e3bfe50705ca57e754771aa1e0164f12d Mon Sep 17 00:00:00 2001
|
||||
From: Myron Marston <myron.marston@gmail.com>
|
||||
Date: Sat, 30 Dec 2017 17:45:43 -0800
|
||||
Subject: [PATCH 1/2] Skip spec that does not apply to Ruby 2.5.
|
||||
|
||||
Ruby 2.5 has removed the ability to access top-level constants
|
||||
via a confusing nested form (e.g. `MyClass::Hash`), so we no
|
||||
longer need this spec there.
|
||||
|
||||
For #1192.
|
||||
---
|
||||
spec/rspec/mocks/mutate_const_spec.rb | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/spec/rspec/mocks/mutate_const_spec.rb b/spec/rspec/mocks/mutate_const_spec.rb
|
||||
index fe8d4128..9d80dd73 100644
|
||||
--- a/spec/rspec/mocks/mutate_const_spec.rb
|
||||
+++ b/spec/rspec/mocks/mutate_const_spec.rb
|
||||
@@ -170,7 +170,7 @@ def change_const_value_to(value)
|
||||
expect(::Hash).to equal(top_level_hash)
|
||||
end
|
||||
|
||||
- it 'does not affect the ability to access the top-level constant from nested contexts', :silence_warnings do
|
||||
+ it 'does not affect the ability to access the top-level constant from nested contexts', :silence_warnings, :if => RUBY_VERSION < '2.5' do
|
||||
top_level_hash = ::Hash
|
||||
|
||||
hide_const("TestClass::Hash")
|
||||
|
||||
From 783923d6879a2f9df9fee8ef24cecca6ac21136e Mon Sep 17 00:00:00 2001
|
||||
From: Myron Marston <myron.marston@gmail.com>
|
||||
Date: Sat, 30 Dec 2017 23:35:27 -0800
|
||||
Subject: [PATCH 2/2] Make spec less brittle.
|
||||
|
||||
On Ruby 2.5, this spec failed, apparently due to the fact that
|
||||
Method equality has changed on 2.5 slightly. The method instances
|
||||
have always been different but 2.4 and before considered them
|
||||
equivalent. Instead, we can show that the two method objects
|
||||
_behave_ the same, which is what we really care about.
|
||||
|
||||
Fixes #1192.
|
||||
---
|
||||
spec/rspec/mocks/and_wrap_original_spec.rb | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/spec/rspec/mocks/and_wrap_original_spec.rb b/spec/rspec/mocks/and_wrap_original_spec.rb
|
||||
index df9cae46..2d4d0a8b 100644
|
||||
--- a/spec/rspec/mocks/and_wrap_original_spec.rb
|
||||
+++ b/spec/rspec/mocks/and_wrap_original_spec.rb
|
||||
@@ -26,12 +26,13 @@ def results
|
||||
}.to raise_error NameError
|
||||
end
|
||||
|
||||
- it "passes in the original method" do
|
||||
- value = nil
|
||||
+ it "passes along the original method" do
|
||||
+ passed_method = nil
|
||||
original_method = instance.method(:results)
|
||||
- allow_it.to receive(:results).and_wrap_original { |m| value = m }
|
||||
+ allow_it.to receive(:results).and_wrap_original { |m| passed_method = m }
|
||||
instance.results
|
||||
- expect(value).to eq original_method
|
||||
+
|
||||
+ expect(passed_method.call).to eq(original_method.call)
|
||||
end
|
||||
|
||||
it "passes along the message arguments" do
|
27
SOURCES/rspec-related-create-full-tarball.sh
Normal file
27
SOURCES/rspec-related-create-full-tarball.sh
Normal file
@ -0,0 +1,27 @@
|
||||
#!/bin/bash
|
||||
|
||||
if [ $# -lt 2 ]
|
||||
then
|
||||
echo "$0 <name> <version>"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
set -x
|
||||
set -e
|
||||
|
||||
CURRDIR=$(pwd)
|
||||
|
||||
TMPDIRPATH=$(mktemp -d /var/tmp/rspec-tar-XXXXXX)
|
||||
pushd $TMPDIRPATH
|
||||
|
||||
git clone https://github.com/rspec/$1.git
|
||||
pushd $1
|
||||
git reset --hard v$2
|
||||
popd
|
||||
|
||||
ln -sf $1 $1-$2
|
||||
tar czf ${CURRDIR}/rubygem-$1-$2-full.tar.gz $1-$2/./
|
||||
|
||||
popd
|
||||
|
||||
rm -rf $TMPDIRPATH
|
263
SPECS/rubygem-rspec-mocks.spec
Normal file
263
SPECS/rubygem-rspec-mocks.spec
Normal file
@ -0,0 +1,263 @@
|
||||
%global majorver 3.7.0
|
||||
#%%global preminorver .rc6
|
||||
%global rpmminorver .%(echo %preminorver | sed -e 's|^\\.\\.*||')
|
||||
%global fullver %{majorver}%{?preminorver}
|
||||
|
||||
%global fedorarel 4
|
||||
|
||||
%global gem_name rspec-mocks
|
||||
|
||||
%global need_bootstrap_set 0
|
||||
|
||||
%undefine __brp_mangle_shebangs
|
||||
|
||||
Summary: RSpec's 'test double' framework (mocks and stubs)
|
||||
Name: rubygem-%{gem_name}
|
||||
Version: %{majorver}
|
||||
Release: %{?preminorver:0.}%{fedorarel}%{?preminorver:%{rpmminorver}}%{?dist}
|
||||
|
||||
Group: Development/Languages
|
||||
License: MIT
|
||||
URL: http://github.com/rspec/rspec-mocks
|
||||
Source0: https://rubygems.org/gems/%{gem_name}-%{fullver}.gem
|
||||
# %%{SOURCE2} %%{name} %%{version}
|
||||
Source1: rubygem-%{gem_name}-%{version}-full.tar.gz
|
||||
Source2: rspec-related-create-full-tarball.sh
|
||||
# https://github.com/rspec/rspec-mocks/pull/1196
|
||||
# https://github.com/rspec/rspec-mocks/commit/1d2f2404a17c3a76742379bb0c57d133df8e7371.patch
|
||||
Patch1: rspec-mocks-3.7.0-test-ruby-25.patch
|
||||
|
||||
#BuildRequires: ruby(release)
|
||||
BuildRequires: rubygems-devel
|
||||
%if 0%{?need_bootstrap_set} < 1
|
||||
BuildRequires: rubygem(rspec)
|
||||
BuildRequires: rubygem(rake)
|
||||
BuildRequires: rubygem(thread_order)
|
||||
BuildRequires: git
|
||||
%endif
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
rspec-mocks provides a test-double framework for rspec including support
|
||||
for method stubs, fakes, and message expectations.
|
||||
|
||||
%package doc
|
||||
Summary: Documentation for %{name}
|
||||
Group: Documentation
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description doc
|
||||
This package contains documentation for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
gem unpack %{SOURCE0}
|
||||
|
||||
%setup -q -D -T -n %{gem_name}-%{version} -b 1
|
||||
%patch1 -p1
|
||||
|
||||
gem specification %{SOURCE0} -l --ruby > %{gem_name}.gemspec
|
||||
|
||||
%build
|
||||
gem build %{gem_name}.gemspec
|
||||
%gem_install
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}%{gem_dir}
|
||||
cp -a .%{gem_dir}/* \
|
||||
%{buildroot}%{gem_dir}/
|
||||
|
||||
# cleanups
|
||||
rm -f %{buildroot}%{gem_instdir}/{.document,.yardopts}
|
||||
|
||||
%if 0%{?need_bootstrap_set} < 1
|
||||
%check
|
||||
# library_wide_checks.rb needs UTF-8
|
||||
LANG=en_US.utf8
|
||||
ruby -rrubygems -Ilib/ -S rspec spec/
|
||||
%endif
|
||||
|
||||
%files
|
||||
%dir %{gem_instdir}
|
||||
|
||||
%license %{gem_instdir}/LICENSE.md
|
||||
%doc %{gem_instdir}/Changelog.md
|
||||
%doc %{gem_instdir}/README.md
|
||||
|
||||
%{gem_instdir}/lib/
|
||||
|
||||
%exclude %{gem_cache}
|
||||
%{gem_spec}
|
||||
|
||||
%files doc
|
||||
%{gem_docdir}
|
||||
|
||||
%changelog
|
||||
* Thu Jul 12 2018 Jun Aruga <jaruga@redhat.com> - 3.7.0-4
|
||||
- Fix FTBFS by adding build dependency for RHEL.
|
||||
|
||||
* Wed Feb 14 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.1-3
|
||||
- Backport patch to fix test failure with ruby 2.5
|
||||
|
||||
* Tue Feb 13 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.1-2
|
||||
- ruby 2.5 drops -rubygems usage
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.0-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Nov 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-1
|
||||
- Enable tests again
|
||||
|
||||
* Mon Nov 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-0.1
|
||||
- 3.7.0
|
||||
- Once disable tests
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.0-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat May 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.6.0-1
|
||||
- Enable tests again
|
||||
|
||||
* Sat May 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.6.0-0.1
|
||||
- 3.6.0
|
||||
- Once disable tests
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.0-2.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jan 17 2017 Vít Ondruch <vondruch@redhat.com> - 3.5.0-2
|
||||
- Fix Ruby 2.4 compatibility.
|
||||
|
||||
* Sun Jul 24 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-1
|
||||
- Enable tests again
|
||||
|
||||
* Sat Jul 23 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-0.1
|
||||
- 3.5.0
|
||||
- Once disable tests
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.1-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jan 14 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.1-1
|
||||
- 3.4.1
|
||||
|
||||
* Tue Dec 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.0-2
|
||||
- Enable tests again
|
||||
|
||||
* Tue Dec 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.0-1
|
||||
- 3.4.0
|
||||
- Once disable tests
|
||||
|
||||
* Wed Aug 12 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.2-3
|
||||
- Enable thread_order dependent tests
|
||||
|
||||
* Sun Aug 2 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.2-2
|
||||
- Enable tests again
|
||||
|
||||
* Sun Aug 2 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.2-1
|
||||
- 3.3.2
|
||||
- Once disable tests
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.1-1
|
||||
- 3.2.1
|
||||
|
||||
* Mon Feb 9 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.0-2
|
||||
- Enable tests again
|
||||
|
||||
* Mon Feb 9 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.0-1
|
||||
- 3.2.0
|
||||
- Once disable tests
|
||||
|
||||
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.3-2
|
||||
- Enable tests
|
||||
|
||||
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.3-1
|
||||
- 3.1.3
|
||||
- Once disable tests
|
||||
|
||||
* Fri Aug 15 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.4-1
|
||||
- 3.0.4
|
||||
|
||||
* Thu Aug 14 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.3-1
|
||||
- 3.0.3
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.6-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Feb 27 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.6-1
|
||||
- 2.14.6
|
||||
|
||||
* Tue Feb 4 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.5-1
|
||||
- 2.14.5
|
||||
|
||||
* Thu Oct 24 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.4-1
|
||||
- 2.14.4
|
||||
|
||||
* Fri Aug 16 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.3-2
|
||||
- Enable test suite again
|
||||
|
||||
* Fri Aug 16 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.3-1
|
||||
- 2.14.3
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.13.1-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Apr 12 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.13.1-1
|
||||
- 2.13.1
|
||||
|
||||
* Thu Mar 28 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.13.0-2
|
||||
- Enable test suite again
|
||||
|
||||
* Thu Mar 28 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.13.0-1
|
||||
- 2.13.0
|
||||
|
||||
* Wed Feb 20 2013 Vít Ondruch <vondruch@redhat.com> - 2.12.2-2
|
||||
- Rebuild for https://fedoraproject.org/wiki/Features/Ruby_2.0.0
|
||||
|
||||
* Mon Feb 4 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.12.2-1
|
||||
- 2.12.2
|
||||
|
||||
* Wed Jan 2 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.12.1-2
|
||||
- Enable test suite again
|
||||
|
||||
* Wed Jan 2 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.12.1-1
|
||||
- 2.12.1
|
||||
|
||||
* Thu Oct 11 2012 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.11.3-1
|
||||
- 2.11.3
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.0-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sun Jan 22 2012 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.8.0-1
|
||||
- 2.8.0
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.0-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon May 16 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.6.0-1
|
||||
- 2.6.0
|
||||
|
||||
* Tue May 10 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.6.0-0.3.rc6
|
||||
- 2.6.0 rc6
|
||||
|
||||
* Tue May 3 2011 Mamoru Tasaka <mtasaka@fedoraproject.org>
|
||||
- And enable check on rawhide
|
||||
|
||||
* Tue May 3 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.6.0-0.1.rc4
|
||||
- 2.6.0 rc4
|
||||
|
||||
* Sat Feb 26 2011 Mamoru Tasaka <mtasaka@fedoraproject.org>
|
||||
- And enable check on rawhide
|
||||
|
||||
* Sat Feb 26 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.5.0-2
|
||||
- Cleanups
|
||||
|
||||
* Thu Feb 17 2011 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 2.5.0-1
|
||||
- 2.5.0
|
||||
|
||||
* Fri Nov 05 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 2.0.1-1
|
||||
- Initial package
|
Loading…
Reference in New Issue
Block a user