Auto sync2gitlab import of rubygem-rspec-expectations-3.7.0-4.el8.src.rpm
This commit is contained in:
parent
9138521809
commit
95d8211519
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
/rspec-expectations-3.7.0.gem
|
||||||
|
/rubygem-rspec-expectations-3.7.0-full.tar.gz
|
33
rspec-expectations-3.7.0-aggregator-ruby25.patch
Normal file
33
rspec-expectations-3.7.0-aggregator-ruby25.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
From 5999ad46df4782a3136c4bad0c2353daede2cbbd Mon Sep 17 00:00:00 2001
|
||||||
|
From: Myron Marston <myron.marston@gmail.com>
|
||||||
|
Date: Sat, 30 Dec 2017 17:36:55 -0800
|
||||||
|
Subject: [PATCH] Disable Ruby 2.5 feature to avoid test failures on 2.5.
|
||||||
|
|
||||||
|
---
|
||||||
|
spec/rspec/expectations/failure_aggregator_spec.rb | 13 +++++++++++++
|
||||||
|
1 file changed, 13 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/spec/rspec/expectations/failure_aggregator_spec.rb b/spec/rspec/expectations/failure_aggregator_spec.rb
|
||||||
|
index 6628aa75..40a1ae35 100644
|
||||||
|
--- a/spec/rspec/expectations/failure_aggregator_spec.rb
|
||||||
|
+++ b/spec/rspec/expectations/failure_aggregator_spec.rb
|
||||||
|
@@ -216,6 +216,19 @@ def expect_error_included_in_aggregated_failure(error)
|
||||||
|
end
|
||||||
|
|
||||||
|
context "when an expectation failure happens in another thread" do
|
||||||
|
+ # On Ruby 2.5+, the new `report_on_exception` causes the errors in the threads
|
||||||
|
+ # to print warnings, which our rspec-support test harness converts into a test
|
||||||
|
+ # failure since we want to enforce warnings-free code. To prevent the warning,
|
||||||
|
+ # we need to disable the setting here.
|
||||||
|
+ if Thread.respond_to?(:report_on_exception)
|
||||||
|
+ around do |example|
|
||||||
|
+ orig = Thread.report_on_exception
|
||||||
|
+ Thread.report_on_exception = false
|
||||||
|
+ example.run
|
||||||
|
+ Thread.report_on_exception = orig
|
||||||
|
+ end
|
||||||
|
+ end
|
||||||
|
+
|
||||||
|
it "includes the failure in the failures array if there are other failures" do
|
||||||
|
expect {
|
||||||
|
aggregate_failures do
|
27
rspec-related-create-full-tarball.sh
Normal file
27
rspec-related-create-full-tarball.sh
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
if [ $# -lt 2 ]
|
||||||
|
then
|
||||||
|
echo "$0 <name> <version>"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
set -x
|
||||||
|
set -e
|
||||||
|
|
||||||
|
CURRDIR=$(pwd)
|
||||||
|
|
||||||
|
TMPDIRPATH=$(mktemp -d /var/tmp/rspec-tar-XXXXXX)
|
||||||
|
pushd $TMPDIRPATH
|
||||||
|
|
||||||
|
git clone https://github.com/rspec/$1.git
|
||||||
|
pushd $1
|
||||||
|
git reset --hard v$2
|
||||||
|
popd
|
||||||
|
|
||||||
|
ln -sf $1 $1-$2
|
||||||
|
tar czf ${CURRDIR}/rubygem-$1-$2-full.tar.gz $1-$2/./
|
||||||
|
|
||||||
|
popd
|
||||||
|
|
||||||
|
rm -rf $TMPDIRPATH
|
267
rubygem-rspec-expectations.spec
Normal file
267
rubygem-rspec-expectations.spec
Normal file
@ -0,0 +1,267 @@
|
|||||||
|
%global majorver 3.7.0
|
||||||
|
#%%global preminorver .rc6
|
||||||
|
%global rpmminorver .%(echo %preminorver | sed -e 's|^\\.\\.*||')
|
||||||
|
%global fullver %{majorver}%{?preminorver}
|
||||||
|
|
||||||
|
%global fedorarel 4
|
||||||
|
|
||||||
|
%global gem_name rspec-expectations
|
||||||
|
|
||||||
|
%global need_bootstrap_set 0
|
||||||
|
|
||||||
|
%undefine __brp_mangle_shebangs
|
||||||
|
|
||||||
|
Summary: RSpec expectations (should and matchers)
|
||||||
|
Name: rubygem-%{gem_name}
|
||||||
|
Version: %{majorver}
|
||||||
|
Release: %{?preminorver:0.}%{fedorarel}%{?preminorver:%{rpmminorver}}%{?dist}
|
||||||
|
|
||||||
|
Group: Development/Languages
|
||||||
|
License: MIT
|
||||||
|
URL: http://github.com/rspec/rspec-expectations
|
||||||
|
Source0: https://rubygems.org/gems/%{gem_name}-%{fullver}.gem
|
||||||
|
# %%{SOURCE2} %%{name} %%{version}
|
||||||
|
Source1: rubygem-%{gem_name}-%{version}-full.tar.gz
|
||||||
|
Source2: rspec-related-create-full-tarball.sh
|
||||||
|
# https://github.com/rspec/rspec-expectations/pull/1037
|
||||||
|
# https://github.com/rspec/rspec-expectations/commit/5999ad46df4782a3136c4bad0c2353daede2cbbd.patch
|
||||||
|
Patch1: rspec-expectations-3.7.0-aggregator-ruby25.patch
|
||||||
|
|
||||||
|
#BuildRequires: ruby(release)
|
||||||
|
BuildRequires: rubygems-devel
|
||||||
|
%if 0%{?need_bootstrap_set} < 1
|
||||||
|
BuildRequires: rubygem(rspec)
|
||||||
|
BuildRequires: rubygem(minitest) >= 5
|
||||||
|
BuildRequires: rubygem(rake)
|
||||||
|
BuildRequires: git
|
||||||
|
%endif
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description
|
||||||
|
rspec-expectations adds `should` and `should_not` to every object and includes
|
||||||
|
RSpec::Matchers, a library of standard matchers.
|
||||||
|
|
||||||
|
%package doc
|
||||||
|
Summary: Documentation for %{name}
|
||||||
|
Group: Documentation
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package contains documentation for %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -T -n %{gem_name}-%{version} -b 1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
gem specification %{SOURCE0} -l --ruby > %{gem_name}.gemspec
|
||||||
|
|
||||||
|
%build
|
||||||
|
gem build %{gem_name}.gemspec
|
||||||
|
%gem_install
|
||||||
|
|
||||||
|
%install
|
||||||
|
mkdir -p %{buildroot}%{gem_dir}
|
||||||
|
cp -a .%{gem_dir}/* \
|
||||||
|
%{buildroot}%{gem_dir}/
|
||||||
|
|
||||||
|
# cleanups
|
||||||
|
rm -f %{buildroot}%{gem_instdir}/{.document,.yardopts}
|
||||||
|
|
||||||
|
%if 0%{?need_bootstrap_set} < 1
|
||||||
|
%check
|
||||||
|
LANG=en_US.UTF-8
|
||||||
|
ruby -rrubygems -Ilib/ -S rspec spec/
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files
|
||||||
|
%dir %{gem_instdir}
|
||||||
|
|
||||||
|
%license %{gem_instdir}/LICENSE.md
|
||||||
|
%doc %{gem_instdir}/Changelog.md
|
||||||
|
%doc %{gem_instdir}/README.md
|
||||||
|
|
||||||
|
%{gem_instdir}/lib/
|
||||||
|
|
||||||
|
%exclude %{gem_cache}
|
||||||
|
%{gem_spec}
|
||||||
|
|
||||||
|
%files doc
|
||||||
|
%{gem_docdir}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Jul 12 2018 Jun Aruga <jaruga@redhat.com> - 3.7.0-4
|
||||||
|
- Fix FTBFS by adding build dependency for RHEL.
|
||||||
|
|
||||||
|
* Wed Feb 14 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-3
|
||||||
|
- Backport upstream patch to fix test failure on ruby 25
|
||||||
|
|
||||||
|
* Tue Feb 13 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-2
|
||||||
|
- ruby 2.5 drops -rubygems usage
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.0-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-1
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Mon Nov 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-0.1
|
||||||
|
- 3.7.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.0-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.6.0-1
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Sat May 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.6.0-0.1
|
||||||
|
- 3.6.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Tue Feb 21 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-3
|
||||||
|
- Always use full tar.gz for installed files and
|
||||||
|
keep using gem file for gem spec (ref: bug 1425220)
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.0-2.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 18 2017 Vít Ondruch <vondruch@redhat.com> - 3.5.0-2
|
||||||
|
- Fix Ruby 2.4 compatibility.
|
||||||
|
|
||||||
|
* Sun Jul 24 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-1
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Sat Jul 23 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-0.1
|
||||||
|
- 3.5.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.0-2.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.0-2
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Tue Dec 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.0-1
|
||||||
|
- 3.4.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Sun Aug 2 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.1-2
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Sun Aug 2 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.1-1
|
||||||
|
- 3.3.1
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.1-1
|
||||||
|
- 3.2.1
|
||||||
|
|
||||||
|
* Mon Feb 9 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.0-2
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Mon Feb 9 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.0-1
|
||||||
|
- 3.2.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.2-2
|
||||||
|
- Enable tests
|
||||||
|
|
||||||
|
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.2-1
|
||||||
|
- 3.1.2
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Fri Aug 15 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.4-1
|
||||||
|
- 3.0.4
|
||||||
|
|
||||||
|
* Thu Aug 14 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.3-1
|
||||||
|
- 3.0.3
|
||||||
|
|
||||||
|
* Thu Aug 14 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.5-4
|
||||||
|
- Clearner way to specify minitest 4.x
|
||||||
|
|
||||||
|
* Wed Aug 13 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.5-3
|
||||||
|
- Backport temporarily be_truthy matchers and so on
|
||||||
|
|
||||||
|
* Thu Jun 26 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.5-2
|
||||||
|
- Force to use minitest 4.x, 5.x is too dangerous now
|
||||||
|
|
||||||
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.5-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 3 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.5-1
|
||||||
|
- 2.14.5
|
||||||
|
|
||||||
|
* Mon Nov 11 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.4-1
|
||||||
|
- 2.14.4
|
||||||
|
|
||||||
|
* Fri Sep 27 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.3-1
|
||||||
|
- 2.14.3
|
||||||
|
|
||||||
|
* Fri Aug 16 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.2-2
|
||||||
|
- Enable test suite again
|
||||||
|
|
||||||
|
* Fri Aug 16 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.14.2-1
|
||||||
|
- 2.14.2
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.13.0-2.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 28 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.13.0-2
|
||||||
|
- Enable test suite again
|
||||||
|
|
||||||
|
* Thu Mar 28 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.13.0-1
|
||||||
|
- 2.13.0
|
||||||
|
|
||||||
|
* Wed Feb 20 2013 Vít Ondruch <vondruch@redhat.com> - 2.12.1-3
|
||||||
|
- Rebuild for https://fedoraproject.org/wiki/Features/Ruby_2.0.0
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12.1-2.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 2 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.12.1-2
|
||||||
|
- Enable test suite again
|
||||||
|
|
||||||
|
* Wed Jan 2 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.12.1-1
|
||||||
|
- 2.12.1
|
||||||
|
|
||||||
|
* Thu Oct 11 2012 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.11.3-1
|
||||||
|
- 2.11.3
|
||||||
|
|
||||||
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.0-2.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 22 2012 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.8.0-2
|
||||||
|
- Require (diff-lcs) again
|
||||||
|
|
||||||
|
* Sun Jan 22 2012 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.8.0-1
|
||||||
|
- 2.8.0
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.0-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon May 16 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.6.0-1
|
||||||
|
- 2.6.0
|
||||||
|
|
||||||
|
* Tue May 10 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.6.0-0.3.rc6
|
||||||
|
- 2.6.0 rc6
|
||||||
|
|
||||||
|
* Tue May 3 2011 Mamoru Tasaka <mtasaka@fedoraproject.org>
|
||||||
|
- And enable check on rawhide
|
||||||
|
|
||||||
|
* Tue May 3 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.6.0-0.1.rc4
|
||||||
|
- 2.6.0 rc4
|
||||||
|
|
||||||
|
* Sat Feb 26 2011 Mamoru Tasaka <mtasaka@fedoraproject.org>
|
||||||
|
- And enable check on rawhide
|
||||||
|
|
||||||
|
* Sat Feb 26 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 2.5.0-2
|
||||||
|
- Cleanups
|
||||||
|
|
||||||
|
* Thu Feb 17 2011 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 2.5.0-1
|
||||||
|
- 2.5.0
|
||||||
|
|
||||||
|
* Fri Nov 05 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 2.0.1-1
|
||||||
|
- Initial package
|
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SHA512 (rspec-expectations-3.7.0.gem) = 011575f87fb26ea3dd04ebff30f94c6686f07508c3adfd5b1fe6cde12758bd05773b685e45d4596ccccf860b85de74da14ea80072ac09932aa0ab30e06304a24
|
||||||
|
SHA512 (rubygem-rspec-expectations-3.7.0-full.tar.gz) = 8c316c899a5f6f165874ba7affc039ef7061a4e002c39757db40b223474ee085403b1e9cc63e26b8b5a3caaf9dd26055a66d7c2263a4f637bf4814c6c9ff593a
|
Loading…
Reference in New Issue
Block a user