1.5.0
This commit is contained in:
parent
7dd6ca4bef
commit
f462b6acbe
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ nokogiri-1.4.3.1.gem
|
|||||||
/nokogiri-1.5.0.beta.2.gem
|
/nokogiri-1.5.0.beta.2.gem
|
||||||
/nokogiri-1.5.0.beta.3.gem
|
/nokogiri-1.5.0.beta.3.gem
|
||||||
/nokogiri-1.5.0.beta.4.gem
|
/nokogiri-1.5.0.beta.4.gem
|
||||||
|
/nokogiri-1.5.0.gem
|
||||||
|
26
rubygem-nokogiri-1.5.0-allow-non-crosscompile.patch
Normal file
26
rubygem-nokogiri-1.5.0-allow-non-crosscompile.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
--- nokogiri-1.5.0/Rakefile.debug 2012-01-18 16:23:02.472224272 +0900
|
||||||
|
+++ nokogiri-1.5.0/Rakefile 2012-01-18 16:23:29.935430496 +0900
|
||||||
|
@@ -83,14 +83,21 @@
|
||||||
|
HOE.spec.files += ['lib/nokogiri/nokogiri.jar']
|
||||||
|
end
|
||||||
|
else
|
||||||
|
- require 'tasks/cross_compile'
|
||||||
|
+ do_cross_compile = true
|
||||||
|
+ begin
|
||||||
|
+ require 'tasks/cross_compile'
|
||||||
|
+ rescue RuntimeError => e
|
||||||
|
+ warn "WARNING: Could not perform some cross-compiling: #{e}"
|
||||||
|
+ do_cross_compile = false
|
||||||
|
+ end
|
||||||
|
require "rake/extensiontask"
|
||||||
|
|
||||||
|
- HOE.spec.files.reject! { |f| f =~ %r{^ext/java|\.jar$} }
|
||||||
|
+ HOE.spec.files.reject! { |f| f =~ %r{^ext/java|\.jar$} } if do_cross_compile
|
||||||
|
|
||||||
|
Rake::ExtensionTask.new("nokogiri", HOE.spec) do |ext|
|
||||||
|
ext.lib_dir = File.join(*['lib', 'nokogiri', ENV['FAT_DIR']].compact)
|
||||||
|
ext.config_options << ENV['EXTOPTS']
|
||||||
|
+ next unless do_cross_compile
|
||||||
|
ext.cross_compile = true
|
||||||
|
ext.cross_platform = ["x86-mswin32-60", "x86-mingw32"]
|
||||||
|
ext.cross_config_options << "--with-xml2-include=#{File.join($recipes[:libxml2].path, 'include', 'libxml2')}"
|
@ -3,9 +3,9 @@
|
|||||||
%global rubyabi 1.8
|
%global rubyabi 1.8
|
||||||
|
|
||||||
%global mainver 1.5.0
|
%global mainver 1.5.0
|
||||||
%global prever .beta.4
|
#%%global prever .beta.4
|
||||||
|
|
||||||
%global mainrel 5
|
%global mainrel 1
|
||||||
%global prerpmver %(echo "%{?prever}" | sed -e 's|\\.||g')
|
%global prerpmver %(echo "%{?prever}" | sed -e 's|\\.||g')
|
||||||
|
|
||||||
%global gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
|
%global gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
|
||||||
@ -27,6 +27,7 @@ URL: http://nokogiri.rubyforge.org/nokogiri/
|
|||||||
Source0: http://gems.rubyforge.org/gems/%{gemname}-%{mainver}%{?prever}.gem
|
Source0: http://gems.rubyforge.org/gems/%{gemname}-%{mainver}%{?prever}.gem
|
||||||
# ./test/html/test_element_description.rb:62 fails, as usual......
|
# ./test/html/test_element_description.rb:62 fails, as usual......
|
||||||
# Patch0: rubygem-nokogiri-1.5.0.beta3-test-failure.patch
|
# Patch0: rubygem-nokogiri-1.5.0.beta3-test-failure.patch
|
||||||
|
Patch0: rubygem-nokogiri-1.5.0-allow-non-crosscompile.patch
|
||||||
BuildRequires: ruby(abi) = %{rubyabi}
|
BuildRequires: ruby(abi) = %{rubyabi}
|
||||||
BuildRequires: ruby(rubygems)
|
BuildRequires: ruby(rubygems)
|
||||||
##
|
##
|
||||||
@ -94,7 +95,7 @@ gem install \
|
|||||||
|
|
||||||
# patches
|
# patches
|
||||||
pushd .%{geminstdir}
|
pushd .%{geminstdir}
|
||||||
#%%patch0 -p1
|
%patch0 -p1
|
||||||
popd
|
popd
|
||||||
|
|
||||||
# Permission
|
# Permission
|
||||||
@ -139,7 +140,7 @@ done
|
|||||||
# cleanups
|
# cleanups
|
||||||
rm -rf %{buildroot}%{geminstdir}/ext/%{gemname}/
|
rm -rf %{buildroot}%{geminstdir}/ext/%{gemname}/
|
||||||
rm -rf %{buildroot}%{geminstdir}/tmp/
|
rm -rf %{buildroot}%{geminstdir}/tmp/
|
||||||
rm -f %{buildroot}%{geminstdir}/{.autotest,.require_paths}
|
rm -f %{buildroot}%{geminstdir}/{.autotest,.require_paths,.gemtest}
|
||||||
|
|
||||||
# The following method is completely copied from rubygem-gettext
|
# The following method is completely copied from rubygem-gettext
|
||||||
# spec file
|
# spec file
|
||||||
@ -238,6 +239,7 @@ popd
|
|||||||
%{ruby_sitearch}/%{gemname}/
|
%{ruby_sitearch}/%{gemname}/
|
||||||
%dir %{geminstdir}/
|
%dir %{geminstdir}/
|
||||||
%doc %{geminstdir}/[A-Z]*
|
%doc %{geminstdir}/[A-Z]*
|
||||||
|
%doc %{geminstdir}/nokogiri_help_responses.md
|
||||||
%exclude %{geminstdir}/Rakefile
|
%exclude %{geminstdir}/Rakefile
|
||||||
%{geminstdir}/bin/
|
%{geminstdir}/bin/
|
||||||
%{geminstdir}/lib/
|
%{geminstdir}/lib/
|
||||||
@ -253,7 +255,7 @@ popd
|
|||||||
%files doc
|
%files doc
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{geminstdir}/Rakefile
|
%{geminstdir}/Rakefile
|
||||||
%{geminstdir}/deps.rip
|
#%%{geminstdir}/deps.rip
|
||||||
#%%{geminstdir}/spec/
|
#%%{geminstdir}/spec/
|
||||||
%{geminstdir}/tasks/
|
%{geminstdir}/tasks/
|
||||||
%{geminstdir}/test/
|
%{geminstdir}/test/
|
||||||
@ -266,6 +268,12 @@ popd
|
|||||||
%{ruby_sitelib}/xsd/
|
%{ruby_sitelib}/xsd/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 18 2012 Mamoru Tasaka <mtasaka@fedoraproject.org> - 1.5.0-1
|
||||||
|
- 1.5.0
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.0-0.5.beta4.1
|
||||||
|
- F-17: Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
* Sun Jun 26 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 1.5.0-0.5.beta4
|
* Sun Jun 26 2011 Mamoru Tasaka <mtasaka@fedoraproject.org> - 1.5.0-0.5.beta4
|
||||||
- Remove unneeded patch
|
- Remove unneeded patch
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user