1.14.3
SPDX confirmed
This commit is contained in:
parent
c83119a48b
commit
56379ffefd
@ -1,26 +0,0 @@
|
||||
--- nokogiri-1.5.0/Rakefile.debug 2012-01-18 16:23:02.472224272 +0900
|
||||
+++ nokogiri-1.5.0/Rakefile 2012-01-18 16:23:29.935430496 +0900
|
||||
@@ -83,14 +83,21 @@
|
||||
HOE.spec.files += ['lib/nokogiri/nokogiri.jar']
|
||||
end
|
||||
else
|
||||
- require 'tasks/cross_compile'
|
||||
+ do_cross_compile = true
|
||||
+ begin
|
||||
+ require 'tasks/cross_compile'
|
||||
+ rescue RuntimeError => e
|
||||
+ warn "WARNING: Could not perform some cross-compiling: #{e}"
|
||||
+ do_cross_compile = false
|
||||
+ end
|
||||
require "rake/extensiontask"
|
||||
|
||||
- HOE.spec.files.reject! { |f| f =~ %r{^ext/java|\.jar$} }
|
||||
+ HOE.spec.files.reject! { |f| f =~ %r{^ext/java|\.jar$} } if do_cross_compile
|
||||
|
||||
Rake::ExtensionTask.new("nokogiri", HOE.spec) do |ext|
|
||||
ext.lib_dir = File.join(*['lib', 'nokogiri', ENV['FAT_DIR']].compact)
|
||||
ext.config_options << ENV['EXTOPTS']
|
||||
+ next unless do_cross_compile
|
||||
ext.cross_compile = true
|
||||
ext.cross_platform = ["x86-mswin32-60", "x86-mingw32"]
|
||||
ext.cross_config_options << "--with-xml2-include=#{File.join($recipes[:libxml2].path, 'include', 'libxml2')}"
|
@ -1,4 +1,4 @@
|
||||
%global mainver 1.14.2
|
||||
%global mainver 1.14.3
|
||||
#%%global prever .rc4
|
||||
|
||||
%global baserelease 1
|
||||
@ -27,9 +27,6 @@ Source0: https://rubygems.org/gems/%{gem_name}-%{mainver}%{?prever}.gem
|
||||
# %%{SOURCE2} %%{name} %%{version}
|
||||
Source1: rubygem-%{gem_name}-%{version}%{?prever}-full.tar.gz
|
||||
Source2: nokogiri-create-full-tarball.sh
|
||||
# ./test/html/test_element_description.rb:62 fails, as usual......
|
||||
# Patch0: rubygem-nokogiri-1.5.0.beta3-test-failure.patch
|
||||
#Patch0: rubygem-nokogiri-1.5.0-allow-non-crosscompile.patch
|
||||
# Shut down libxml2 version unmatching warning
|
||||
Patch0: %{name}-1.11.0.rc4-shutdown-libxml2-warning.patch
|
||||
BuildRequires: ruby(release)
|
||||
@ -60,16 +57,6 @@ correctly implemented CSS3 selector support as well as XPath support.
|
||||
Nokogiri also features an Hpricot compatibility layer to help ease the change
|
||||
to using correct CSS and XPath.
|
||||
|
||||
%if 0
|
||||
%package jruby
|
||||
Summary: JRuby support for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description jruby
|
||||
This package contains JRuby support for %{name}.
|
||||
%endif
|
||||
|
||||
|
||||
%package doc
|
||||
Summary: Documentation for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
@ -92,7 +79,7 @@ This package provides non-Gem support for %{gem_name}.
|
||||
mv ../%{gem_name}-%{version}.gemspec .
|
||||
|
||||
# patches
|
||||
%patch0 -p1
|
||||
%patch -P0 -p1
|
||||
|
||||
# remove bundled external libraries
|
||||
sed -i \
|
||||
@ -122,10 +109,10 @@ sed -i \
|
||||
gumbo-parser/src/Makefile \
|
||||
-e 's|^\(CFLAGS.*=.*\)$|\1 -fPIC|'
|
||||
|
||||
%build
|
||||
# Ummm...
|
||||
env LANG=C.UTF-8 gem build %{gem_name}-%{version}.gemspec
|
||||
|
||||
%build
|
||||
# 1.6.0 needs this
|
||||
export NOKOGIRI_USE_SYSTEM_LIBRARIES=yes
|
||||
|
||||
@ -186,6 +173,7 @@ pushd %{buildroot}%{gem_instdir}
|
||||
rm -rf \
|
||||
Gemfile* \
|
||||
Rakefile \
|
||||
Vagrantfile \
|
||||
dependencies.yml \
|
||||
ext \
|
||||
*gemspec \
|
||||
@ -260,7 +248,9 @@ popd
|
||||
%{gem_extdir_mri}/
|
||||
|
||||
%dir %{gem_instdir}/
|
||||
%doc %{gem_instdir}/[A-Z]*
|
||||
%license %{gem_instdir}/LICENSE*.md
|
||||
%doc %{gem_instdir}/CHANGELOG.md
|
||||
%doc %{gem_instdir}/README.md
|
||||
|
||||
%{gem_instdir}/bin/
|
||||
%{gem_instdir}/lib/
|
||||
@ -268,15 +258,23 @@ popd
|
||||
%dir %{gem_instdir}/gumbo-parser
|
||||
%dir %{gem_instdir}/gumbo-parser/src
|
||||
%doc %{gem_instdir}/gumbo-parser/[A-Z]*
|
||||
%doc %{gem_instdir}/gumbo-parser/src/README.md
|
||||
%license %{gem_instdir}/gumbo-parser/src/README.md
|
||||
|
||||
%{gem_dir}/specifications/%{gem_name}-%{mainver}%{?prever}.gemspec
|
||||
|
||||
%files doc
|
||||
%defattr(-,root,root,-)
|
||||
%{gem_dir}/doc/%{gem_name}-%{mainver}%{?prever}/
|
||||
%doc %{gem_instdir}/CODE_OF_CONDUCT.md
|
||||
%doc %{gem_instdir}/CONTRIBUTING.md
|
||||
%doc %{gem_instdir}/ROADMAP.md
|
||||
%doc %{gem_instdir}/SECURITY.md
|
||||
%doc %{gem_dir}/doc/%{gem_name}-%{mainver}%{?prever}/
|
||||
|
||||
%changelog
|
||||
* Wed Apr 12 2023 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.14.3-1
|
||||
- 1.14.3
|
||||
- SPDX confirmed
|
||||
|
||||
* Tue Feb 14 2023 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.14.2-1
|
||||
- 1.14.2
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (nokogiri-1.14.2.gem) = b905cdc7988b1f0fb273d6ab5d1ba889c124cd2441730d15df5517d7860bdb6626460bfde7f16a81fa41c8bff29b17fd2a3f9bc3a34d188a45bc155137a45c3c
|
||||
SHA512 (rubygem-nokogiri-1.14.2-full.tar.gz) = 84208b9ccb99c415510137bc8398eb0a39bc7235f9b728b14bb1d880b7ca5e3703ebe84170ba749868fe212d4a2f8b14479da50ed12bf143a9e2e5b446a63ad3
|
||||
SHA512 (nokogiri-1.14.3.gem) = 1883ec99c2a72c16987bba4f5d8f81a67fa79a3492325db04457cf0667cc41eb3188a54130776cee2d962b545a8bc2df61e0244628bafb2bc10f0f3f7c48b364
|
||||
SHA512 (rubygem-nokogiri-1.14.3-full.tar.gz) = 5291551955ccb8746210518ceca7bbeaf8619b4d0a11ea8d294db7edbc1457298a097b5767048e24cf298c5150a9cf1c7c29c2f20febc0749b0dface87064ad8
|
||||
|
Loading…
Reference in New Issue
Block a user