Merge remote-tracking branch 'fedora/master' into private-jaruga-stream-ruby-2.5
This commit is contained in:
commit
cdb192b83e
7
.gitignore
vendored
7
.gitignore
vendored
@ -0,0 +1,7 @@
|
||||
/mysql2-0.3.13.gem
|
||||
/mysql2-0.3.15.gem
|
||||
/mysql2-0.3.16.gem
|
||||
/mysql2-0.4.0.gem
|
||||
/mysql2-0.4.4.gem
|
||||
/mysql2-0.4.8.gem
|
||||
/mysql2-0.4.10.gem
|
@ -0,0 +1,15 @@
|
||||
diff --git a/spec/mysql2/statement_spec.rb b/spec/mysql2/statement_spec.rb
|
||||
index 50b2e99..3db7886 100644
|
||||
--- a/spec/mysql2/statement_spec.rb
|
||||
+++ b/spec/mysql2/statement_spec.rb
|
||||
@@ -731,7 +731,6 @@ RSpec.describe Mysql2::Statement do
|
||||
|
||||
it 'should return number of rows affected by an insert' do
|
||||
stmt = @client.prepare 'INSERT INTO lastIdTest (blah) VALUES (?)'
|
||||
- expect(stmt.affected_rows).to eq 0
|
||||
stmt.execute 1
|
||||
expect(stmt.affected_rows).to eq 1
|
||||
end
|
||||
--
|
||||
2.14.3
|
||||
|
@ -0,0 +1,162 @@
|
||||
From 235eaa482ce2cfa0dfbe1e4e7123d1a1f6bbf136 Mon Sep 17 00:00:00 2001
|
||||
From: Jun Aruga <junaruga@users.noreply.github.com>
|
||||
Date: Sat, 25 Nov 2017 20:10:10 +0100
|
||||
Subject: [PATCH 1/2] Suppress Fixnum and Bignum warnings on Ruby 2.4. (#907)
|
||||
|
||||
---
|
||||
spec/mysql2/client_spec.rb | 8 ++++----
|
||||
spec/mysql2/result_spec.rb | 12 ++++++------
|
||||
spec/mysql2/statement_spec.rb | 12 ++++++------
|
||||
spec/spec_helper.rb | 4 ++++
|
||||
4 files changed, 20 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/spec/mysql2/client_spec.rb b/spec/mysql2/client_spec.rb
|
||||
index dfb92a2..9de040b 100644
|
||||
--- a/spec/mysql2/client_spec.rb
|
||||
+++ b/spec/mysql2/client_spec.rb
|
||||
@@ -572,7 +572,7 @@ RSpec.describe Mysql2::Client do
|
||||
end
|
||||
|
||||
it "#socket should return a Fixnum (file descriptor from C)" do
|
||||
- expect(@client.socket).to be_an_instance_of(Fixnum)
|
||||
+ expect(@client.socket).to be_an_instance_of(0.class)
|
||||
expect(@client.socket).not_to eql(0)
|
||||
end
|
||||
|
||||
@@ -852,7 +852,7 @@ RSpec.describe Mysql2::Client do
|
||||
info = @client.info
|
||||
expect(info).to be_an_instance_of(Hash)
|
||||
expect(info).to have_key(:id)
|
||||
- expect(info[:id]).to be_an_instance_of(Fixnum)
|
||||
+ expect(info[:id]).to be_an_instance_of(0.class)
|
||||
expect(info).to have_key(:version)
|
||||
expect(info[:version]).to be_an_instance_of(String)
|
||||
end
|
||||
@@ -883,7 +883,7 @@ RSpec.describe Mysql2::Client do
|
||||
server_info = @client.server_info
|
||||
expect(server_info).to be_an_instance_of(Hash)
|
||||
expect(server_info).to have_key(:id)
|
||||
- expect(server_info[:id]).to be_an_instance_of(Fixnum)
|
||||
+ expect(server_info[:id]).to be_an_instance_of(0.class)
|
||||
expect(server_info).to have_key(:version)
|
||||
expect(server_info[:version]).to be_an_instance_of(String)
|
||||
end
|
||||
@@ -974,7 +974,7 @@ RSpec.describe Mysql2::Client do
|
||||
end
|
||||
|
||||
it "#thread_id should be a Fixnum" do
|
||||
- expect(@client.thread_id).to be_an_instance_of(Fixnum)
|
||||
+ expect(@client.thread_id).to be_an_instance_of(0.class)
|
||||
end
|
||||
|
||||
it "should respond to #ping" do
|
||||
diff --git a/spec/mysql2/result_spec.rb b/spec/mysql2/result_spec.rb
|
||||
index c8e26c5..e8ee8d0 100644
|
||||
--- a/spec/mysql2/result_spec.rb
|
||||
+++ b/spec/mysql2/result_spec.rb
|
||||
@@ -204,7 +204,7 @@ RSpec.describe Mysql2::Result do
|
||||
end
|
||||
|
||||
it "should return Fixnum for a TINYINT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['tiny_int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['tiny_int_test'].class)
|
||||
expect(@test_result['tiny_int_test']).to eql(1)
|
||||
end
|
||||
|
||||
@@ -248,27 +248,27 @@ RSpec.describe Mysql2::Result do
|
||||
end
|
||||
|
||||
it "should return Fixnum for a SMALLINT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['small_int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['small_int_test'].class)
|
||||
expect(@test_result['small_int_test']).to eql(10)
|
||||
end
|
||||
|
||||
it "should return Fixnum for a MEDIUMINT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['medium_int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['medium_int_test'].class)
|
||||
expect(@test_result['medium_int_test']).to eql(10)
|
||||
end
|
||||
|
||||
it "should return Fixnum for an INT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['int_test'].class)
|
||||
expect(@test_result['int_test']).to eql(10)
|
||||
end
|
||||
|
||||
it "should return Fixnum for a BIGINT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['big_int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['big_int_test'].class)
|
||||
expect(@test_result['big_int_test']).to eql(10)
|
||||
end
|
||||
|
||||
it "should return Fixnum for a YEAR value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['year_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['year_test'].class)
|
||||
expect(@test_result['year_test']).to eql(2009)
|
||||
end
|
||||
|
||||
diff --git a/spec/mysql2/statement_spec.rb b/spec/mysql2/statement_spec.rb
|
||||
index e0fccad..50b2e99 100644
|
||||
--- a/spec/mysql2/statement_spec.rb
|
||||
+++ b/spec/mysql2/statement_spec.rb
|
||||
@@ -372,7 +372,7 @@ RSpec.describe Mysql2::Statement do
|
||||
end
|
||||
|
||||
it "should return Fixnum for a TINYINT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['tiny_int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['tiny_int_test'].class)
|
||||
expect(@test_result['tiny_int_test']).to eql(1)
|
||||
end
|
||||
|
||||
@@ -420,27 +420,27 @@ RSpec.describe Mysql2::Statement do
|
||||
end
|
||||
|
||||
it "should return Fixnum for a SMALLINT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['small_int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['small_int_test'].class)
|
||||
expect(@test_result['small_int_test']).to eql(10)
|
||||
end
|
||||
|
||||
it "should return Fixnum for a MEDIUMINT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['medium_int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['medium_int_test'].class)
|
||||
expect(@test_result['medium_int_test']).to eql(10)
|
||||
end
|
||||
|
||||
it "should return Fixnum for an INT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['int_test'].class)
|
||||
expect(@test_result['int_test']).to eql(10)
|
||||
end
|
||||
|
||||
it "should return Fixnum for a BIGINT value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['big_int_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['big_int_test'].class)
|
||||
expect(@test_result['big_int_test']).to eql(10)
|
||||
end
|
||||
|
||||
it "should return Fixnum for a YEAR value" do
|
||||
- expect([Fixnum, Bignum]).to include(@test_result['year_test'].class)
|
||||
+ expect(num_classes).to include(@test_result['year_test'].class)
|
||||
expect(@test_result['year_test']).to eql(2009)
|
||||
end
|
||||
|
||||
diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
|
||||
index 53c098a..045e783 100644
|
||||
--- a/spec/spec_helper.rb
|
||||
+++ b/spec/spec_helper.rb
|
||||
@@ -36,6 +36,10 @@ RSpec.configure do |config|
|
||||
end
|
||||
end
|
||||
|
||||
+ def num_classes
|
||||
+ 0.class == Integer ? [Integer] : [Fixnum, Bignum]
|
||||
+ end
|
||||
+
|
||||
config.before :each do
|
||||
@client = new_client
|
||||
end
|
||||
--
|
||||
2.14.3
|
||||
|
@ -0,0 +1,37 @@
|
||||
diff --git a/ext/mysql2/result.c b/ext/mysql2/result.c
|
||||
index ccb49a5..67f75be 100644
|
||||
--- a/ext/mysql2/result.c
|
||||
+++ b/ext/mysql2/result.c
|
||||
@@ -278,12 +278,12 @@ static void rb_mysql_result_alloc_result_buffers(VALUE self, MYSQL_FIELD *fields
|
||||
wrapper->result_buffers[i].buffer_length = sizeof(signed char);
|
||||
break;
|
||||
case MYSQL_TYPE_SHORT: // short int
|
||||
+ case MYSQL_TYPE_YEAR: // short int
|
||||
wrapper->result_buffers[i].buffer = xcalloc(1, sizeof(short int));
|
||||
wrapper->result_buffers[i].buffer_length = sizeof(short int);
|
||||
break;
|
||||
case MYSQL_TYPE_INT24: // int
|
||||
case MYSQL_TYPE_LONG: // int
|
||||
- case MYSQL_TYPE_YEAR: // int
|
||||
wrapper->result_buffers[i].buffer = xcalloc(1, sizeof(int));
|
||||
wrapper->result_buffers[i].buffer_length = sizeof(int);
|
||||
break;
|
||||
@@ -413,6 +413,7 @@ static VALUE rb_mysql_result_fetch_row_stmt(VALUE self, MYSQL_FIELD * fields, co
|
||||
}
|
||||
break;
|
||||
case MYSQL_TYPE_SHORT: // short int
|
||||
+ case MYSQL_TYPE_YEAR: // short int
|
||||
if (result_buffer->is_unsigned) {
|
||||
val = UINT2NUM(*((unsigned short int*)result_buffer->buffer));
|
||||
} else {
|
||||
@@ -421,7 +422,6 @@ static VALUE rb_mysql_result_fetch_row_stmt(VALUE self, MYSQL_FIELD * fields, co
|
||||
break;
|
||||
case MYSQL_TYPE_INT24: // int
|
||||
case MYSQL_TYPE_LONG: // int
|
||||
- case MYSQL_TYPE_YEAR: // int
|
||||
if (result_buffer->is_unsigned) {
|
||||
val = UINT2NUM(*((unsigned int*)result_buffer->buffer));
|
||||
} else {
|
||||
--
|
||||
2.14.3
|
||||
|
@ -0,0 +1,15 @@
|
||||
diff --git a/ext/mysql2/client.c b/ext/mysql2/client.c
|
||||
index 665147a2..482f1877 100644
|
||||
--- a/ext/mysql2/client.c
|
||||
+++ b/ext/mysql2/client.c
|
||||
@@ -872,8 +872,8 @@ static VALUE _mysql_client_options(VALUE self, int opt, VALUE value) {
|
||||
break;
|
||||
|
||||
case MYSQL_OPT_LOCAL_INFILE:
|
||||
- intval = (value == Qfalse ? 0 : 1);
|
||||
- retval = &intval;
|
||||
+ boolval = (value == Qfalse ? 0 : 1);
|
||||
+ retval = &boolval;
|
||||
break;
|
||||
|
||||
case MYSQL_OPT_RECONNECT:
|
250
rubygem-mysql2.spec
Normal file
250
rubygem-mysql2.spec
Normal file
@ -0,0 +1,250 @@
|
||||
# build with tests?
|
||||
%bcond_without tests
|
||||
|
||||
# Generated from mysql2-0.3.11.gem by gem2rpm -*- rpm-spec -*-
|
||||
%global gem_name mysql2
|
||||
|
||||
Name: rubygem-%{gem_name}
|
||||
Version: 0.4.10
|
||||
Release: 4%{?dist}
|
||||
Summary: A simple, fast Mysql library for Ruby, binding to libmysql
|
||||
License: MIT
|
||||
URL: http://github.com/brianmario/mysql2
|
||||
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
|
||||
# Fix a client option local_infile not enabled
|
||||
# with mariadb-connector-c 3.0.2 on big endian environment.
|
||||
# Temporary patch until mariadb-connector-c version 3.0.3 released.
|
||||
# https://github.com/brianmario/mysql2/pull/914
|
||||
# https://github.com/MariaDB/mariadb-connector-c/commit/434b67e
|
||||
Patch0: rubygem-mysql2-0.4.10-mariadb-connector-c-3.0.2-fix-wrong-local-infile-on-big-endian.patch
|
||||
# Fix YEAR type wrong value on big endian environment.
|
||||
# https://github.com/brianmario/mysql2/pull/921
|
||||
Patch1: rubygem-mysql2-0.4.10-fix-wrong-type-year-value-on-big-endian.patch
|
||||
# Suppress Fixnum and Bignum warnings on Ruby 2.4.
|
||||
# https://github.com/brianmario/mysql2/commit/0e4fcc3
|
||||
Patch2: rubygem-mysql2-0.4.10-Suppress-Fixnum-and-Bignum-warnings-on-Ruby2.4.patch
|
||||
# Skip test to prepare statement and no query on MariaDB 10.2.
|
||||
# https://github.com/brianmario/mysql2/commit/a2fadb6
|
||||
Patch3: rubygem-mysql2-0.4.10-Skip-statement-and-no-query-test-on-MariaDB-10.2.patch
|
||||
|
||||
# Required in lib/mysql2.rb
|
||||
Requires: rubygem(bigdecimal)
|
||||
BuildRequires: ruby(release)
|
||||
BuildRequires: rubygems-devel
|
||||
BuildRequires: ruby-devel
|
||||
BuildRequires: mariadb-connector-c-devel
|
||||
%if %{with tests}
|
||||
BuildRequires: mariadb-server
|
||||
BuildRequires: rubygem(rspec)
|
||||
# Used in mysql_install_db
|
||||
BuildRequires: %{_bindir}/hostname
|
||||
BuildRequires: rubygem(bigdecimal)
|
||||
# Used in spec/em/em_spec.rb
|
||||
BuildRequires: rubygem(eventmachine)
|
||||
%endif
|
||||
|
||||
%description
|
||||
The Mysql2 gem is meant to serve the extremely common use-case of
|
||||
connecting, querying and iterating on results. Some database libraries
|
||||
out there serve as direct 1:1 mappings of the already complex C API\'s
|
||||
available. This one is not.
|
||||
|
||||
|
||||
%package doc
|
||||
Summary: Documentation for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
|
||||
%description doc
|
||||
Documentation for %{name}
|
||||
|
||||
%prep
|
||||
gem unpack %{SOURCE0}
|
||||
|
||||
%setup -q -D -T -n %{gem_name}-%{version}
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
|
||||
|
||||
%build
|
||||
# Create the gem as gem install only works on a gem file
|
||||
gem build %{gem_name}.gemspec
|
||||
|
||||
# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
|
||||
# by default, so that we can move it into the buildroot in %%install
|
||||
%gem_install
|
||||
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}%{gem_dir}
|
||||
cp -pa .%{gem_dir}/* \
|
||||
%{buildroot}%{gem_dir}/
|
||||
|
||||
mkdir -p %{buildroot}%{gem_extdir_mri}
|
||||
cp -a .%{gem_extdir_mri}/* %{buildroot}%{gem_extdir_mri}/
|
||||
|
||||
# Prevent dangling symlink in -debuginfo.
|
||||
rm -rf %{buildroot}%{gem_instdir}/ext
|
||||
|
||||
|
||||
%if %{with tests}
|
||||
%check
|
||||
pushd .%{gem_instdir}
|
||||
|
||||
TOP_DIR=$(pwd)
|
||||
# Use testing port because the standard mysqld port 3306 is occupied.
|
||||
MYSQL_TEST_PORT="13306"
|
||||
MYSQL_TEST_USER=$(id -un)
|
||||
MYSQL_TEST_DATA_DIR="${TOP_DIR}/data"
|
||||
MYSQL_TEST_SOCKET="${TOP_DIR}/mysql.sock"
|
||||
MYSQL_TEST_LOG="${TOP_DIR}/mysql.log"
|
||||
MYSQL_TEST_PID_FILE="${TOP_DIR}/mysql.pid"
|
||||
|
||||
mkdir "${MYSQL_TEST_DATA_DIR}"
|
||||
mysql_install_db \
|
||||
--datadir="${MYSQL_TEST_DATA_DIR}" \
|
||||
--log-error="${MYSQL_TEST_LOG}"
|
||||
|
||||
%{_libexecdir}/mysqld \
|
||||
--datadir="${MYSQL_TEST_DATA_DIR}" \
|
||||
--log-error="${MYSQL_TEST_LOG}" \
|
||||
--socket="${MYSQL_TEST_SOCKET}" \
|
||||
--pid-file="${MYSQL_TEST_PID_FILE}" \
|
||||
--port="${MYSQL_TEST_PORT}" \
|
||||
--ssl &
|
||||
|
||||
for i in $(seq 10); do
|
||||
sleep 1
|
||||
if grep -q 'ready for connections.' "${MYSQL_TEST_LOG}"; then
|
||||
break
|
||||
fi
|
||||
echo "Waiting connections... ${i}"
|
||||
done
|
||||
|
||||
# See https://github.com/brianmario/mysql2/blob/master/.travis_setup.sh
|
||||
mysql -u root \
|
||||
-e 'CREATE DATABASE /*M!50701 IF NOT EXISTS */ test' \
|
||||
-S "${MYSQL_TEST_SOCKET}" \
|
||||
-P "${MYSQL_TEST_PORT}"
|
||||
|
||||
# See https://github.com/brianmario/mysql2/blob/master/tasks/rspec.rake
|
||||
cat <<EOF > spec/configuration.yml
|
||||
root:
|
||||
host: localhost
|
||||
username: root
|
||||
password:
|
||||
database: test
|
||||
port: ${MYSQL_TEST_PORT}
|
||||
socket: ${MYSQL_TEST_SOCKET}
|
||||
|
||||
user:
|
||||
host: localhost
|
||||
username: ${MYSQL_TEST_USER}
|
||||
password:
|
||||
database: mysql2_test
|
||||
port: ${MYSQL_TEST_PORT}
|
||||
socket: ${MYSQL_TEST_SOCKET}
|
||||
EOF
|
||||
|
||||
cat "%{PATCH2}" | patch -p1
|
||||
cat "%{PATCH3}" | patch -p1
|
||||
|
||||
# Comment out an issue (maybe test specified issue) for coredump or
|
||||
# SystemStackError: stack level too deep.
|
||||
sed -i '/^ it "returns error messages and sql state in Encoding.default_internal if set" do$/,/^ end$/ s/^/#/' \
|
||||
spec/mysql2/error_spec.rb
|
||||
|
||||
# This test would require changes in host configuration.
|
||||
sed -i '/^ it "should be able to connect via SSL options" do$/,/^ end$/ s/^/#/' \
|
||||
spec/mysql2/client_spec.rb
|
||||
|
||||
rspec -Ilib:%{buildroot}%{gem_extdir_mri} -f d spec
|
||||
popd
|
||||
|
||||
# Clean up
|
||||
kill "$(cat "${MYSQL_TEST_PID_FILE}")"
|
||||
|
||||
%endif
|
||||
|
||||
%files
|
||||
%dir %{gem_instdir}
|
||||
%{gem_libdir}
|
||||
%{gem_extdir_mri}
|
||||
%exclude %{gem_cache}
|
||||
%{gem_spec}
|
||||
%exclude %{gem_instdir}/support
|
||||
%license %{gem_instdir}/LICENSE
|
||||
|
||||
%files doc
|
||||
%doc %{gem_docdir}
|
||||
%doc %{gem_instdir}/README.md
|
||||
%doc %{gem_instdir}/CHANGELOG.md
|
||||
%{gem_instdir}/examples
|
||||
%{gem_instdir}/spec
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.10-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 0.4.10-3
|
||||
- Rebuilt for switch to libxcrypt
|
||||
|
||||
* Thu Jan 04 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 0.4.10-2
|
||||
- F-28: rebuild for ruby25
|
||||
|
||||
* Thu Nov 23 2017 Jun Aruga <jaruga@redhat.com> - 0.4.10-1
|
||||
- New upstream release 0.4.10
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu Jul 13 2017 Adam Williamson <awilliam@redhat.com> - 0.4.8-1
|
||||
- New upstream release 0.4.8 (builds against MariaDB 10.2)
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Jan 11 2017 Vít Ondruch <vondruch@redhat.com> - 0.4.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.4
|
||||
|
||||
* Thu Jun 09 2016 Miroslav Suchý <msuchy@redhat.com> - 0.4.4-1
|
||||
- New upstream release 0.4.4
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Jan 11 2016 Vít Ondruch <vondruch@redhat.com> - 0.4.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.3
|
||||
|
||||
* Tue Sep 8 2015 Miroslav Suchý <msuchy@redhat.com> 0.4.0-1
|
||||
- rebase to mysql2-0.4.0
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.16-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Jan 16 2015 Vít Ondruch <vondruch@redhat.com> - 0.3.16-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.2
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.16-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.16-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon May 26 2014 Miroslav Suchý <msuchy@redhat.com> 0.3.16-1
|
||||
- rebase to mysql2-0.3.16
|
||||
|
||||
* Tue Apr 15 2014 Vít Ondruch <vondruch@redhat.com> - 0.3.15-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.1
|
||||
|
||||
* Tue Feb 11 2014 Miroslav Suchý <msuchy@redhat.com> 0.3.15-2
|
||||
- rebase to mysql2-0.3.15
|
||||
|
||||
* Wed Sep 11 2013 Alexander Chernyakhovsky <achernya@mit.edu> - 0.3.13-1
|
||||
- Initial package
|
Loading…
Reference in New Issue
Block a user