Initial import
This commit is contained in:
commit
8b6b5dd5c0
71
asciidoctor-disable-use-of-pending.patch
Normal file
71
asciidoctor-disable-use-of-pending.patch
Normal file
@ -0,0 +1,71 @@
|
||||
diff --git a/test/attributes_test.rb b/test/attributes_test.rb
|
||||
index ac2d6a5..ae28d9c 100644
|
||||
--- a/test/attributes_test.rb
|
||||
+++ b/test/attributes_test.rb
|
||||
@@ -67,7 +67,7 @@ context "Attributes" do
|
||||
end
|
||||
|
||||
test "renders attribute until it's deleted" do
|
||||
- pending "Not working yet (will require adding element-specific attributes or early attr substitution during parsing)"
|
||||
+ #pending "Not working yet (will require adding element-specific attributes or early attr substitution during parsing)"
|
||||
# html = render_string(":foo: bar\nCrossing the {foo}\n\n:foo!:\nBelly up to the {foo}")
|
||||
# result = Nokogiri::HTML(html)
|
||||
# assert_match /Crossing the bar/, result.css("p").first.content.strip
|
||||
@@ -84,15 +84,15 @@ context "Attributes" do
|
||||
html = render_string(":foo: bar\nThis is a +++{foo}+++ day.")
|
||||
result = Nokogiri::HTML(html)
|
||||
#assert_equal 'This is a {foo} day.', result.css('p').first.content.strip
|
||||
- pending "Don't yet have inline passthrough working"
|
||||
+ #pending "Don't yet have inline passthrough working"
|
||||
end
|
||||
|
||||
test "doesn't substitute attributes inside code blocks" do
|
||||
- pending "whut?"
|
||||
+ #pending "whut?"
|
||||
end
|
||||
|
||||
test "doesn't substitute attributes inside literal blocks" do
|
||||
- pending "whut?"
|
||||
+ #pending "whut?"
|
||||
end
|
||||
|
||||
context "Block attributes" do
|
||||
diff --git a/test/reader_test.rb b/test/reader_test.rb
|
||||
index 095d98f..af3912f 100644
|
||||
--- a/test/reader_test.rb
|
||||
+++ b/test/reader_test.rb
|
||||
@@ -45,7 +45,7 @@ class ReaderTest < Test::Unit::TestCase
|
||||
end
|
||||
|
||||
def test_grab_lines_until
|
||||
- pending "Not tested yet"
|
||||
+ #pending "Not tested yet"
|
||||
end
|
||||
|
||||
def test_sanitize_attribute_name
|
||||
diff --git a/test/test_helper.rb b/test/test_helper.rb
|
||||
index b9cad90..f7b099b 100644
|
||||
--- a/test/test_helper.rb
|
||||
+++ b/test/test_helper.rb
|
||||
@@ -6,7 +6,7 @@ require "#{File.expand_path(File.dirname(__FILE__))}/../lib/asciidoctor.rb"
|
||||
require 'mocha'
|
||||
require 'htmlentities'
|
||||
require 'nokogiri'
|
||||
-require 'pending'
|
||||
+#require 'pending'
|
||||
|
||||
ENV['SUPPRESS_DEBUG'] ||= 'true'
|
||||
|
||||
diff --git a/test/text_test.rb b/test/text_test.rb
|
||||
index f892398..ca1e955 100644
|
||||
--- a/test/text_test.rb
|
||||
+++ b/test/text_test.rb
|
||||
@@ -2,7 +2,7 @@ require 'test_helper'
|
||||
|
||||
context "Text" do
|
||||
test 'escaped text markup' do
|
||||
- pending "Not done yet"
|
||||
+ #pending "Not done yet"
|
||||
end
|
||||
|
||||
test "line breaks" do
|
13
asciidoctor-modify-mocha-import.patch
Normal file
13
asciidoctor-modify-mocha-import.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/test/test_helper.rb b/test/test_helper.rb
|
||||
index a6577e8..b9cad90 100644
|
||||
--- a/test/test_helper.rb
|
||||
+++ b/test/test_helper.rb
|
||||
@@ -3,7 +3,7 @@ require 'test/unit'
|
||||
|
||||
require "#{File.expand_path(File.dirname(__FILE__))}/../lib/asciidoctor.rb"
|
||||
|
||||
-require 'mocha/setup'
|
||||
+require 'mocha'
|
||||
require 'htmlentities'
|
||||
require 'nokogiri'
|
||||
require 'pending'
|
100
rubygem-asciidoctor.spec
Normal file
100
rubygem-asciidoctor.spec
Normal file
@ -0,0 +1,100 @@
|
||||
%global gem_name asciidoctor
|
||||
%global rubyabi 1.9.1
|
||||
|
||||
Summary: AsciiDoc implementation in Ruby that uses Tilt-supported templates to generate output
|
||||
Name: rubygem-%{gem_name}
|
||||
Version: 0.0.8
|
||||
Release: 1%{?dist}
|
||||
Group: Development/Languages
|
||||
License: MIT
|
||||
URL: http://github.com/erebor/asciidoctor
|
||||
Source0: http://rubygems.org/gems/%{gem_name}-%{version}.gem
|
||||
Patch0: asciidoctor-modify-mocha-import.patch
|
||||
Patch1: asciidoctor-disable-use-of-pending.patch
|
||||
Requires: ruby(abi) = %{rubyabi}
|
||||
Requires: ruby(rubygems)
|
||||
Requires: ruby
|
||||
Requires: rubygem(tilt)
|
||||
BuildRequires: ruby(abi) = %{rubyabi}
|
||||
BuildRequires: rubygems-devel
|
||||
BuildRequires: ruby
|
||||
BuildRequires: rubygem(tilt)
|
||||
BuildRequires: rubygem(mocha)
|
||||
BuildRequires: rubygem(nokogiri)
|
||||
BuildRequires: rubygem(htmlentities)
|
||||
# using patch to comment lines where pending is used
|
||||
#BuildRequires: rubygem(pending)
|
||||
BuildArch: noarch
|
||||
Provides: rubygem(%{gem_name}) = %{version}
|
||||
|
||||
%description
|
||||
A pure-Ruby processor for parsing AsciiDoc documents or strings and rendering
|
||||
them as HTML and other formats using Tilt-based templates.
|
||||
|
||||
%package doc
|
||||
Summary: Documentation for %{name}
|
||||
Group: Documentation
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
|
||||
%description doc
|
||||
Documentation for %{name}
|
||||
|
||||
%prep
|
||||
%setup -q -c -T
|
||||
mkdir -p .%{gem_dir}
|
||||
gem install --local --install-dir .%{gem_dir} \
|
||||
--bindir .%{_bindir} \
|
||||
--force %{SOURCE0}
|
||||
%patch0 -p1 -d .%{gem_instdir}
|
||||
%patch1 -p1 -d .%{gem_instdir}
|
||||
|
||||
%build
|
||||
# TODO
|
||||
#cd .%{gem_instdir}
|
||||
#rdoc --charset=UTF-8
|
||||
#cd -
|
||||
|
||||
%check
|
||||
echo %{gem_spec}
|
||||
LANG=en_US.utf8 testrb2 -b .%{gem_instdir} -Ilib test
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}%{gem_dir}
|
||||
cp -a .%{gem_dir}/* \
|
||||
%{buildroot}%{gem_dir}/
|
||||
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
cp -a .%{_bindir}/* \
|
||||
%{buildroot}%{_bindir}/
|
||||
|
||||
find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x
|
||||
|
||||
# TODO
|
||||
#mkdir -p %{buildroot}%{gem_docdir}
|
||||
#cp -a .%{gem_instdir}/doc/* \
|
||||
# %{buildroot}%{gem_docdir}/
|
||||
|
||||
%files
|
||||
%dir %{gem_instdir}
|
||||
%{_bindir}/asciidoctor
|
||||
%{gem_instdir}/bin
|
||||
%{gem_libdir}
|
||||
%exclude %{gem_cache}
|
||||
%exclude %{gem_instdir}/Rakefile
|
||||
%exclude %{gem_instdir}/test
|
||||
%exclude %{gem_instdir}/noof.rb
|
||||
%exclude %{gem_instdir}/%{gem_name}.gemspec
|
||||
# following exclude is necessary if you have rubygems-bundler installed
|
||||
%exclude /usr/share/gems/bin/ruby_noexec_wrapper
|
||||
%{gem_spec}
|
||||
|
||||
%files doc
|
||||
# TODO
|
||||
#%doc %{gem_docdir}
|
||||
%doc %{gem_instdir}/LICENSE
|
||||
%doc %{gem_instdir}/README.asciidoc
|
||||
|
||||
%changelog
|
||||
* Wed Dec 19 2012 Dan Allen <dan.j.allen@gmail.com> - 0.0.8-1
|
||||
- Initial package
|
Loading…
Reference in New Issue
Block a user