3cd2ea3699
* Upgrade to Ruby 3.0.7. Resolves: RHEL-35740 The released Ruby 3.0.5 includes the following fix. * Fix HTTP response splitting in CGI. Resolves: RHEL-35741 The released Ruby 3.0.6 includes the following fixes. * Fix ReDoS vulnerability in URI. Resolves: RHEL-35742 * Fix ReDoS vulnerability in Time. Resolves: RHEL-35743 The released Ruby 3.0.7 includes the following fixes. * Fix buffer overread vulnerability in StringIO. Resolves: RHEL-35744 * Fix RCE vulnerability with .rdoc_options in RDoc. Resolves: RHEL-35746 * Fix arbitrary memory address read vulnerability with Regex search. Resolves: RHEL-35747 Replaced the patch ruby-3.0.3-ext-openssl-extconf.rb-require-OpenSSL-version-1.0.1.patch with the tiny patch ruby-ext-openssl-extconf.rb-ignore-OpenSSL-version-check.patch not using the reverse logic. Because it was hard to maintain the patch file, when the included file was updated on the upstream. Added the following patches. * Fix net-http test errors due to expired certificate. The patch ruby-3.4.0-ruby-net-http-Renew-test-certificates.patch was copied from the part on the Fedora rawhide <05a6c9c8f3
>. * Fix `TestNetHTTPS#test_session_reuse_but_expire` test failure cause. The patch ruby-3.3.1-Fix-test-session-reuse-but-expire.patch was copied from the part on Fedora rawhide <a34f33bc50
>. As a reference, the part comes from Fedora ruby-3.3 branch <99d21ecc4c
>.
81 lines
2.2 KiB
Diff
81 lines
2.2 KiB
Diff
From e24d97c938c481450ed80ec83e5399595946c1ae Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
|
Date: Fri, 8 Feb 2013 22:48:41 +0100
|
|
Subject: [PATCH] Prevent duplicated paths when empty version string is
|
|
configured.
|
|
|
|
---
|
|
configure.ac | 3 ++-
|
|
loadpath.c | 12 ++++++++++++
|
|
tool/mkconfig.rb | 2 +-
|
|
3 files changed, 15 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c42436c23d..d261ea57b5 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3913,7 +3913,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
|
ruby_version_dir=/'${ruby_version_dir_name}'
|
|
|
|
if test -z "${ruby_version_dir_name}"; then
|
|
- AC_MSG_ERROR([No ruby version, No place for bundled libraries])
|
|
+ unset ruby_version_dir
|
|
+ AC_DEFINE(RUBY_LIB_VERSION_BLANK, 1)
|
|
fi
|
|
|
|
rubylibdir='${rubylibprefix}'${ruby_version_dir}
|
|
diff --git a/loadpath.c b/loadpath.c
|
|
index 9160031..0d4d953 100644
|
|
--- a/loadpath.c
|
|
+++ b/loadpath.c
|
|
@@ -65,21 +65,33 @@ const char ruby_initial_load_paths[] =
|
|
RUBY_SEARCH_PATH "\0"
|
|
#endif
|
|
#ifndef NO_RUBY_SITE_LIB
|
|
+#ifdef RUBY_LIB_VERSION_BLANK
|
|
+ RUBY_SITE_LIB "\0"
|
|
+#else
|
|
RUBY_SITE_LIB2 "\0"
|
|
+#endif
|
|
#ifdef RUBY_THINARCH
|
|
RUBY_SITE_ARCH_LIB_FOR(RUBY_THINARCH) "\0"
|
|
#endif
|
|
RUBY_SITE_ARCH_LIB_FOR(RUBY_SITEARCH) "\0"
|
|
+#ifndef RUBY_LIB_VERSION_BLANK
|
|
RUBY_SITE_LIB "\0"
|
|
#endif
|
|
+#endif
|
|
|
|
#ifndef NO_RUBY_VENDOR_LIB
|
|
+#ifdef RUBY_LIB_VERSION_BLANK
|
|
+ RUBY_VENDOR_LIB "\0"
|
|
+#else
|
|
RUBY_VENDOR_LIB2 "\0"
|
|
+#endif
|
|
#ifdef RUBY_THINARCH
|
|
RUBY_VENDOR_ARCH_LIB_FOR(RUBY_THINARCH) "\0"
|
|
#endif
|
|
RUBY_VENDOR_ARCH_LIB_FOR(RUBY_SITEARCH) "\0"
|
|
+#ifndef RUBY_LIB_VERSION_BLANK
|
|
RUBY_VENDOR_LIB "\0"
|
|
+#endif
|
|
#endif
|
|
|
|
RUBY_LIB "\0"
|
|
diff --git a/tool/mkconfig.rb b/tool/mkconfig.rb
|
|
index 07076d4..35e6c3c 100755
|
|
--- a/tool/mkconfig.rb
|
|
+++ b/tool/mkconfig.rb
|
|
@@ -114,7 +114,7 @@
|
|
val = val.gsub(/\$(?:\$|\{?(\w+)\}?)/) {$1 ? "$(#{$1})" : $&}.dump
|
|
case name
|
|
when /^prefix$/
|
|
- val = "(TOPDIR || DESTDIR + #{val})"
|
|
+ val = "(((TOPDIR && TOPDIR.empty?) ? nil : TOPDIR) || DESTDIR + #{val})"
|
|
when /^ARCH_FLAG$/
|
|
val = "arch_flag || #{val}" if universal
|
|
when /^UNIVERSAL_ARCHNAMES$/
|
|
--
|
|
1.9.0
|
|
|