9ad4115fe3
* Upgrade to Ruby 3.0.7.
Resolves: RHEL-36189
The released Ruby 3.0.5 includes the following fix.
* Fix HTTP response splitting in CGI.
Resolves: RHEL-36193
The released Ruby 3.0.6 includes the following fixes.
* Fix ReDoS vulnerability in URI.
Resolves: RHEL-36196
* Fix ReDoS vulnerability in Time.
Resolves: RHEL-36205
The released Ruby 3.0.7 includes the following fixes.
* Fix buffer overread vulnerability in StringIO.
Resolves: RHEL-36198
* Fix RCE vulnerability with .rdoc_options in RDoc.
Resolves: RHEL-36200
* Fix arbitrary memory address read vulnerability with Regex search.
Resolves: RHEL-36203
Added the following patch.
* Fix net-http test errors due to expired certificate.
The patch ruby-3.4.0-ruby-net-http-Renew-test-certificates.patch was copied
from the part on the Fedora rawhide
<05a6c9c8f3
>.
26 lines
772 B
Diff
26 lines
772 B
Diff
From 2089cab72b38d6d5e7ba2b596e41014209acad30 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
|
Date: Mon, 19 Nov 2012 14:37:28 +0100
|
|
Subject: [PATCH] Always use i386.
|
|
|
|
---
|
|
configure.ac | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 3c13076b82..93af30321d 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3977,6 +3977,8 @@ AC_SUBST(vendorarchdir)dnl
|
|
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
|
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
|
|
|
+target_cpu=`echo $target_cpu | sed s/i.86/i386/`
|
|
+
|
|
AS_IF([test "${universal_binary-no}" = yes ], [
|
|
arch="universal-${target_os}"
|
|
AS_IF([test "${rb_cv_architecture_available}" = yes], [
|
|
--
|
|
1.8.3.1
|
|
|