9ad4115fe3
* Upgrade to Ruby 3.0.7.
Resolves: RHEL-36189
The released Ruby 3.0.5 includes the following fix.
* Fix HTTP response splitting in CGI.
Resolves: RHEL-36193
The released Ruby 3.0.6 includes the following fixes.
* Fix ReDoS vulnerability in URI.
Resolves: RHEL-36196
* Fix ReDoS vulnerability in Time.
Resolves: RHEL-36205
The released Ruby 3.0.7 includes the following fixes.
* Fix buffer overread vulnerability in StringIO.
Resolves: RHEL-36198
* Fix RCE vulnerability with .rdoc_options in RDoc.
Resolves: RHEL-36200
* Fix arbitrary memory address read vulnerability with Regex search.
Resolves: RHEL-36203
Added the following patch.
* Fix net-http test errors due to expired certificate.
The patch ruby-3.4.0-ruby-net-http-Renew-test-certificates.patch was copied
from the part on the Fedora rawhide
<05a6c9c8f3
>.
29 lines
787 B
Diff
29 lines
787 B
Diff
From 07c666ba5c3360dd6f43605a8ac7c85c99c1721f Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
|
Date: Tue, 1 Oct 2013 12:22:40 +0200
|
|
Subject: [PATCH] Allow to configure libruby.so placement.
|
|
|
|
---
|
|
configure.ac | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index d261ea57b5..3c13076b82 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3267,6 +3267,11 @@ AS_IF([test ${multiarch+set}], [
|
|
])
|
|
|
|
archlibdir='${libdir}/${arch}'
|
|
+AC_ARG_WITH(archlibdir,
|
|
+ AS_HELP_STRING([--with-archlibdir=DIR],
|
|
+ [prefix for libruby [[LIBDIR/ARCH]]]),
|
|
+ [archlibdir="$withval"])
|
|
+
|
|
sitearchlibdir='${libdir}/${sitearch}'
|
|
archincludedir='${includedir}/${arch}'
|
|
sitearchincludedir='${includedir}/${sitearch}'
|
|
--
|
|
2.22.0
|
|
|