8475ee2d69
Rebased from Fedora rawhide, commit: 6b2ff68
.
* Except "Fix FTBFS due to an incompatible load" as that is included as
a separate commit to highlight the change.
* Add missing `rubygem-` prefix for bundled provide of 'connection_pool'.
* Pass ldflags to gem install via CONFIGURE_ARGS
* Remove IRB dependency from rubygem-rdoc.
* Fix flaky excon test suite.
* Properly support DWARF5 debug information.
Related: rhbz#1920533
* Bundle OpenSSL into StdLib.
* Fix SEGFAULT in rubygem-shoulda-matchers test suite.
* Provide `gem.build_complete` file for binary gems.
* Re-enable test suite.
* ruby-default-gems have to depend on rubygem(io-console) due to
reline.
* Fix SEGFAULT preventing rubygem-unicode to build on armv7hl.
* Add support for reworked RubyGems plugins.
* Use proper path for plugin wrappers.
* Extract RSS and REXML into separate subpackages, because they were
moved from default gems to bundled gems.
* Drop Net::Telnet and XMLRPC packages, because they were dropped from
Ruby.
Resolves: rhbz#1938942
29 lines
787 B
Diff
29 lines
787 B
Diff
From 07c666ba5c3360dd6f43605a8ac7c85c99c1721f Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
|
Date: Tue, 1 Oct 2013 12:22:40 +0200
|
|
Subject: [PATCH] Allow to configure libruby.so placement.
|
|
|
|
---
|
|
configure.ac | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index d261ea57b5..3c13076b82 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3211,6 +3211,11 @@ AS_IF([test ${multiarch+set}], [
|
|
])
|
|
|
|
archlibdir='${libdir}/${arch}'
|
|
+AC_ARG_WITH(archlibdir,
|
|
+ AS_HELP_STRING([--with-archlibdir=DIR],
|
|
+ [prefix for libruby [[LIBDIR/ARCH]]]),
|
|
+ [archlibdir="$withval"])
|
|
+
|
|
sitearchlibdir='${libdir}/${sitearch}'
|
|
archincludedir='${includedir}/${arch}'
|
|
sitearchincludedir='${includedir}/${sitearch}'
|
|
--
|
|
2.22.0
|
|
|