23b8352956
Fix buffer overread vulnerability in StringIO.
(CVE-2024-27280)
Fix RCE vulnerability with .rdoc_options in RDoc.
(CVE-2024-27281)
Fix Arbitrary memory address read vulnerability with Regex search.
(CVE-2024-27282)
Ruby bundled NKF, add appropriate `bundled` provide and test
License review and clarification
Upgrade by merging Fedora changes up to commit:
ff5301a5f3
Resolves: RHEL-33976
Resolves: RHEL-34130
Resolves: RHEL-34122
Resolves: RHEL-33872
23 lines
759 B
Diff
23 lines
759 B
Diff
From 2089cab72b38d6d5e7ba2b596e41014209acad30 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
|
Date: Mon, 19 Nov 2012 14:37:28 +0100
|
|
Subject: [PATCH] Always use i386.
|
|
|
|
---
|
|
configure.ac | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 3c13076b82..93af30321d 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4376,6 +4376,8 @@ AC_SUBST(vendorarchdir)dnl
|
|
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
|
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
|
|
|
+target_cpu=`echo $target_cpu | sed s/i.86/i386/`
|
|
+
|
|
AS_IF([test "${universal_binary-no}" = yes ], [
|
|
arch="universal-${target_os}"
|
|
AS_IF([test "${rb_cv_architecture_available}" = yes], [
|