Remove debug messages (rhbz#2040278)
This commit is contained in:
parent
fe9531dc3a
commit
facd063cdb
22
remove-debug-messages.patch
Normal file
22
remove-debug-messages.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff --git rtkit-0.11/rtkit-daemon.c~ rtkit-0.11/rtkit-daemon.c
|
||||
index fdff7f63dc..5f108d842d 100644
|
||||
--- rtkit-0.11/rtkit-daemon.c~
|
||||
+++ rtkit-0.11/rtkit-daemon.c
|
||||
@@ -1485,17 +1485,6 @@ static DBusHandlerResult dbus_handler(DBusConnection *c, DBusMessage *m, void *u
|
||||
} else
|
||||
return DBUS_HANDLER_RESULT_NOT_YET_HANDLED;
|
||||
|
||||
- syslog(LOG_DEBUG, "Supervising %u threads of %u processes of %u users.\n",
|
||||
- n_total_threads,
|
||||
- n_total_processes,
|
||||
- n_users);
|
||||
-
|
||||
- sd_notifyf(0,
|
||||
- "STATUS=Supervising %u threads of %u processes of %u users.",
|
||||
- n_total_threads,
|
||||
- n_total_processes,
|
||||
- n_users);
|
||||
-
|
||||
finish:
|
||||
if (r) {
|
||||
assert_se(dbus_connection_send(c, r, NULL));
|
16
rtkit.spec
16
rtkit.spec
@ -14,16 +14,18 @@ BuildRequires: libcap-devel
|
||||
BuildRequires: polkit-devel
|
||||
BuildRequires: autoconf automake libtool
|
||||
Source0: http://0pointer.de/public/%{name}-%{version}.tar.xz
|
||||
Patch1: rtkit-mq_getattr.patch
|
||||
Patch2: 0001-SECURITY-Pass-uid-of-caller-to-polkit.patch
|
||||
Patch3: rtkit-controlgroup.patch
|
||||
Patch: rtkit-mq_getattr.patch
|
||||
Patch: 0001-SECURITY-Pass-uid-of-caller-to-polkit.patch
|
||||
Patch: rtkit-controlgroup.patch
|
||||
|
||||
# Temporarily disable -Werror=format-security since it breaks the build
|
||||
Patch4: format-security.patch
|
||||
Patch: format-security.patch
|
||||
|
||||
Patch5: 0001-Fix-borked-error-check.patch
|
||||
Patch6: 0001-systemd-update-sd-daemon.-ch.patch
|
||||
Patch7: 0002-Remove-bundled-copy-of-sd-daemon.-ch.patch
|
||||
Patch: 0001-Fix-borked-error-check.patch
|
||||
Patch: 0001-systemd-update-sd-daemon.-ch.patch
|
||||
Patch: 0002-Remove-bundled-copy-of-sd-daemon.-ch.patch
|
||||
|
||||
Patch: remove-debug-messages.patch
|
||||
|
||||
%description
|
||||
RealtimeKit is a D-Bus system service that changes the
|
||||
|
Loading…
Reference in New Issue
Block a user