d569da167a
Revert the change to use a newer default kernel Resolves: RHEL-8967 Signed-off-by: John Kacur <jkacur@redhat.com>
69 lines
2.1 KiB
Diff
69 lines
2.1 KiB
Diff
From 47fc74501aa5741fd5dcb2d04aacd857d3d87740 Mon Sep 17 00:00:00 2001
|
|
From: John Kacur <jkacur@redhat.com>
|
|
Date: Wed, 25 Oct 2023 10:59:28 -0400
|
|
Subject: [PATCH] Revert "rteval: Change the default kernel to compile to
|
|
linux-6.1.8"
|
|
|
|
This reverts commit 0f39c69610985b07ce2aa41142d2f0481da8e3a4.
|
|
|
|
For RHEL-8.x we want to continue using the same kernel for kcompile
|
|
|
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
|
---
|
|
Makefile | 2 +-
|
|
rteval/modules/loads/kcompile.py | 4 ++--
|
|
rteval/rteval.conf | 2 +-
|
|
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index b73e8c13f3e5..176435a8cfd5 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -18,7 +18,7 @@ PREFIX := /usr
|
|
DATADIR := $(DESTDIR)/$(PREFIX)/share
|
|
LOADDIR := loadsource
|
|
|
|
-KLOAD := $(LOADDIR)/linux-6.1.8.tar.xz
|
|
+KLOAD := $(LOADDIR)/linux-5.18.1.tar.xz
|
|
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
|
|
LOADS := $(KLOAD) $(BLOAD)
|
|
|
|
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
|
|
index 8be79ce630d5..e531b60754e9 100644
|
|
--- a/rteval/modules/loads/kcompile.py
|
|
+++ b/rteval/modules/loads/kcompile.py
|
|
@@ -20,7 +20,7 @@ expand_cpulist = CpuList.expand_cpulist
|
|
compress_cpulist = CpuList.compress_cpulist
|
|
nonisolated_cpulist = CpuList.nonisolated_cpulist
|
|
|
|
-DEFAULT_KERNEL_PREFIX = "linux-6.1"
|
|
+DEFAULT_KERNEL_PREFIX = "linux-5.18"
|
|
|
|
class KBuildJob:
|
|
'''Class to manage a build job bound to a particular node'''
|
|
@@ -334,7 +334,7 @@ class Kcompile(CommandLineLoad):
|
|
|
|
def ModuleParameters():
|
|
return {"source": {"descr": "Source tar ball",
|
|
- "default": "linux-6.1.8.tar.xz",
|
|
+ "default": "linux-5.18.1.tar.xz",
|
|
"metavar": "TARBALL"},
|
|
"jobspercore": {"descr": "Number of working threads per core",
|
|
"default": 2,
|
|
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
|
|
index 79e28032dc6b..1a8d0afd2642 100644
|
|
--- a/rteval/rteval.conf
|
|
+++ b/rteval/rteval.conf
|
|
@@ -18,7 +18,7 @@ dbench: external
|
|
stressng: module
|
|
|
|
[kcompile]
|
|
-source: linux-6.1.8.xz
|
|
+source: linux-5.18.1.xz
|
|
jobspercore: 2
|
|
|
|
[hackbench]
|
|
--
|
|
2.41.0
|
|
|