- rteval: Make changes to use linux-5.13.2 - Fixes to spec file from previous inadvertent changes Signed-off-by: John Kacur <jkacur@redhat.com>
66 lines
2.0 KiB
Diff
66 lines
2.0 KiB
Diff
From 936bdd7aff0e46a1509ee4844cba279053ca97c7 Mon Sep 17 00:00:00 2001
|
|
From: John Kacur <jkacur@redhat.com>
|
|
Date: Fri, 16 Jul 2021 11:33:19 -0400
|
|
Subject: [PATCH] rteval: Update to using the linux-5.13.2 kernel
|
|
|
|
Update to using the linux-5.13.2 kernel
|
|
|
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
|
---
|
|
Makefile | 2 +-
|
|
rteval/modules/loads/kcompile.py | 4 ++--
|
|
rteval/rteval.conf | 2 +-
|
|
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index d942858d5a62..36d40867883c 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -17,7 +17,7 @@ PREFIX := /usr
|
|
DATADIR := $(DESTDIR)/$(PREFIX)/share
|
|
LOADDIR := loadsource
|
|
|
|
-KLOAD := $(LOADDIR)/linux-5.7.tar.xz
|
|
+KLOAD := $(LOADDIR)/linux-5.13.2.tar.xz
|
|
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
|
|
LOADS := $(KLOAD) $(BLOAD)
|
|
|
|
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
|
|
index e747b9f17782..d1955c7aee3d 100644
|
|
--- a/rteval/modules/loads/kcompile.py
|
|
+++ b/rteval/modules/loads/kcompile.py
|
|
@@ -35,7 +35,7 @@ from rteval.Log import Log
|
|
from rteval.misc import expand_cpulist, compress_cpulist
|
|
from rteval.systopology import SysTopology
|
|
|
|
-kernel_prefix = "linux-5.7"
|
|
+kernel_prefix = "linux-5.13"
|
|
|
|
class KBuildJob:
|
|
'''Class to manage a build job bound to a particular node'''
|
|
@@ -302,7 +302,7 @@ class Kcompile(CommandLineLoad):
|
|
|
|
def ModuleParameters():
|
|
return {"source": {"descr": "Source tar ball",
|
|
- "default": "linux-5.7.tar.xz",
|
|
+ "default": "linux-5.13.2.tar.xz",
|
|
"metavar": "TARBALL"},
|
|
"jobspercore": {"descr": "Number of working threads per core",
|
|
"default": 2,
|
|
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
|
|
index 6065d2e909f6..7ce6ef0b5acc 100644
|
|
--- a/rteval/rteval.conf
|
|
+++ b/rteval/rteval.conf
|
|
@@ -18,7 +18,7 @@ dbench: external
|
|
stressng: module
|
|
|
|
[kcompile]
|
|
-source: linux-5.7.xz
|
|
+source: linux-5.13.2.xz
|
|
jobspercore: 2
|
|
|
|
[hackbench]
|
|
--
|
|
2.31.1
|
|
|