rteval/SOURCES/rteval-Change-the-default-k...

67 lines
2.1 KiB
Diff

From e20fb6d6f1a357afe5ae7ba63d5bb340e0041156 Mon Sep 17 00:00:00 2001
From: John Kacur <jkacur@redhat.com>
Date: Tue, 7 Jun 2022 11:29:18 -0400
Subject: [PATCH] rteval: Change the default kernel to compile to linux-5.18.1
rteval compiles the linux kernel as a load
Change the default kernel that rteval compiles to linux-5.18.1
Signed-off-by: John Kacur <jkacur@redhat.com>
---
Makefile | 2 +-
rteval/modules/loads/kcompile.py | 4 ++--
rteval/rteval.conf | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
index 36d40867883c..ffea8a05f460 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ PREFIX := /usr
DATADIR := $(DESTDIR)/$(PREFIX)/share
LOADDIR := loadsource
-KLOAD := $(LOADDIR)/linux-5.13.2.tar.xz
+KLOAD := $(LOADDIR)/linux-5.18.1.tar.xz
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
LOADS := $(KLOAD) $(BLOAD)
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
index 3d9b882d8810..2c93c794fe75 100644
--- a/rteval/modules/loads/kcompile.py
+++ b/rteval/modules/loads/kcompile.py
@@ -36,7 +36,7 @@ from rteval.Log import Log
from rteval.misc import expand_cpulist, compress_cpulist
from rteval.systopology import SysTopology
-DEFAULT_KERNEL_PREFIX = "linux-5.13"
+DEFAULT_KERNEL_PREFIX = "linux-5.18"
class KBuildJob:
'''Class to manage a build job bound to a particular node'''
@@ -326,7 +326,7 @@ class Kcompile(CommandLineLoad):
def ModuleParameters():
return {"source": {"descr": "Source tar ball",
- "default": "linux-5.13.2.tar.xz",
+ "default": "linux-5.18.1.tar.xz",
"metavar": "TARBALL"},
"jobspercore": {"descr": "Number of working threads per core",
"default": 2,
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
index aa0a53bcfc63..1a8d0afd2642 100644
--- a/rteval/rteval.conf
+++ b/rteval/rteval.conf
@@ -18,7 +18,7 @@ dbench: external
stressng: module
[kcompile]
-source: linux-5.13.2.xz
+source: linux-5.18.1.xz
jobspercore: 2
[hackbench]
--
2.36.1