rteval/SOURCES/rteval-Use-linux-5.7-in-kco...

81 lines
2.6 KiB
Diff

From a377b5ae936ecf355da348883c4e143860d781ab Mon Sep 17 00:00:00 2001
From: John Kacur <jkacur@redhat.com>
Date: Thu, 23 Jul 2020 15:00:01 -0400
Subject: [PATCH] rteval: Use linux-5.7 in kcompile
Use linux-5.7 in kcompile since it has some fixes for code that breaks
newer tools.
Signed-off-by: John Kacur <jkacur@redhat.com>
---
Makefile | 2 +-
rteval-loads.spec | 2 +-
rteval/modules/loads/kcompile.py | 4 ++--
rteval/rteval.conf | 2 +-
4 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/Makefile b/Makefile
index 479bda8d8674..b11ecec75e42 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ PREFIX := /usr
DATADIR := $(DESTDIR)/$(PREFIX)/share
LOADDIR := loadsource
-KLOAD := $(LOADDIR)/linux-5.1.tar.xz
+KLOAD := $(LOADDIR)/linux-5.7.tar.xz
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
LOADS := $(KLOAD) $(BLOAD)
diff --git a/rteval-loads.spec b/rteval-loads.spec
index 6b21dc9e6b36..710729914465 100644
--- a/rteval-loads.spec
+++ b/rteval-loads.spec
@@ -5,7 +5,7 @@ Summary: Source files for rteval loads
Group: Development/Tools
License: GPLv2
URL: http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rteval.git
-Source0: https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.1.tar.xz
+Source0: https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.7.tar.xz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: gcc binutils make kernel-headers
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
index 3973c2af6bce..597f40238cf1 100644
--- a/rteval/modules/loads/kcompile.py
+++ b/rteval/modules/loads/kcompile.py
@@ -32,7 +32,7 @@ from rteval.Log import Log
from rteval.misc import expand_cpulist, compress_cpulist
from rteval.systopology import SysTopology
-kernel_prefix = "linux-5.1"
+kernel_prefix = "linux-5.7"
class KBuildJob:
'''Class to manage a build job bound to a particular node'''
@@ -294,7 +294,7 @@ class Kcompile(CommandLineLoad):
def ModuleParameters():
return {"source": {"descr": "Source tar ball",
- "default": "linux-5.1.tar.xz",
+ "default": "linux-5.7.tar.xz",
"metavar": "TARBALL"},
"jobspercore": {"descr": "Number of working threads per core",
"default": 2,
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
index db0b8ef005b6..6065d2e909f6 100644
--- a/rteval/rteval.conf
+++ b/rteval/rteval.conf
@@ -18,7 +18,7 @@ dbench: external
stressng: module
[kcompile]
-source: linux-5.1.xz
+source: linux-5.7.xz
jobspercore: 2
[hackbench]
--
2.26.2