rteval/SOURCES/Makefile-Remove-non-distuti...

52 lines
1.6 KiB
Diff

From 3a432a4217e1d91bb1dbc2e0503942997c40f370 Mon Sep 17 00:00:00 2001
From: Scott Wood <swood@redhat.com>
Date: Mon, 6 Apr 2020 17:14:03 -0500
Subject: [PATCH 01/17] Makefile: Remove non-distutil install leftovers
setup.py installs into /usr/local by default, but the makefile
is still creating directories in /usr that it doesn't install
anything into. Worse, the uninstall target removes things
from /usr rather than what was installed by "make install".
Signed-off-by: Scott Wood <swood@redhat.com>
Signed-off-by: John Kacur <jkacur@redhat.com>
---
Makefile | 14 --------------
1 file changed, 14 deletions(-)
diff --git a/Makefile b/Makefile
index f784ba778bc3..f91e6e06a9a4 100644
--- a/Makefile
+++ b/Makefile
@@ -15,9 +15,6 @@ XMLRPCDIR := server
DESTDIR :=
PREFIX := /usr
DATADIR := $(DESTDIR)/$(PREFIX)/share
-CONFDIR := $(DESTDIR)/etc
-MANDIR := $(DESTDIR)/$(PREFIX)/share/man
-PYLIB := $(DESTDIR)$(shell $(PYTHON) -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()')
LOADDIR := loadsource
KLOAD := $(LOADDIR)/linux-5.1.tar.xz
@@ -60,17 +57,6 @@ install_loads: $(LOADS)
installdirs:
[ -d $(DATADIR)/rteval ] || mkdir -p $(DATADIR)/rteval
- [ -d $(CONFDIR) ] || mkdir -p $(CONFDIR)
- [ -d $(MANDIR)/man8 ] || mkdir -p $(MANDIR)/man8
- [ -d $(PYLIB) ] || mkdir -p $(PYLIB)
- [ -d $(DESTDIR)/usr/bin ] || mkdir -p $(DESTDIR)/usr/bin
-
-uninstall:
- rm -f /usr/bin/rteval
- rm -f $(CONFDIR)/rteval.conf
- rm -f $(MANDIR)/man8/rteval.8.gz
- rm -rf $(PYLIB)/rteval
- rm -rf $(DATADIR)/rteval
tarfile: rteval-$(VERSION).tar.bz2
--
2.21.3