65 lines
2.0 KiB
Diff
65 lines
2.0 KiB
Diff
From 2d2e85c459d240926c99b1961bbef090aa80a1fc Mon Sep 17 00:00:00 2001
|
|
From: John Kacur <jkacur@redhat.com>
|
|
Date: Wed, 20 Dec 2023 17:22:22 -0500
|
|
Subject: [PATCH 1/2] rteval: Makefile: More rpm cleanups
|
|
|
|
Afer having removed the upstream specfile, there were still a few
|
|
references to rpms in the Makefile. These are not necessary because any
|
|
work with rpms can be done with modern rpm tools and are typically done
|
|
by distributions
|
|
|
|
Also test whether directory 'run' exists since it may have been removed
|
|
by make realclean, and create it if it does not
|
|
|
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
|
---
|
|
Makefile | 11 +++--------
|
|
1 file changed, 3 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index ee4cca555b95..b8bed643f760 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -31,6 +31,7 @@ load:
|
|
$(PYTHON) rteval-cmd --onlyload -D -L -v --workdir=./run --loaddir=$(HERE)/loadsource -f $(HERE)/rteval/rteval.conf -i $(HERE)/rteval
|
|
|
|
sysreport:
|
|
+ [ -d $(HERE)/run ] || mkdir run
|
|
$(PYTHON) rteval-cmd -D -v --workdir=$(HERE)/run --loaddir=$(HERE)/loadsource --duration=$(D) -i $(HERE)/rteval --sysreport
|
|
|
|
clean:
|
|
@@ -39,7 +40,7 @@ clean:
|
|
|
|
realclean: clean
|
|
[ -f $(XMLRPCDIR)/Makefile ] && make -C $(XMLRPCDIR) maintainer-clean || echo -n
|
|
- rm -rf run rpm
|
|
+ rm -rf run
|
|
|
|
install: install_loads install_rteval
|
|
|
|
@@ -73,13 +74,6 @@ rteval-xmlrpc-$(XMLRPCVER).tar.gz :
|
|
make distcheck
|
|
cp $(XMLRPCDIR)/rteval-xmlrpc-$(XMLRPCVER).tar.gz $(HERE)/
|
|
|
|
-rpm_prep:
|
|
- rm -rf rpm
|
|
- mkdir -p rpm/{BUILD,RPMS,SRPMS,SOURCES,SPECS}
|
|
-
|
|
-rpms rpm: rpm_prep rtevalrpm loadrpm
|
|
-
|
|
-
|
|
help:
|
|
@echo ""
|
|
@echo "rteval Makefile targets:"
|
|
@@ -88,6 +82,7 @@ help:
|
|
@echo " tarfile: create the source tarball"
|
|
@echo " install: install rteval locally"
|
|
@echo " clean: cleanup generated files"
|
|
+ @echo " realclean: Same as clean plus directory run"
|
|
@echo " sysreport: do a short testrun and generate sysreport data"
|
|
@echo " tags: generate a ctags file"
|
|
@echo " cleantags: remove the ctags file"
|
|
--
|
|
2.42.0
|
|
|