68 lines
2.1 KiB
Diff
68 lines
2.1 KiB
Diff
From 0f39c69610985b07ce2aa41142d2f0481da8e3a4 Mon Sep 17 00:00:00 2001
|
|
From: John Kacur <jkacur@redhat.com>
|
|
Date: Fri, 3 Feb 2023 16:13:09 -0500
|
|
Subject: [PATCH 8/8] rteval: Change the default kernel to compile to
|
|
linux-6.1.8
|
|
|
|
rteval compiles the linux kernel as a load
|
|
Change the default kernel that rteval compiles to linux-6.1.8
|
|
|
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
|
---
|
|
Makefile | 2 +-
|
|
rteval/modules/loads/kcompile.py | 4 ++--
|
|
rteval/rteval.conf | 2 +-
|
|
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index ffea8a05f460..81ca8242bbbe 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -17,7 +17,7 @@ PREFIX := /usr
|
|
DATADIR := $(DESTDIR)/$(PREFIX)/share
|
|
LOADDIR := loadsource
|
|
|
|
-KLOAD := $(LOADDIR)/linux-5.18.1.tar.xz
|
|
+KLOAD := $(LOADDIR)/linux-6.1.8.tar.xz
|
|
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
|
|
LOADS := $(KLOAD) $(BLOAD)
|
|
|
|
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
|
|
index 6faa686f81d0..35ee5cbbb52d 100644
|
|
--- a/rteval/modules/loads/kcompile.py
|
|
+++ b/rteval/modules/loads/kcompile.py
|
|
@@ -38,7 +38,7 @@ from rteval.systopology import CpuList, SysTopology
|
|
expand_cpulist = CpuList.expand_cpulist
|
|
compress_cpulist = CpuList.compress_cpulist
|
|
|
|
-DEFAULT_KERNEL_PREFIX = "linux-5.18"
|
|
+DEFAULT_KERNEL_PREFIX = "linux-6.1"
|
|
|
|
class KBuildJob:
|
|
'''Class to manage a build job bound to a particular node'''
|
|
@@ -349,7 +349,7 @@ class Kcompile(CommandLineLoad):
|
|
|
|
def ModuleParameters():
|
|
return {"source": {"descr": "Source tar ball",
|
|
- "default": "linux-5.18.1.tar.xz",
|
|
+ "default": "linux-6.1.8.tar.xz",
|
|
"metavar": "TARBALL"},
|
|
"jobspercore": {"descr": "Number of working threads per core",
|
|
"default": 2,
|
|
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
|
|
index 1a8d0afd2642..79e28032dc6b 100644
|
|
--- a/rteval/rteval.conf
|
|
+++ b/rteval/rteval.conf
|
|
@@ -18,7 +18,7 @@ dbench: external
|
|
stressng: module
|
|
|
|
[kcompile]
|
|
-source: linux-5.18.1.xz
|
|
+source: linux-6.1.8.xz
|
|
jobspercore: 2
|
|
|
|
[hackbench]
|
|
--
|
|
2.39.0
|
|
|