173d95e08e
Add patch to put stress-ng options in their own manpage section Change constant name earlystop TO EARLYSTOP Update the kcompile kernel to linux-6.12-rc4 Resolves: RHEL-63611 Signed-off-by: John Kacur <jkacur@redhat.com>
89 lines
2.8 KiB
Diff
89 lines
2.8 KiB
Diff
From d7dc1a05dd60c0fe2ab3edaaea3786a8be592ade Mon Sep 17 00:00:00 2001
|
|
From: John Kacur <jkacur@redhat.com>
|
|
Date: Tue, 22 Oct 2024 13:42:12 -0400
|
|
Subject: [PATCH 2/2] rteval: Update the kcompile kernel to linux-6.12-rc4
|
|
|
|
Update the kernel that rteval compiles as a load in the load module
|
|
kcompile
|
|
|
|
This kernel contains patches to address the fact that ENGINE API has
|
|
been deprecated since OpenSSL version 3.0. This is important because
|
|
some distros have been dropping the headers for the deprecated api
|
|
and this has been causing kcompile to fail, unless you supply a special
|
|
kernel with the patches to address this.
|
|
|
|
With this change the upstream kernel as is will work again.
|
|
|
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
|
---
|
|
Dockerfile | 2 +-
|
|
Makefile | 2 +-
|
|
rteval/modules/loads/kcompile.py | 4 ++--
|
|
rteval/rteval.conf | 2 +-
|
|
4 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Dockerfile b/Dockerfile
|
|
index f3ee516b57d5..b8f602b11703 100644
|
|
--- a/Dockerfile
|
|
+++ b/Dockerfile
|
|
@@ -1,7 +1,7 @@
|
|
# Use CentOS Stream 9 as base image
|
|
FROM centos:stream9
|
|
|
|
-ARG KERNEL_VERSION=linux-6.10.5.tar.xz
|
|
+ARG KERNEL_VERSION=linux-6.12-rc4.tar.gz
|
|
|
|
|
|
# Copy current directory to /opt/rteval/
|
|
diff --git a/Makefile b/Makefile
|
|
index e1a2bbba0373..a250b18611b4 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -14,7 +14,7 @@ PREFIX := /usr
|
|
DATADIR := $(DESTDIR)/$(PREFIX)/share
|
|
LOADDIR := loadsource
|
|
|
|
-KLOAD := $(LOADDIR)/linux-6.10.5.tar.xz
|
|
+KLOAD := $(LOADDIR)/linux-6.12-rc4.tar.gz
|
|
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
|
|
LOADS := $(KLOAD) $(BLOAD)
|
|
|
|
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
|
|
index 58c542201a1b..8a3a0e93fa14 100644
|
|
--- a/rteval/modules/loads/kcompile.py
|
|
+++ b/rteval/modules/loads/kcompile.py
|
|
@@ -21,7 +21,7 @@ expand_cpulist = cpulist_utils.expand_cpulist
|
|
compress_cpulist = cpulist_utils.compress_cpulist
|
|
nonisolated_cpulist = cpulist_utils.nonisolated_cpulist
|
|
|
|
-DEFAULT_KERNEL_PREFIX = "linux-6.10.5"
|
|
+DEFAULT_KERNEL_PREFIX = "linux-6.12-rc4"
|
|
|
|
class KBuildJob:
|
|
'''Class to manage a build job bound to a particular node'''
|
|
@@ -342,7 +342,7 @@ class Kcompile(CommandLineLoad):
|
|
|
|
def ModuleParameters():
|
|
return {"source": {"descr": "Source tar ball",
|
|
- "default": "linux-6.10.5.tar.xz",
|
|
+ "default": "linux-6.12-rc4.tar.gz",
|
|
"metavar": "TARBALL"},
|
|
"jobspercore": {"descr": "Number of working threads per core",
|
|
"default": 2,
|
|
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
|
|
index 0611c031c2a0..5a49040d980f 100644
|
|
--- a/rteval/rteval.conf
|
|
+++ b/rteval/rteval.conf
|
|
@@ -18,7 +18,7 @@ dbench: external
|
|
stressng: module
|
|
|
|
[kcompile]
|
|
-source: linux-6.10.5.xz
|
|
+source: linux-6.12-rc4.tar.gz
|
|
jobspercore: 2
|
|
|
|
[hackbench]
|
|
--
|
|
2.46.2
|
|
|