1e67c0e973
Add relative cpulists for measurements Convert CpuList class to a module Disable use of python-dmidecode Makefile: More rpm cleanups systopology: Fix incorrect test to invert a cpulist Minor improvements to CpuList class Refactor collapse_cpulist in systopology Added the tests dir Resolves: RHEL-30162 Signed-off-by: John Kacur <jkacur@redhat.com>
66 lines
2.1 KiB
Diff
66 lines
2.1 KiB
Diff
From c0ee73f00f6868e0ead5ace958a88a6a23db6ad3 Mon Sep 17 00:00:00 2001
|
|
From: John Kacur <jkacur@redhat.com>
|
|
Date: Thu, 9 Nov 2023 15:43:53 -0500
|
|
Subject: [PATCH] rteval: Change the default kernel for kcompile to linux-6.6.1
|
|
|
|
Change the default kernel for kcompile to linux-6.6.1
|
|
|
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
|
---
|
|
Makefile | 2 +-
|
|
rteval/modules/loads/kcompile.py | 4 ++--
|
|
rteval/rteval.conf | 2 +-
|
|
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index b73e8c13f3e5..14f74e087eff 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -18,7 +18,7 @@ PREFIX := /usr
|
|
DATADIR := $(DESTDIR)/$(PREFIX)/share
|
|
LOADDIR := loadsource
|
|
|
|
-KLOAD := $(LOADDIR)/linux-6.1.8.tar.xz
|
|
+KLOAD := $(LOADDIR)/linux-6.6.1.tar.xz
|
|
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
|
|
LOADS := $(KLOAD) $(BLOAD)
|
|
|
|
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
|
|
index 8be79ce630d5..0d025771e90e 100644
|
|
--- a/rteval/modules/loads/kcompile.py
|
|
+++ b/rteval/modules/loads/kcompile.py
|
|
@@ -20,7 +20,7 @@ expand_cpulist = CpuList.expand_cpulist
|
|
compress_cpulist = CpuList.compress_cpulist
|
|
nonisolated_cpulist = CpuList.nonisolated_cpulist
|
|
|
|
-DEFAULT_KERNEL_PREFIX = "linux-6.1"
|
|
+DEFAULT_KERNEL_PREFIX = "linux-6.6"
|
|
|
|
class KBuildJob:
|
|
'''Class to manage a build job bound to a particular node'''
|
|
@@ -334,7 +334,7 @@ class Kcompile(CommandLineLoad):
|
|
|
|
def ModuleParameters():
|
|
return {"source": {"descr": "Source tar ball",
|
|
- "default": "linux-6.1.8.tar.xz",
|
|
+ "default": "linux-6.6.1.tar.xz",
|
|
"metavar": "TARBALL"},
|
|
"jobspercore": {"descr": "Number of working threads per core",
|
|
"default": 2,
|
|
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
|
|
index 79e28032dc6b..a4aad33e264f 100644
|
|
--- a/rteval/rteval.conf
|
|
+++ b/rteval/rteval.conf
|
|
@@ -18,7 +18,7 @@ dbench: external
|
|
stressng: module
|
|
|
|
[kcompile]
|
|
-source: linux-6.1.8.xz
|
|
+source: linux-6.6.1.xz
|
|
jobspercore: 2
|
|
|
|
[hackbench]
|
|
--
|
|
2.41.0
|
|
|