rteval/SOURCES/rteval-setup.py-Open-byte-l...

29 lines
785 B
Diff

From b64537b1530b7918618f925ea7ccc3b119a8b471 Mon Sep 17 00:00:00 2001
From: John Kacur <jkacur@redhat.com>
Date: Wed, 30 May 2018 13:12:21 +0100
Subject: [PATCH] rteval: setup.py: Open byte like object
python3 differentiates between text and binary data
Signed-off-by: John Kacur <jkacur@redhat.com>
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index fc78a93c8793..95efa905f4d1 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ from dist import RTEVAL_VERSION
# Compress the man page, so distutil will only care for the compressed file
mangz = gzip.GzipFile('dist/rteval.8.gz', 'w', 9)
-man = open('doc/rteval.8', 'r')
+man = open('doc/rteval.8', 'rb')
mangz.writelines(man)
man.close()
mangz.close()
--
2.14.3