173d95e08e
Add patch to put stress-ng options in their own manpage section Change constant name earlystop TO EARLYSTOP Update the kcompile kernel to linux-6.12-rc4 Resolves: RHEL-63611 Signed-off-by: John Kacur <jkacur@redhat.com>
81 lines
2.5 KiB
Diff
81 lines
2.5 KiB
Diff
From 0e6fa19365330937d54132a3077d5d9961877546 Mon Sep 17 00:00:00 2001
|
|
From: John Kacur <jkacur@redhat.com>
|
|
Date: Sun, 18 Aug 2024 12:10:55 -0400
|
|
Subject: [PATCH 20/23] rteval: Upgrade load kernel to linux-6.10.5
|
|
|
|
The older kernel fails to compile on newer tool chains, so upgrade
|
|
the kernel that kcompile compiles as a load to linux-6.10.5
|
|
|
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
|
---
|
|
Dockerfile | 2 +-
|
|
Makefile | 2 +-
|
|
rteval/modules/loads/kcompile.py | 4 ++--
|
|
rteval/rteval.conf | 2 +-
|
|
4 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Dockerfile b/Dockerfile
|
|
index 45f6434777d4..f3ee516b57d5 100644
|
|
--- a/Dockerfile
|
|
+++ b/Dockerfile
|
|
@@ -1,7 +1,7 @@
|
|
# Use CentOS Stream 9 as base image
|
|
FROM centos:stream9
|
|
|
|
-ARG KERNEL_VERSION=linux-6.6.1.tar.xz
|
|
+ARG KERNEL_VERSION=linux-6.10.5.tar.xz
|
|
|
|
|
|
# Copy current directory to /opt/rteval/
|
|
diff --git a/Makefile b/Makefile
|
|
index d9a6b9f116ac..e1a2bbba0373 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -14,7 +14,7 @@ PREFIX := /usr
|
|
DATADIR := $(DESTDIR)/$(PREFIX)/share
|
|
LOADDIR := loadsource
|
|
|
|
-KLOAD := $(LOADDIR)/linux-6.6.1.tar.xz
|
|
+KLOAD := $(LOADDIR)/linux-6.10.5.tar.xz
|
|
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
|
|
LOADS := $(KLOAD) $(BLOAD)
|
|
|
|
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
|
|
index f7a9c0084805..80106812af0a 100644
|
|
--- a/rteval/modules/loads/kcompile.py
|
|
+++ b/rteval/modules/loads/kcompile.py
|
|
@@ -21,7 +21,7 @@ expand_cpulist = cpulist_utils.expand_cpulist
|
|
compress_cpulist = cpulist_utils.compress_cpulist
|
|
nonisolated_cpulist = cpulist_utils.nonisolated_cpulist
|
|
|
|
-DEFAULT_KERNEL_PREFIX = "linux-6.6"
|
|
+DEFAULT_KERNEL_PREFIX = "linux-6.10.5"
|
|
|
|
class KBuildJob:
|
|
'''Class to manage a build job bound to a particular node'''
|
|
@@ -334,7 +334,7 @@ class Kcompile(CommandLineLoad):
|
|
|
|
def ModuleParameters():
|
|
return {"source": {"descr": "Source tar ball",
|
|
- "default": "linux-6.6.1.tar.xz",
|
|
+ "default": "linux-6.10.5.tar.xz",
|
|
"metavar": "TARBALL"},
|
|
"jobspercore": {"descr": "Number of working threads per core",
|
|
"default": 2,
|
|
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
|
|
index a4aad33e264f..0611c031c2a0 100644
|
|
--- a/rteval/rteval.conf
|
|
+++ b/rteval/rteval.conf
|
|
@@ -18,7 +18,7 @@ dbench: external
|
|
stressng: module
|
|
|
|
[kcompile]
|
|
-source: linux-6.6.1.xz
|
|
+source: linux-6.10.5.xz
|
|
jobspercore: 2
|
|
|
|
[hackbench]
|
|
--
|
|
2.46.2
|
|
|