import rteval-3.3-6.el8

This commit is contained in:
CentOS Sources 2022-02-18 12:18:50 +00:00 committed by Stepan Oksanichenko
parent a6711d1095
commit fc978f7684
2 changed files with 42 additions and 2 deletions

View File

@ -0,0 +1,34 @@
From 14b0cff41f13602579fd708748eb8a2ad93db85b Mon Sep 17 00:00:00 2001
From: John Kacur <jkacur@redhat.com>
Date: Mon, 14 Feb 2022 22:09:21 -0500
Subject: [PATCH] rteval: If the user doesn't specify a cpumask, use the
inherited one
If the user doesn't specify a cpumask, then we need to use the inherited
one to match what cyclictest currently does
Signed-off-by: John Kacur <jkacur@redhat.com>
---
rteval/modules/measurement/cyclictest.py | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/rteval/modules/measurement/cyclictest.py b/rteval/modules/measurement/cyclictest.py
index 4ca310bf7490..8fdd5341794a 100644
--- a/rteval/modules/measurement/cyclictest.py
+++ b/rteval/modules/measurement/cyclictest.py
@@ -216,6 +216,12 @@ class Cyclictest(rtevalModulePrototype):
self.__sparse = True
else:
self.__cpus = online_cpus()
+ # Get the cpuset from the environment
+ cpuset = os.sched_getaffinity(0)
+ # Convert the elements to strings
+ cpuset = [str(c) for c in cpuset]
+ # Only include cpus that are in the cpuset
+ self.__cpus = [c for c in self.__cpus if c in cpuset]
# Sort the list of cpus to align with the order reported by cyclictest
self.__cpus.sort(key=int)
--
2.34.1

View File

@ -1,6 +1,6 @@
Name: rteval
Version: 3.3
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Utility to evaluate system suitability for RT Linux
Group: Development/Tools
@ -36,6 +36,7 @@ Patch1: rteval-Fix-test-misses-threshold-assignment.patch
Patch2: rteval-Fix-Popen-for-python3.6-where-text-True-is-no.patch
Patch3: rteval-Increase-default-buckets-from-2000-to-3500.patch
Patch4: rteval-Don-t-restrict-measurement-threads-to-inherit.patch
Patch5: rteval-If-the-user-doesn-t-specify-a-cpumask-use-the.patch
%description
The rteval script is a utility for measuring various aspects of
@ -52,6 +53,7 @@ to the screen.
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%build
%{__python3} setup.py build
@ -89,7 +91,11 @@ rm -rf $RPM_BUILD_ROOT
%{python3_sitelib}/rteval/__pycache__/*
%changelog
* Mon Feb 07 2022 John Kacur <jkacur@redhat.com> - 3.3-2
* Tue Feb 15 2022 John Kacur <jkacur@redhat.com> - 3.3-6
- Use inherited cpumask if user doesn't specify a cpumask
Resolves: rhbz#2012284
* Mon Feb 07 2022 John Kacur <jkacur@redhat.com> - 3.3-5
- Don't restrict threads to cpumask in environment if user specifies cpumask
Resolves: rhbz#2012284