Fix test missing threshold assignment
Fix test missing threshold assignment Resolves: rhbz#1995195 Signed-off-by: John Kacur <jkacur@redhat.com>
This commit is contained in:
parent
bbb443541c
commit
be9b846752
32
rteval-Fix-test-misses-threshold-assignment.patch
Normal file
32
rteval-Fix-test-misses-threshold-assignment.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From aca562064a8d9f5927aa39bc108eac3bf4d0a56b Mon Sep 17 00:00:00 2001
|
||||
From: John Kacur <jkacur@redhat.com>
|
||||
Date: Fri, 14 Jan 2022 14:00:54 -0500
|
||||
Subject: [PATCH] rteval: Fix test misses threshold assignment
|
||||
|
||||
Fix case where self.__cfg.threshold has a value but
|
||||
instead of 'threshold' in self.__cfg,
|
||||
'breaktrace' in self.__cfg.
|
||||
by just checking whether self.__cfg.threshold has a value
|
||||
if self._cfg.breaktrace does not have a value
|
||||
|
||||
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||
---
|
||||
rteval/modules/measurement/cyclictest.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/rteval/modules/measurement/cyclictest.py b/rteval/modules/measurement/cyclictest.py
|
||||
index cc74b467913d..af8adeeeb402 100644
|
||||
--- a/rteval/modules/measurement/cyclictest.py
|
||||
+++ b/rteval/modules/measurement/cyclictest.py
|
||||
@@ -299,7 +299,7 @@ class Cyclictest(rtevalModulePrototype):
|
||||
if 'breaktrace' in self.__cfg and self.__cfg.breaktrace:
|
||||
self.__cmd.append("-b%d" % int(self.__cfg.breaktrace))
|
||||
self.__cmd.append("--tracemark")
|
||||
- elif 'threshold' in self.__cfg and self.__cfg.threshold:
|
||||
+ elif self.__cfg.threshold:
|
||||
self.__cmd.append("-b%d" % int(self.__cfg.threshold))
|
||||
|
||||
# Buffer for cyclictest data written to stdout
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: rteval
|
||||
Version: 3.2
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
Summary: Utility to evaluate system suitability for RT Linux
|
||||
|
||||
Group: Development/Tools
|
||||
@ -41,6 +41,7 @@ Patch9: rteval-cyclictest.py-Parse-max-latencies-from-cyclic.patch
|
||||
Patch10: rteval-cyclictest.py-Sort-the-list-of-cpus.patch
|
||||
Patch11: rteval-cyclictest.py-Skip-statistics-reporting-in-ca.patch
|
||||
Patch12: rteval-Add-cyclictest-threshold-USEC.patch
|
||||
Patch13: rteval-Fix-test-misses-threshold-assignment.patch
|
||||
|
||||
%description
|
||||
The rteval script is a utility for measuring various aspects of
|
||||
@ -65,6 +66,7 @@ to the screen.
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
|
||||
%build
|
||||
%{__python3} setup.py build
|
||||
@ -91,6 +93,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{python3_sitelib}/rteval/__pycache__/*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 14 2022 john Kacur <jkacur@redhat.com> - 3.2-10
|
||||
- Fix test missing threshold assignment
|
||||
Resolves: rhbz#1995195
|
||||
|
||||
* Wed Jan 12 2022 John Kacur <jkacur@redhat.com> - 3.2-9
|
||||
- Do not pass obsolete notrace option to cyclictest
|
||||
- Parse maximum latency even if outside configured buckets
|
||||
|
Loading…
Reference in New Issue
Block a user