Change the default kernel to compile as a load to linux-6.1.8
Update requires Resolves: rhbz#2166355 jiraProject == RHELPLAN-147318 Signed-off-by: John Kacur <jkacur@redhat.com>
This commit is contained in:
parent
45cda1e611
commit
596b077ac5
67
rteval-Change-the-default-kernel-to-compile-to-linux.patch
Normal file
67
rteval-Change-the-default-kernel-to-compile-to-linux.patch
Normal file
@ -0,0 +1,67 @@
|
||||
From 0f39c69610985b07ce2aa41142d2f0481da8e3a4 Mon Sep 17 00:00:00 2001
|
||||
From: John Kacur <jkacur@redhat.com>
|
||||
Date: Fri, 3 Feb 2023 16:13:09 -0500
|
||||
Subject: [PATCH 8/8] rteval: Change the default kernel to compile to
|
||||
linux-6.1.8
|
||||
|
||||
rteval compiles the linux kernel as a load
|
||||
Change the default kernel that rteval compiles to linux-6.1.8
|
||||
|
||||
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
rteval/modules/loads/kcompile.py | 4 ++--
|
||||
rteval/rteval.conf | 2 +-
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index ffea8a05f460..81ca8242bbbe 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -17,7 +17,7 @@ PREFIX := /usr
|
||||
DATADIR := $(DESTDIR)/$(PREFIX)/share
|
||||
LOADDIR := loadsource
|
||||
|
||||
-KLOAD := $(LOADDIR)/linux-5.18.1.tar.xz
|
||||
+KLOAD := $(LOADDIR)/linux-6.1.8.tar.xz
|
||||
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
|
||||
LOADS := $(KLOAD) $(BLOAD)
|
||||
|
||||
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
|
||||
index 6faa686f81d0..35ee5cbbb52d 100644
|
||||
--- a/rteval/modules/loads/kcompile.py
|
||||
+++ b/rteval/modules/loads/kcompile.py
|
||||
@@ -38,7 +38,7 @@ from rteval.systopology import CpuList, SysTopology
|
||||
expand_cpulist = CpuList.expand_cpulist
|
||||
compress_cpulist = CpuList.compress_cpulist
|
||||
|
||||
-DEFAULT_KERNEL_PREFIX = "linux-5.18"
|
||||
+DEFAULT_KERNEL_PREFIX = "linux-6.1"
|
||||
|
||||
class KBuildJob:
|
||||
'''Class to manage a build job bound to a particular node'''
|
||||
@@ -349,7 +349,7 @@ class Kcompile(CommandLineLoad):
|
||||
|
||||
def ModuleParameters():
|
||||
return {"source": {"descr": "Source tar ball",
|
||||
- "default": "linux-5.18.1.tar.xz",
|
||||
+ "default": "linux-6.1.8.tar.xz",
|
||||
"metavar": "TARBALL"},
|
||||
"jobspercore": {"descr": "Number of working threads per core",
|
||||
"default": 2,
|
||||
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
|
||||
index 1a8d0afd2642..79e28032dc6b 100644
|
||||
--- a/rteval/rteval.conf
|
||||
+++ b/rteval/rteval.conf
|
||||
@@ -18,7 +18,7 @@ dbench: external
|
||||
stressng: module
|
||||
|
||||
[kcompile]
|
||||
-source: linux-5.18.1.xz
|
||||
+source: linux-6.1.8.xz
|
||||
jobspercore: 2
|
||||
|
||||
[hackbench]
|
||||
--
|
||||
2.39.0
|
||||
|
16
rteval.spec
16
rteval.spec
@ -1,6 +1,6 @@
|
||||
Name: rteval
|
||||
Version: 3.5
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Summary: Utility to evaluate system suitability for RT Linux
|
||||
|
||||
Group: Development/Tools
|
||||
@ -14,8 +14,8 @@ Requires: python3-lxml
|
||||
Requires: python3-libxml2
|
||||
Requires: python3-dmidecode >= 3.10
|
||||
Requires: python3-requests
|
||||
Requires: realtime-tests >= 2.1-1
|
||||
Requires: rteval-loads >= 1.6-1
|
||||
Requires: realtime-tests >= 2.5-1
|
||||
Requires: rteval-loads >= 1.6-2
|
||||
Requires: sysstat
|
||||
Requires: xz bzip2 tar gzip m4 make gawk
|
||||
Requires: kernel-headers
|
||||
@ -28,7 +28,7 @@ Requires: stress-ng
|
||||
Requires: perl-interpreter, perl-devel, perl-generators
|
||||
Requires: libmpc, libmpc-devel
|
||||
Requires: dwarves
|
||||
Requires: python-sphinx
|
||||
Requires: python3-sphinx
|
||||
BuildArch: noarch
|
||||
|
||||
#Patches
|
||||
@ -36,6 +36,7 @@ Patch1: rteval-Replace-python-ethtool-with-inline-code.patch
|
||||
Patch2: Fix-DMI-WARNING-when-not-running-as-root.patch
|
||||
Patch3: rteval-Don-t-attempt-to-get-DMIinfo-if-there-are-dmi.patch
|
||||
Patch4: rteval-Catch-failures-in-python-dmidecode.patch
|
||||
Patch5: rteval-Change-the-default-kernel-to-compile-to-linux.patch
|
||||
|
||||
%description
|
||||
The rteval script is a utility for measuring various aspects of
|
||||
@ -52,6 +53,7 @@ to the screen.
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%build
|
||||
%{__python3} setup.py build
|
||||
@ -73,6 +75,12 @@ to the screen.
|
||||
%{_bindir}/rteval
|
||||
|
||||
%changelog
|
||||
* Fri Feb 03 2023 John Kacur <jkacur@redhat.com> - 3.5-6
|
||||
- Change the default kernel to compile as a load to linux-6.1.8
|
||||
- Update requires
|
||||
Resolves: rhbz#2166355
|
||||
jiraProject == RHELPLAN-147318
|
||||
|
||||
* Thu Feb 02 2023 John Kacur <jkacur@redhat.com> - 3.5-5
|
||||
- Change requires to python-sphinx
|
||||
Resolves: rhbz#2164416
|
||||
|
Loading…
Reference in New Issue
Block a user