Use inherited cpumask if user doesn't specify a cpumask
Use inherited cpumask if user doesn't specify a cpumask Resolves: rhbz#1983783 Signed-off-by: John Kacur <jkacur@redhat.com>
This commit is contained in:
parent
6be39f0b28
commit
2a84938dd6
34
rteval-If-the-user-doesn-t-specify-a-cpumask-use-the.patch
Normal file
34
rteval-If-the-user-doesn-t-specify-a-cpumask-use-the.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From 14b0cff41f13602579fd708748eb8a2ad93db85b Mon Sep 17 00:00:00 2001
|
||||||
|
From: John Kacur <jkacur@redhat.com>
|
||||||
|
Date: Mon, 14 Feb 2022 22:09:21 -0500
|
||||||
|
Subject: [PATCH] rteval: If the user doesn't specify a cpumask, use the
|
||||||
|
inherited one
|
||||||
|
|
||||||
|
If the user doesn't specify a cpumask, then we need to use the inherited
|
||||||
|
one to match what cyclictest currently does
|
||||||
|
|
||||||
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||||
|
---
|
||||||
|
rteval/modules/measurement/cyclictest.py | 6 ++++++
|
||||||
|
1 file changed, 6 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/rteval/modules/measurement/cyclictest.py b/rteval/modules/measurement/cyclictest.py
|
||||||
|
index 4ca310bf7490..8fdd5341794a 100644
|
||||||
|
--- a/rteval/modules/measurement/cyclictest.py
|
||||||
|
+++ b/rteval/modules/measurement/cyclictest.py
|
||||||
|
@@ -216,6 +216,12 @@ class Cyclictest(rtevalModulePrototype):
|
||||||
|
self.__sparse = True
|
||||||
|
else:
|
||||||
|
self.__cpus = online_cpus()
|
||||||
|
+ # Get the cpuset from the environment
|
||||||
|
+ cpuset = os.sched_getaffinity(0)
|
||||||
|
+ # Convert the elements to strings
|
||||||
|
+ cpuset = [str(c) for c in cpuset]
|
||||||
|
+ # Only include cpus that are in the cpuset
|
||||||
|
+ self.__cpus = [c for c in self.__cpus if c in cpuset]
|
||||||
|
|
||||||
|
# Sort the list of cpus to align with the order reported by cyclictest
|
||||||
|
self.__cpus.sort(key=int)
|
||||||
|
--
|
||||||
|
2.34.1
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: rteval
|
Name: rteval
|
||||||
Version: 3.3
|
Version: 3.3
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Utility to evaluate system suitability for RT Linux
|
Summary: Utility to evaluate system suitability for RT Linux
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -32,6 +32,7 @@ BuildArch: noarch
|
|||||||
Patch1: rteval-Fix-test-misses-threshold-assignment.patch
|
Patch1: rteval-Fix-test-misses-threshold-assignment.patch
|
||||||
Patch2: rteval-Increase-default-buckets-from-2000-to-3500.patch
|
Patch2: rteval-Increase-default-buckets-from-2000-to-3500.patch
|
||||||
Patch3: rteval-Don-t-restrict-measurement-threads-to-inherit.patch
|
Patch3: rteval-Don-t-restrict-measurement-threads-to-inherit.patch
|
||||||
|
Patch4: rteval-If-the-user-doesn-t-specify-a-cpumask-use-the.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The rteval script is a utility for measuring various aspects of
|
The rteval script is a utility for measuring various aspects of
|
||||||
@ -47,6 +48,7 @@ to the screen.
|
|||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__python3} setup.py build
|
%{__python3} setup.py build
|
||||||
@ -73,6 +75,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{python3_sitelib}/rteval/__pycache__/*
|
%{python3_sitelib}/rteval/__pycache__/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 15 2022 John Kacur <jkacur@redhat.com> - 3.3-3
|
||||||
|
- Use inherited cpumask if user doesn't specify a cpumask
|
||||||
|
Resolves: rhbz#1983783
|
||||||
|
|
||||||
* Mon Feb 07 2022 John Kacur <jkacur@redhat.com> - 3.3-2
|
* Mon Feb 07 2022 John Kacur <jkacur@redhat.com> - 3.3-2
|
||||||
- Don't restrict threads to cpumask in environment if user specifies cpumask
|
- Don't restrict threads to cpumask in environment if user specifies cpumask
|
||||||
Resolves: rhbz#1983783
|
Resolves: rhbz#1983783
|
||||||
|
Loading…
Reference in New Issue
Block a user