rteval: Make changes to use linux-5.13.2
- rteval: Make changes to use linux-5.13.2 - Fixes to spec file from previous inadvertent changes Signed-off-by: John Kacur <jkacur@redhat.com>
This commit is contained in:
parent
ae33cce7c9
commit
06c2f1af33
65
rteval-Update-to-using-the-linux-5.13.2-kernel.patch
Normal file
65
rteval-Update-to-using-the-linux-5.13.2-kernel.patch
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
From 936bdd7aff0e46a1509ee4844cba279053ca97c7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: John Kacur <jkacur@redhat.com>
|
||||||
|
Date: Fri, 16 Jul 2021 11:33:19 -0400
|
||||||
|
Subject: [PATCH] rteval: Update to using the linux-5.13.2 kernel
|
||||||
|
|
||||||
|
Update to using the linux-5.13.2 kernel
|
||||||
|
|
||||||
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile | 2 +-
|
||||||
|
rteval/modules/loads/kcompile.py | 4 ++--
|
||||||
|
rteval/rteval.conf | 2 +-
|
||||||
|
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index d942858d5a62..36d40867883c 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -17,7 +17,7 @@ PREFIX := /usr
|
||||||
|
DATADIR := $(DESTDIR)/$(PREFIX)/share
|
||||||
|
LOADDIR := loadsource
|
||||||
|
|
||||||
|
-KLOAD := $(LOADDIR)/linux-5.7.tar.xz
|
||||||
|
+KLOAD := $(LOADDIR)/linux-5.13.2.tar.xz
|
||||||
|
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
|
||||||
|
LOADS := $(KLOAD) $(BLOAD)
|
||||||
|
|
||||||
|
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
|
||||||
|
index e747b9f17782..d1955c7aee3d 100644
|
||||||
|
--- a/rteval/modules/loads/kcompile.py
|
||||||
|
+++ b/rteval/modules/loads/kcompile.py
|
||||||
|
@@ -35,7 +35,7 @@ from rteval.Log import Log
|
||||||
|
from rteval.misc import expand_cpulist, compress_cpulist
|
||||||
|
from rteval.systopology import SysTopology
|
||||||
|
|
||||||
|
-kernel_prefix = "linux-5.7"
|
||||||
|
+kernel_prefix = "linux-5.13"
|
||||||
|
|
||||||
|
class KBuildJob:
|
||||||
|
'''Class to manage a build job bound to a particular node'''
|
||||||
|
@@ -302,7 +302,7 @@ class Kcompile(CommandLineLoad):
|
||||||
|
|
||||||
|
def ModuleParameters():
|
||||||
|
return {"source": {"descr": "Source tar ball",
|
||||||
|
- "default": "linux-5.7.tar.xz",
|
||||||
|
+ "default": "linux-5.13.2.tar.xz",
|
||||||
|
"metavar": "TARBALL"},
|
||||||
|
"jobspercore": {"descr": "Number of working threads per core",
|
||||||
|
"default": 2,
|
||||||
|
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
|
||||||
|
index 6065d2e909f6..7ce6ef0b5acc 100644
|
||||||
|
--- a/rteval/rteval.conf
|
||||||
|
+++ b/rteval/rteval.conf
|
||||||
|
@@ -18,7 +18,7 @@ dbench: external
|
||||||
|
stressng: module
|
||||||
|
|
||||||
|
[kcompile]
|
||||||
|
-source: linux-5.7.xz
|
||||||
|
+source: linux-5.13.2.xz
|
||||||
|
jobspercore: 2
|
||||||
|
|
||||||
|
[hackbench]
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
38
rteval.spec
38
rteval.spec
@ -1,38 +1,37 @@
|
|||||||
Name: rteval
|
Name: rteval
|
||||||
Version: 3.2
|
Version: 3.2
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Summary: Utility to evaluate system suitability for RT Linux
|
Summary: Utility to evaluate system suitability for RT Linux
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: https://git.kernel.org/pub/scm/utils/rteval/rteval.git
|
URL: https://git.kernel.org/pub/scm/utils/rteval/rteval.git
|
||||||
Source0: https://www.kernel.org/pub/linux/utils/rteval/rteval-%{version}.tar.xz
|
Source0: https://www.kernel.org/pub/linux/utils/%{name}/%{name}-%{version}.tar.xz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
Requires: platform-python
|
|
||||||
Requires: python3-ethtool
|
Requires: python3-ethtool
|
||||||
Requires: python3-lxml
|
Requires: python3-lxml
|
||||||
Requires: python3-dmidecode >= 3.10
|
Requires: python3-dmidecode >= 3.10
|
||||||
Requires: realtime-tests >= 2.1-1
|
Requires: realtime-tests >= 2.1-1
|
||||||
Requires: rteval-loads >= 1.4-7
|
Requires: rteval-loads >= 1.4-14
|
||||||
Requires: sysstat
|
Requires: sysstat
|
||||||
Requires: xz bzip2
|
Requires: xz bzip2
|
||||||
Requires: kernel-headers
|
Requires: kernel-headers
|
||||||
Requires: sos
|
Requires: sos
|
||||||
Requires: tar
|
Requires: tar
|
||||||
BuildArch: noarch
|
|
||||||
Obsoletes: rteval <= 2.14
|
|
||||||
Requires: numactl
|
Requires: numactl
|
||||||
Requires: gcc flex bison bc make
|
Requires: gcc flex bison bc make
|
||||||
Requires: elfutils elfutils-libelf-devel
|
Requires: elfutils elfutils-libelf-devel
|
||||||
Requires: openssl
|
Requires: openssl
|
||||||
Requires: openssl-devel
|
Requires: openssl-devel
|
||||||
Requires: stress-ng
|
Requires: stress-ng
|
||||||
Obsoletes: rteval-common <= 3.1
|
Requires: binutils
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
#Patches
|
#Patches
|
||||||
Patch1: rteval-Restrict-measurement-threads-to-the-cpus-in-cpumask.patch
|
Patch1: rteval-Restrict-measurement-threads-to-the-cpus-in-cpumask.patch
|
||||||
|
Patch2: rteval-Update-to-using-the-linux-5.13.2-kernel.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The rteval script is a utility for measuring various aspects of
|
The rteval script is a utility for measuring various aspects of
|
||||||
@ -46,6 +45,7 @@ to the screen.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__python3} setup.py build
|
%{__python3} setup.py build
|
||||||
@ -60,29 +60,23 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{python3_sitelib}/*.egg-info
|
%{python3_sitelib}/*.egg-info
|
||||||
|
|
||||||
%doc COPYING README doc/rteval.txt
|
%doc README doc/rteval.txt
|
||||||
|
%license COPYING
|
||||||
%dir %{_datadir}/%{name}
|
%dir %{_datadir}/%{name}
|
||||||
%{python3_sitelib}/rteval/rtevalclient.py*
|
%{python3_sitelib}/rteval
|
||||||
%{python3_sitelib}/rteval/rtevalConfig.py*
|
|
||||||
%{python3_sitelib}/rteval/rtevalXMLRPC.py*
|
|
||||||
%{python3_sitelib}/rteval/version.py*
|
|
||||||
%{python3_sitelib}/rteval/Log.py*
|
|
||||||
%{python3_sitelib}/rteval/misc.py*
|
|
||||||
%{python3_sitelib}/rteval/systopology.py*
|
|
||||||
%{_mandir}/man8/rteval.8.gz
|
%{_mandir}/man8/rteval.8.gz
|
||||||
%config(noreplace) %{_sysconfdir}/rteval.conf
|
%config(noreplace) %{_sysconfdir}/rteval.conf
|
||||||
%{_datadir}/%{name}/rteval_*.xsl
|
%{_datadir}/%{name}/rteval_*.xsl
|
||||||
%{python3_sitelib}/rteval/__init__.py*
|
%{_bindir}/rteval
|
||||||
%{python3_sitelib}/rteval/rtevalMailer.py*
|
|
||||||
%{python3_sitelib}/rteval/rtevalReport.py*
|
|
||||||
%{python3_sitelib}/rteval/xmlout.py*
|
|
||||||
%{python3_sitelib}/rteval/modules
|
|
||||||
%{python3_sitelib}/rteval/sysinfo
|
|
||||||
/usr/bin/rteval
|
|
||||||
|
|
||||||
%{python3_sitelib}/rteval/__pycache__/*
|
%{python3_sitelib}/rteval/__pycache__/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 16 2021 John Kacur <jkacur@redhat.com> - 3.2-5
|
||||||
|
- Make changes to use linux-5.13.2 kernel
|
||||||
|
- specfile changes to undo some inadvertent changes from e083e0224c00d984e9e9e7
|
||||||
|
Resolves: rhbz#1982810
|
||||||
|
|
||||||
* Thu Jul 15 2021 John Kacur <jkacur@redhat.com> - 3.2-4
|
* Thu Jul 15 2021 John Kacur <jkacur@redhat.com> - 3.2-4
|
||||||
- Fix Requires to require realtime-tests not rt-tests
|
- Fix Requires to require realtime-tests not rt-tests
|
||||||
Resolves: rhbz#1981875
|
Resolves: rhbz#1981875
|
||||||
|
Loading…
Reference in New Issue
Block a user