Change the default kernel to compile to linux-5.18.1

rteval compiles the linux kernel as a load
Change the default kernel to compile to linux-5.18.1

Resolves: rhbz#2093480
Signed-off-by: John Kacur <jkacur@redhat.com>
This commit is contained in:
John Kacur 2022-06-07 12:11:42 -04:00
parent 6d294447e9
commit 03867dafe5
2 changed files with 72 additions and 1 deletions

View File

@ -0,0 +1,66 @@
From e20fb6d6f1a357afe5ae7ba63d5bb340e0041156 Mon Sep 17 00:00:00 2001
From: John Kacur <jkacur@redhat.com>
Date: Tue, 7 Jun 2022 11:29:18 -0400
Subject: [PATCH] rteval: Change the default kernel to compile to linux-5.18.1
rteval compiles the linux kernel as a load
Change the default kernel that rteval compiles to linux-5.18.1
Signed-off-by: John Kacur <jkacur@redhat.com>
---
Makefile | 2 +-
rteval/modules/loads/kcompile.py | 4 ++--
rteval/rteval.conf | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
index 36d40867883c..ffea8a05f460 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ PREFIX := /usr
DATADIR := $(DESTDIR)/$(PREFIX)/share
LOADDIR := loadsource
-KLOAD := $(LOADDIR)/linux-5.13.2.tar.xz
+KLOAD := $(LOADDIR)/linux-5.18.1.tar.xz
BLOAD := $(LOADDIR)/dbench-4.0.tar.gz
LOADS := $(KLOAD) $(BLOAD)
diff --git a/rteval/modules/loads/kcompile.py b/rteval/modules/loads/kcompile.py
index 3d9b882d8810..2c93c794fe75 100644
--- a/rteval/modules/loads/kcompile.py
+++ b/rteval/modules/loads/kcompile.py
@@ -36,7 +36,7 @@ from rteval.Log import Log
from rteval.misc import expand_cpulist, compress_cpulist
from rteval.systopology import SysTopology
-DEFAULT_KERNEL_PREFIX = "linux-5.13"
+DEFAULT_KERNEL_PREFIX = "linux-5.18"
class KBuildJob:
'''Class to manage a build job bound to a particular node'''
@@ -326,7 +326,7 @@ class Kcompile(CommandLineLoad):
def ModuleParameters():
return {"source": {"descr": "Source tar ball",
- "default": "linux-5.13.2.tar.xz",
+ "default": "linux-5.18.1.tar.xz",
"metavar": "TARBALL"},
"jobspercore": {"descr": "Number of working threads per core",
"default": 2,
diff --git a/rteval/rteval.conf b/rteval/rteval.conf
index aa0a53bcfc63..1a8d0afd2642 100644
--- a/rteval/rteval.conf
+++ b/rteval/rteval.conf
@@ -18,7 +18,7 @@ dbench: external
stressng: module
[kcompile]
-source: linux-5.13.2.xz
+source: linux-5.18.1.xz
jobspercore: 2
[hackbench]
--
2.36.1

View File

@ -1,6 +1,6 @@
Name: rteval
Version: 3.3
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Utility to evaluate system suitability for RT Linux
Group: Development/Tools
@ -35,6 +35,7 @@ Patch3: rteval-Don-t-restrict-measurement-threads-to-inherit.patch
Patch4: rteval-If-the-user-doesn-t-specify-a-cpumask-use-the.patch
Patch5: rteval-Fix-Popen-for-python3.6-where-text-True-is-no.patch
Patch6: rteval-Fix-allmodconfig-build-on-machines-that-don-t.patch
Patch7: rteval-Change-the-default-kernel-to-compile.patch
%description
The rteval script is a utility for measuring various aspects of
@ -79,6 +80,10 @@ rm -rf $RPM_BUILD_ROOT
%{python3_sitelib}/rteval/__pycache__/*
%changelog
* Tue Jun 07 2022 John Kacur <jkacur@redhat.com> - 3.3-5
- Change the default kernel to compile to linux-5.18.1
Resolves: rhbz#2093480
* Thu Apr 14 2022 John Kacur <jkacur@redhat.com> - 3.3-4
- Fix Popen for python3.6
- Fix allmodconfig when SHA1 signing of modules is not available