rt-tests/SOURCES/rt-tests-Makefile-Change-sy...

30 lines
888 B
Diff

From 026f2a31c505b244bbb4a811ba5329225e3f66f1 Mon Sep 17 00:00:00 2001
From: John Kacur <jkacur@redhat.com>
Date: Wed, 13 Jun 2018 01:53:11 +0200
Subject: [PATCH] rt-tests: Makefile: Change syntax for python3
When testing for the PYLIB version, we need to explicitly
specify python3 and fix the print syntax
Signed-off-by: John Kacur <jkacur@redhat.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index cffb255d96d1..8b08385890fe 100644
--- a/Makefile
+++ b/Makefile
@@ -33,7 +33,7 @@ CFLAGS ?= -Wall -Wno-nonnull
CPPFLAGS += -D_GNU_SOURCE -Isrc/include
LDFLAGS ?=
-PYLIB ?= $(shell python -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()')
+PYLIB ?= $(shell python3 -c 'import distutils.sysconfig; print (distutils.sysconfig.get_python_lib())')
ifndef DEBUG
CFLAGS += -O2 -g
--
2.14.4