f7cef91834
- drop patches merged upstream - resolve detection of the new GnuTLS package - add autoconf to BuildRequires - add --enable-generate-man-pages to configure parameters; the rscryutil man page isn't generated without it https://github.com/rsyslog/rsyslog/pull/469
25 lines
833 B
Diff
25 lines
833 B
Diff
diff -up ./configure.ac.fix ./configure.ac
|
|
--- ./configure.ac.fix 2015-08-10 12:25:41.000000000 +0200
|
|
+++ ./configure.ac 2015-08-31 10:35:18.515110190 +0200
|
|
@@ -763,17 +763,11 @@ AC_ARG_ENABLE(gnutls,
|
|
if test "x$enable_gnutls" = "xyes"; then
|
|
PKG_CHECK_MODULES(GNUTLS, gnutls >= 1.4.0)
|
|
AC_DEFINE([ENABLE_GNUTLS], [1], [Indicator that GnuTLS is present])
|
|
- AC_CHECK_LIB(
|
|
- [gnutls],
|
|
- [gnutls_global_init],
|
|
- [
|
|
- AC_DEFINE(HAVE_LIB_GNUTLS, 1, [gnutls is available])
|
|
- ],
|
|
- [AC_MSG_WARN([gnutls_global_init function missing or not detected])],
|
|
- []
|
|
- )
|
|
+ save_libs=$LIBS
|
|
+ LIBS="$LIBS $GNUTLS_LIBS"
|
|
AC_CHECK_FUNCS(gnutls_certificate_set_retrieve_function,,)
|
|
AC_CHECK_FUNCS(gnutls_certificate_type_set_priority,,)
|
|
+ LIBS=$save_libs
|
|
fi
|
|
AM_CONDITIONAL(ENABLE_GNUTLS, test x$enable_gnutls = xyes)
|
|
|