Rebase to 8.12.0
- drop patches merged upstream - resolve detection of the new GnuTLS package - add autoconf to BuildRequires - add --enable-generate-man-pages to configure parameters; the rscryutil man page isn't generated without it https://github.com/rsyslog/rsyslog/pull/469
This commit is contained in:
parent
6f66b29841
commit
f7cef91834
24
rsyslog-8.12.0-gnutls-detection.patch
Normal file
24
rsyslog-8.12.0-gnutls-detection.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up ./configure.ac.fix ./configure.ac
|
||||||
|
--- ./configure.ac.fix 2015-08-10 12:25:41.000000000 +0200
|
||||||
|
+++ ./configure.ac 2015-08-31 10:35:18.515110190 +0200
|
||||||
|
@@ -763,17 +763,11 @@ AC_ARG_ENABLE(gnutls,
|
||||||
|
if test "x$enable_gnutls" = "xyes"; then
|
||||||
|
PKG_CHECK_MODULES(GNUTLS, gnutls >= 1.4.0)
|
||||||
|
AC_DEFINE([ENABLE_GNUTLS], [1], [Indicator that GnuTLS is present])
|
||||||
|
- AC_CHECK_LIB(
|
||||||
|
- [gnutls],
|
||||||
|
- [gnutls_global_init],
|
||||||
|
- [
|
||||||
|
- AC_DEFINE(HAVE_LIB_GNUTLS, 1, [gnutls is available])
|
||||||
|
- ],
|
||||||
|
- [AC_MSG_WARN([gnutls_global_init function missing or not detected])],
|
||||||
|
- []
|
||||||
|
- )
|
||||||
|
+ save_libs=$LIBS
|
||||||
|
+ LIBS="$LIBS $GNUTLS_LIBS"
|
||||||
|
AC_CHECK_FUNCS(gnutls_certificate_set_retrieve_function,,)
|
||||||
|
AC_CHECK_FUNCS(gnutls_certificate_type_set_priority,,)
|
||||||
|
+ LIBS=$save_libs
|
||||||
|
fi
|
||||||
|
AM_CONDITIONAL(ENABLE_GNUTLS, test x$enable_gnutls = xyes)
|
||||||
|
|
31
rsyslog.spec
31
rsyslog.spec
@ -11,7 +11,7 @@
|
|||||||
|
|
||||||
Summary: Enhanced system logging and kernel message trapping daemon
|
Summary: Enhanced system logging and kernel message trapping daemon
|
||||||
Name: rsyslog
|
Name: rsyslog
|
||||||
Version: 8.10.0
|
Version: 8.12.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: (GPLv3+ and ASL 2.0)
|
License: (GPLv3+ and ASL 2.0)
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -25,20 +25,19 @@ Source4: rsyslog.log
|
|||||||
Patch0: rsyslog-8.8.0-sd-service.patch
|
Patch0: rsyslog-8.8.0-sd-service.patch
|
||||||
# prevent modification of trusted properties (proposed upstream)
|
# prevent modification of trusted properties (proposed upstream)
|
||||||
Patch1: rsyslog-8.8.0-immutable-json-props.patch
|
Patch1: rsyslog-8.8.0-immutable-json-props.patch
|
||||||
Patch2: rsyslog-8.8.0-missing-test-data.patch
|
# Fix detection of the GnuTLS package
|
||||||
# https://github.com/rsyslog/rsyslog/pull/412
|
# https://github.com/rsyslog/rsyslog/pull/476
|
||||||
Patch3: rsyslog-8.10.0-imjournal-empty-messages.patch
|
Patch2: rsyslog-8.12.0-gnutls-detection.patch
|
||||||
# https://github.com/rsyslog/rsyslog/pull/413
|
|
||||||
Patch4: rsyslog-8.10.0-resetconfigvariables.patch
|
|
||||||
# https://github.com/rsyslog/rsyslog/pull/391
|
|
||||||
Patch5: rsyslog-8.10.0-imfile-maxlinesatonce.patch
|
|
||||||
|
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: dos2unix
|
BuildRequires: dos2unix
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: json-c-devel
|
BuildRequires: json-c-devel
|
||||||
BuildRequires: libestr-devel >= 0.1.9
|
BuildRequires: libestr-devel >= 0.1.9
|
||||||
BuildRequires: liblogging-stdlog-devel
|
BuildRequires: liblogging-stdlog-devel
|
||||||
|
BuildRequires: libtool
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: python-docutils
|
BuildRequires: python-docutils
|
||||||
@ -257,9 +256,8 @@ mv build doc
|
|||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p1
|
autoreconf -iv
|
||||||
%patch5 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%ifarch sparc64
|
%ifarch sparc64
|
||||||
@ -280,6 +278,7 @@ export HIREDIS_LIBS="-L%{_libdir} -lhiredis"
|
|||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--enable-elasticsearch \
|
--enable-elasticsearch \
|
||||||
|
--enable-generate-man-pages \
|
||||||
--enable-gnutls \
|
--enable-gnutls \
|
||||||
--enable-gssapi-krb5 \
|
--enable-gssapi-krb5 \
|
||||||
--enable-imdiag \
|
--enable-imdiag \
|
||||||
@ -375,6 +374,7 @@ done
|
|||||||
%{!?_licensedir:%global license %%doc}
|
%{!?_licensedir:%global license %%doc}
|
||||||
%license COPYING*
|
%license COPYING*
|
||||||
%doc AUTHORS ChangeLog README.md
|
%doc AUTHORS ChangeLog README.md
|
||||||
|
%{rsyslog_docdir}
|
||||||
%exclude %{rsyslog_docdir}/html
|
%exclude %{rsyslog_docdir}/html
|
||||||
%exclude %{rsyslog_docdir}/mysql-createDB.sql
|
%exclude %{rsyslog_docdir}/mysql-createDB.sql
|
||||||
%exclude %{rsyslog_docdir}/pgsql-createDB.sql
|
%exclude %{rsyslog_docdir}/pgsql-createDB.sql
|
||||||
@ -506,6 +506,15 @@ done
|
|||||||
%{_libdir}/rsyslog/omudpspoof.so
|
%{_libdir}/rsyslog/omudpspoof.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 1 2015 Radovan Sroka <rsroka@redhat.com> 8.12.0-1
|
||||||
|
- rebase to 8.12.0
|
||||||
|
- drop patches merged upstream
|
||||||
|
- resolve detection of the new GnuTLS package
|
||||||
|
- add autoconf to BuildRequires
|
||||||
|
- add --enable-generate-man-pages to configure parameters;
|
||||||
|
the rscryutil man page isn't generated without it
|
||||||
|
https://github.com/rsyslog/rsyslog/pull/469
|
||||||
|
|
||||||
* Wed Jun 24 2015 Tomas Heinrich <theinric@redhat.com> 8.10.0-1
|
* Wed Jun 24 2015 Tomas Heinrich <theinric@redhat.com> 8.10.0-1
|
||||||
- rebase to 8.10.0
|
- rebase to 8.10.0
|
||||||
- drop patches merged upstream
|
- drop patches merged upstream
|
||||||
|
Loading…
Reference in New Issue
Block a user