upgrade
This commit is contained in:
parent
d34772a253
commit
b9007df8d2
@ -1,5 +1,5 @@
|
|||||||
rsyslog-3.14.1.tar.gz
|
|
||||||
rsyslog.conf
|
rsyslog.conf
|
||||||
rsyslog.init
|
|
||||||
rsyslog.sysconfig
|
rsyslog.sysconfig
|
||||||
rsyslog-3.16.1.tar.gz
|
rsyslog.init
|
||||||
|
rsyslog.log
|
||||||
|
rsyslog-3.19.3.tar.gz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff -up rsyslog-3.11.0/plugins/imklog/imklog.h.undef rsyslog-3.11.0/plugins/imklog/imklog.h
|
|
||||||
--- rsyslog-3.11.0/plugins/imklog/imklog.h.undef 2008-02-01 12:42:18.000000000 +0100
|
|
||||||
+++ rsyslog-3.11.0/plugins/imklog/imklog.h 2008-02-01 12:43:33.000000000 +0100
|
|
||||||
@@ -28,6 +28,9 @@
|
|
||||||
#include "rsyslog.h"
|
|
||||||
#include "syslogd.h"
|
|
||||||
|
|
||||||
+#undef syslog
|
|
||||||
+#undef vsyslog
|
|
||||||
+
|
|
||||||
/* global variables */
|
|
||||||
extern int dbgPrintSymbols;
|
|
||||||
|
|
@ -1,34 +0,0 @@
|
|||||||
diff -up rsyslog-3.16.1/plugins/omsnmp/omsnmp.c.cfsline rsyslog-3.16.1/plugins/omsnmp/omsnmp.c
|
|
||||||
--- rsyslog-3.16.1/plugins/omsnmp/omsnmp.c.cfsline 2008-05-14 10:50:13.000000000 +0200
|
|
||||||
+++ rsyslog-3.16.1/plugins/omsnmp/omsnmp.c 2008-05-14 10:54:09.000000000 +0200
|
|
||||||
@@ -518,14 +518,14 @@ CODEmodInit_QueryRegCFSLineHdlr
|
|
||||||
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmptransport", 0, eCmdHdlrGetWord, NULL, &pszTransport, STD_LOADABLE_MODULE_ID));
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmptarget", 0, eCmdHdlrGetWord, NULL, &pszTarget, STD_LOADABLE_MODULE_ID));
|
|
||||||
- CHKiRet(regCfSysLineHdlr( (uchar *)"actionsnmptargetport", 0, eCmdHdlrInt, NULL, &iPort, NULL));
|
|
||||||
- CHKiRet(regCfSysLineHdlr( (uchar *)"actionsnmpversion", 0, eCmdHdlrInt, NULL, &iSNMPVersion, NULL));
|
|
||||||
+ CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmptargetport", 0, eCmdHdlrInt, NULL, &iPort, STD_LOADABLE_MODULE_ID));
|
|
||||||
+ CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmpversion", 0, eCmdHdlrInt, NULL, &iSNMPVersion, STD_LOADABLE_MODULE_ID));
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmpcommunity", 0, eCmdHdlrGetWord, NULL, &pszCommunity, STD_LOADABLE_MODULE_ID));
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmpenterpriseoid", 0, eCmdHdlrGetWord, NULL, &pszEnterpriseOID, STD_LOADABLE_MODULE_ID));
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmptrapoid", 0, eCmdHdlrGetWord, NULL, &pszSnmpTrapOID, STD_LOADABLE_MODULE_ID));
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmpsyslogmessageoid", 0, eCmdHdlrGetWord, NULL, &pszSyslogMessageOID, STD_LOADABLE_MODULE_ID));
|
|
||||||
- CHKiRet(regCfSysLineHdlr( (uchar *)"actionsnmpspecifictype", 0, eCmdHdlrInt, NULL, &iSpecificType, NULL));
|
|
||||||
- CHKiRet(regCfSysLineHdlr( (uchar *)"actionsnmptraptype", 0, eCmdHdlrInt, NULL, &iTrapType, NULL));
|
|
||||||
+ CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmpspecifictype", 0, eCmdHdlrInt, NULL, &iSpecificType, STD_LOADABLE_MODULE_ID));
|
|
||||||
+ CHKiRet(omsdRegCFSLineHdlr( (uchar *)"actionsnmptraptype", 0, eCmdHdlrInt, NULL, &iTrapType, STD_LOADABLE_MODULE_ID));
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr( (uchar *)"resetconfigvariables", 1, eCmdHdlrCustomHandler, resetConfigVariables, NULL, STD_LOADABLE_MODULE_ID));
|
|
||||||
ENDmodInit
|
|
||||||
/*
|
|
||||||
diff -up rsyslog-3.16.1/plugins/omgssapi/omgssapi.c.cfsline rsyslog-3.16.1/plugins/omgssapi/omgssapi.c
|
|
||||||
--- rsyslog-3.16.1/plugins/omgssapi/omgssapi.c.cfsline 2008-05-14 10:50:23.000000000 +0200
|
|
||||||
+++ rsyslog-3.16.1/plugins/omgssapi/omgssapi.c 2008-05-14 10:54:43.000000000 +0200
|
|
||||||
@@ -696,7 +696,7 @@ CODEmodInit_QueryRegCFSLineHdlr
|
|
||||||
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr((uchar *)"gssforwardservicename", 0, eCmdHdlrGetWord, NULL, &gss_base_service_name, STD_LOADABLE_MODULE_ID));
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr((uchar *)"gssmode", 0, eCmdHdlrGetWord, setGSSMode, &gss_mode, STD_LOADABLE_MODULE_ID));
|
|
||||||
- CHKiRet(regCfSysLineHdlr((uchar *)"actiongssforwarddefaulttemplate", 0, eCmdHdlrGetWord, NULL, &pszTplName, NULL));
|
|
||||||
+ CHKiRet(omsdRegCFSLineHdlr((uchar *)"actiongssforwarddefaulttemplate", 0, eCmdHdlrGetWord, NULL, &pszTplName, STD_LOADABLE_MODULE_ID));
|
|
||||||
CHKiRet(omsdRegCFSLineHdlr((uchar *)"resetconfigvariables", 1, eCmdHdlrCustomHandler, resetConfigVariables, NULL, STD_LOADABLE_MODULE_ID));
|
|
||||||
ENDmodInit
|
|
||||||
|
|
32
rsyslog.spec
32
rsyslog.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Summary: Enhanced system logging and kernel message trapping daemons
|
Summary: Enhanced system logging and kernel message trapping daemons
|
||||||
Name: rsyslog
|
Name: rsyslog
|
||||||
Version: 3.16.1
|
Version: 3.19.3
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -11,8 +11,7 @@ Source0: http://download.rsyslog.com/rsyslog/%{name}-%{version}.tar.gz
|
|||||||
Source1: rsyslog.init
|
Source1: rsyslog.init
|
||||||
Source2: rsyslog.conf
|
Source2: rsyslog.conf
|
||||||
Source3: rsyslog.sysconfig
|
Source3: rsyslog.sysconfig
|
||||||
Patch1: rsyslog-3.11.4-undef.patch
|
Source4: rsyslog.log
|
||||||
Patch2: rsyslog-3.16.1-cfsline.patch
|
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: autoconf automake
|
BuildRequires: autoconf automake
|
||||||
Requires: logrotate >= 3.5.2
|
Requires: logrotate >= 3.5.2
|
||||||
@ -49,6 +48,12 @@ Group: System Environment/Daemons
|
|||||||
Requires: %name = %version-%release
|
Requires: %name = %version-%release
|
||||||
BuildRequires: librelp-devel
|
BuildRequires: librelp-devel
|
||||||
|
|
||||||
|
%package gnutls
|
||||||
|
Summary: TLS protocol support for rsyslog
|
||||||
|
Group: System Environment/Daemons
|
||||||
|
Requires: %name = %version-%release
|
||||||
|
BuildRequires: gnutls-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Rsyslog is an enhanced multi-threaded syslogd supporting, among others, MySQL,
|
Rsyslog is an enhanced multi-threaded syslogd supporting, among others, MySQL,
|
||||||
syslog/tcp, RFC 3195, permitted sender lists, filtering on any message part,
|
syslog/tcp, RFC 3195, permitted sender lists, filtering on any message part,
|
||||||
@ -57,7 +62,6 @@ and can be used as a drop-in replacement. Its advanced features make it
|
|||||||
suitable for enterprise-class, encryption protected syslog relay chains while
|
suitable for enterprise-class, encryption protected syslog relay chains while
|
||||||
at the same time being very easy to setup for the novice user.
|
at the same time being very easy to setup for the novice user.
|
||||||
|
|
||||||
|
|
||||||
%description mysql
|
%description mysql
|
||||||
The rsyslog-mysql package contains a dynamic shared object that will add
|
The rsyslog-mysql package contains a dynamic shared object that will add
|
||||||
MySQL database support to rsyslog.
|
MySQL database support to rsyslog.
|
||||||
@ -76,11 +80,13 @@ The rsyslog-relp package contains the rsyslog plugins that provide
|
|||||||
the ability to receive syslog messages via the reliable RELP
|
the ability to receive syslog messages via the reliable RELP
|
||||||
protocol.
|
protocol.
|
||||||
|
|
||||||
|
%description gnutls
|
||||||
|
The rsyslog-gnutls package contains the rsyslog plugins that provide the
|
||||||
|
ability to receive syslog messages via upcoming syslog-transport-tls
|
||||||
|
IETF standard protocol.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .undef
|
|
||||||
%patch2 -p1 -b .cfsline
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --sbindir=%{sbindir} \
|
%configure --sbindir=%{sbindir} \
|
||||||
@ -89,7 +95,8 @@ protocol.
|
|||||||
--enable-pgsql \
|
--enable-pgsql \
|
||||||
--enable-gssapi-krb5 \
|
--enable-gssapi-krb5 \
|
||||||
--enable-imfile \
|
--enable-imfile \
|
||||||
--enable-relp
|
--enable-relp \
|
||||||
|
--enable-gnutls
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -104,7 +111,7 @@ install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
|
|||||||
install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/rsyslog
|
install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/rsyslog
|
||||||
install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rsyslog.conf
|
install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rsyslog.conf
|
||||||
install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rsyslog
|
install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rsyslog
|
||||||
install -p -m 644 redhat/rsyslog.log $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/syslog
|
install -p -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/syslog
|
||||||
|
|
||||||
#get rid of *.la
|
#get rid of *.la
|
||||||
rm $RPM_BUILD_ROOT/%{_libdir}/rsyslog/*.la
|
rm $RPM_BUILD_ROOT/%{_libdir}/rsyslog/*.la
|
||||||
@ -149,6 +156,8 @@ fi
|
|||||||
%{_libdir}/rsyslog/lmregexp.so
|
%{_libdir}/rsyslog/lmregexp.so
|
||||||
%{_libdir}/rsyslog/lmtcpclt.so
|
%{_libdir}/rsyslog/lmtcpclt.so
|
||||||
%{_libdir}/rsyslog/lmtcpsrv.so
|
%{_libdir}/rsyslog/lmtcpsrv.so
|
||||||
|
%{_libdir}/rsyslog/lmnetstrms.so
|
||||||
|
%{_libdir}/rsyslog/lmnsd_ptcp.so
|
||||||
%config %{_sysconfdir}/rsyslog.conf
|
%config %{_sysconfdir}/rsyslog.conf
|
||||||
%config %{_sysconfdir}/sysconfig/rsyslog
|
%config %{_sysconfdir}/sysconfig/rsyslog
|
||||||
%config(noreplace) %{_sysconfdir}/logrotate.d/syslog
|
%config(noreplace) %{_sysconfdir}/logrotate.d/syslog
|
||||||
@ -177,7 +186,14 @@ fi
|
|||||||
%{_libdir}/rsyslog/imrelp.so
|
%{_libdir}/rsyslog/imrelp.so
|
||||||
%{_libdir}/rsyslog/omrelp.so
|
%{_libdir}/rsyslog/omrelp.so
|
||||||
|
|
||||||
|
%files gnutls
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/rsyslog/lmnsd_gtls.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 26 2008 Peter Vrabec <pvrabec@redhat.com> 3.19-3-1
|
||||||
|
- upgrade to new upstream release
|
||||||
|
|
||||||
* Wed May 14 2008 Tomas Heinrich <theinric@redhat.com> 3.16.1-1
|
* Wed May 14 2008 Tomas Heinrich <theinric@redhat.com> 3.16.1-1
|
||||||
- upgrade
|
- upgrade
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,5 +1,5 @@
|
|||||||
7e4a7b506e249d69c7d8c5ce7567ee8c rsyslog-3.14.1.tar.gz
|
|
||||||
e6fd8aa699a50ec9abffae50a423aca9 rsyslog.conf
|
e6fd8aa699a50ec9abffae50a423aca9 rsyslog.conf
|
||||||
04f3868aa518d33809f5943d7bc2fc0b rsyslog.sysconfig
|
04f3868aa518d33809f5943d7bc2fc0b rsyslog.sysconfig
|
||||||
26fb52edc816e59e29b1f3b4ac520d30 rsyslog.init
|
26fb52edc816e59e29b1f3b4ac520d30 rsyslog.init
|
||||||
eb371da5e221182fa77c5d814212e460 rsyslog-3.16.1.tar.gz
|
27b77a99af14212ae56995eb47b12975 rsyslog.log
|
||||||
|
ea5f89f994d22b564dc795d844e9189e rsyslog-3.19.3.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user