* Fri Feb 17 2017 Jiri Vymazal <jvymazal@redhat.com> - 8.24.0-5
- new default config, using RainerScript wherever possible resolves: rhbz#1419625 - updated testbench guard as testbench now needs explicit configuration see: rhbz#1211194 - added patch to make chdir call after chroot resolves: rhbz#1422542
This commit is contained in:
parent
1b704f0a0d
commit
4674d1ce99
15
rsyslog-8.24.0-missing-chdir-w-chroot.patch
Normal file
15
rsyslog-8.24.0-missing-chdir-w-chroot.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff --git a/tools/rsyslogd.c b/tools/rsyslogd.c
|
||||||
|
index c099705..12b037f 100644
|
||||||
|
--- a/tools/rsyslogd.c
|
||||||
|
+++ b/tools/rsyslogd.c
|
||||||
|
@@ -1350,6 +1350,10 @@ initAll(int argc, char **argv)
|
||||||
|
perror("chroot");
|
||||||
|
exit(1);
|
||||||
|
}
|
||||||
|
+ if(chdir("\\") != 0) {
|
||||||
|
+ perror("chdir");
|
||||||
|
+ exit(1);
|
||||||
|
+ }
|
||||||
|
break;
|
||||||
|
case 'u': /* misc user settings */
|
||||||
|
iHelperUOpt = (arg == NULL) ? 0 : atoi(arg);
|
62
rsyslog.conf
62
rsyslog.conf
@ -1,24 +1,28 @@
|
|||||||
# rsyslog configuration file
|
# rsyslog configuration file
|
||||||
|
|
||||||
# For more information see /usr/share/doc/rsyslog-*/rsyslog_conf.html
|
# For more information see /usr/share/doc/rsyslog-*/rsyslog_conf.html
|
||||||
|
# or latest version online at http://www.rsyslog.com/doc/rsyslog_conf.html
|
||||||
# If you experience problems, see http://www.rsyslog.com/doc/troubleshoot.html
|
# If you experience problems, see http://www.rsyslog.com/doc/troubleshoot.html
|
||||||
|
|
||||||
#### MODULES ####
|
#### MODULES ####
|
||||||
|
|
||||||
# The imjournal module bellow is now used as a message source instead of imuxsock.
|
module(load="imuxsock" # provides support for local system logging (e.g. via logger command)
|
||||||
$ModLoad imuxsock # provides support for local system logging (e.g. via logger command)
|
SysSock.Use="off") # Turn off message reception via local log socket;
|
||||||
$ModLoad imjournal # provides access to the systemd journal
|
# local messages are retrieved through imjournal now.
|
||||||
#$ModLoad imklog # reads kernel messages (the same are read from journald)
|
module(load="imjournal" # provides access to the systemd journal
|
||||||
#$ModLoad immark # provides --MARK-- message capability
|
StateFile="imjournal.state") # File to store the position in the journal
|
||||||
|
#module(load="imklog") # reads kernel messages (the same are read from journald)
|
||||||
|
#module(load"immark") # provides --MARK-- message capability
|
||||||
|
|
||||||
# Provides UDP syslog reception
|
# Provides UDP syslog reception
|
||||||
#$ModLoad imudp
|
# for parameters see http://www.rsyslog.com/doc/imudp.html
|
||||||
#$UDPServerRun 514
|
#module(load="imudp") # needs to be done just once
|
||||||
|
#input(type="imudp" port="514")
|
||||||
|
|
||||||
# Provides TCP syslog reception
|
# Provides TCP syslog reception
|
||||||
#$ModLoad imtcp
|
# for parameters see http://www.rsyslog.com/doc/imtcp.html
|
||||||
#$InputTCPServerRun 514
|
#module(load="imtcp") # needs to be done just once
|
||||||
|
#input(type="imtcp" port="514")
|
||||||
|
|
||||||
#### GLOBAL DIRECTIVES ####
|
#### GLOBAL DIRECTIVES ####
|
||||||
|
|
||||||
@ -26,23 +30,11 @@ $ModLoad imjournal # provides access to the systemd journal
|
|||||||
$WorkDirectory /var/lib/rsyslog
|
$WorkDirectory /var/lib/rsyslog
|
||||||
|
|
||||||
# Use default timestamp format
|
# Use default timestamp format
|
||||||
$ActionFileDefaultTemplate RSYSLOG_TraditionalFileFormat
|
module(load="builtin:omfile" Template="RSYSLOG_TraditionalFileFormat")
|
||||||
|
|
||||||
# File syncing capability is disabled by default. This feature is usually not required,
|
|
||||||
# not useful and an extreme performance hit
|
|
||||||
#$ActionFileEnableSync on
|
|
||||||
|
|
||||||
# Include all config files in /etc/rsyslog.d/
|
# Include all config files in /etc/rsyslog.d/
|
||||||
$IncludeConfig /etc/rsyslog.d/*.conf
|
$IncludeConfig /etc/rsyslog.d/*.conf
|
||||||
|
|
||||||
# Turn off message reception via local log socket;
|
|
||||||
# local messages are retrieved through imjournal now.
|
|
||||||
$OmitLocalLogging on
|
|
||||||
|
|
||||||
# File to store the position in the journal
|
|
||||||
$IMJournalStateFile imjournal.state
|
|
||||||
|
|
||||||
|
|
||||||
#### RULES ####
|
#### RULES ####
|
||||||
|
|
||||||
# Log all kernel messages to the console.
|
# Log all kernel messages to the console.
|
||||||
@ -73,19 +65,15 @@ uucp,news.crit /var/log/spooler
|
|||||||
local7.* /var/log/boot.log
|
local7.* /var/log/boot.log
|
||||||
|
|
||||||
|
|
||||||
# ### begin forwarding rule ###
|
# ### sample forwarding rule ###
|
||||||
# The statement between the begin ... end define a SINGLE forwarding
|
#action(type="omfwd"
|
||||||
# rule. They belong together, do NOT split them. If you create multiple
|
|
||||||
# forwarding rules, duplicate the whole block!
|
|
||||||
# Remote Logging (we use TCP for reliable delivery)
|
|
||||||
#
|
|
||||||
# An on-disk queue is created for this action. If the remote host is
|
# An on-disk queue is created for this action. If the remote host is
|
||||||
# down, messages are spooled to disk and sent when it is up again.
|
# down, messages are spooled to disk and sent when it is up again.
|
||||||
#$ActionQueueFileName fwdRule1 # unique name prefix for spool files
|
#queue.filename="fwdRule1" # unique name prefix for spool files
|
||||||
#$ActionQueueMaxDiskSpace 1g # 1gb space limit (use as much as possible)
|
#queue.maxdiskspace="1g" # 1gb space limit (use as much as possible)
|
||||||
#$ActionQueueSaveOnShutdown on # save messages to disk on shutdown
|
#queue.saveonshutdown="on" # save messages to disk on shutdown
|
||||||
#$ActionQueueType LinkedList # run asynchronously
|
#queue.type="LinkedList" # run asynchronously
|
||||||
#$ActionResumeRetryCount -1 # infinite retries if host is down
|
#action.resumeRetryCount="-1" # infinite retries if host is down
|
||||||
# remote host is: name/ip:port, e.g. 192.168.0.1:514, port optional
|
# Remote Logging (we use TCP for reliable delivery)
|
||||||
#*.* @@remote-host:514
|
# remote_host is: name/ip, e.g. 192.168.0.1, port optional e.g. 10514
|
||||||
# ### end of the forwarding rule ###
|
#Target="remote_host" Port="XXX" Protocol="tcp")
|
||||||
|
29
rsyslog.spec
29
rsyslog.spec
@ -8,11 +8,15 @@
|
|||||||
%global want_hiredis 1
|
%global want_hiredis 1
|
||||||
%global want_mongodb 1
|
%global want_mongodb 1
|
||||||
%endif
|
%endif
|
||||||
|
#due to multiple failures of extensive testbench on various archs
|
||||||
|
#and module requirements of certain tests need to have it disabled,
|
||||||
|
#tests execution possible locally on properly set up workstation
|
||||||
|
%global want_testbench 0
|
||||||
|
|
||||||
Summary: Enhanced system logging and kernel message trapping daemon
|
Summary: Enhanced system logging and kernel message trapping daemon
|
||||||
Name: rsyslog
|
Name: rsyslog
|
||||||
Version: 8.24.0
|
Version: 8.24.0
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: (GPLv3+ and ASL 2.0)
|
License: (GPLv3+ and ASL 2.0)
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.rsyslog.com/
|
URL: http://www.rsyslog.com/
|
||||||
@ -52,6 +56,7 @@ Obsoletes: sysklogd < 1.5-11
|
|||||||
Patch0: rsyslog-8.8.0-sd-service.patch
|
Patch0: rsyslog-8.8.0-sd-service.patch
|
||||||
Patch1: rsyslog-8.23.0-msg_c_nonoverwrite_merge.patch
|
Patch1: rsyslog-8.23.0-msg_c_nonoverwrite_merge.patch
|
||||||
Patch2: rsyslog-8.24.0-recover_qi-doc.patch
|
Patch2: rsyslog-8.24.0-recover_qi-doc.patch
|
||||||
|
Patch3: rsyslog-8.24.0-missing-chdir-w-chroot.patch
|
||||||
|
|
||||||
%package crypto
|
%package crypto
|
||||||
Summary: Encryption support
|
Summary: Encryption support
|
||||||
@ -274,6 +279,7 @@ mv build doc
|
|||||||
%setup -q -D
|
%setup -q -D
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
autoreconf -iv
|
autoreconf -iv
|
||||||
|
|
||||||
@ -295,6 +301,9 @@ export HIREDIS_LIBS="-L%{_libdir} -lhiredis"
|
|||||||
%configure \
|
%configure \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
|
%if %{want_testbench}
|
||||||
|
--enable-testbench \
|
||||||
|
%endif
|
||||||
--enable-elasticsearch \
|
--enable-elasticsearch \
|
||||||
--enable-generate-man-pages \
|
--enable-generate-man-pages \
|
||||||
--enable-gnutls \
|
--enable-gnutls \
|
||||||
@ -330,24 +339,17 @@ export HIREDIS_LIBS="-L%{_libdir} -lhiredis"
|
|||||||
--enable-pmaixforwardedfrom \
|
--enable-pmaixforwardedfrom \
|
||||||
--enable-pmcisconames \
|
--enable-pmcisconames \
|
||||||
--enable-pmlastmsg \
|
--enable-pmlastmsg \
|
||||||
--enable-pmrfc3164sd \
|
|
||||||
--enable-pmsnare \
|
--enable-pmsnare \
|
||||||
--enable-relp \
|
--enable-relp \
|
||||||
--enable-snmp \
|
--enable-snmp \
|
||||||
--disable-testbench \
|
|
||||||
--enable-unlimited-select \
|
--enable-unlimited-select \
|
||||||
--enable-usertools \
|
--enable-usertools \
|
||||||
--enable-omkafka \
|
--enable-omkafka \
|
||||||
|
|
||||||
make V=1
|
make V=1
|
||||||
|
|
||||||
# small portion of the test suite seems to be consistently failing (this is more severe on arm*)
|
|
||||||
# there are also some random failures (~1 test out of the whole batch) on i686 and x86_64
|
|
||||||
# thus the test suite is disabled for now until these issues are sorted out
|
|
||||||
%check
|
%check
|
||||||
%if 0
|
|
||||||
make V=1 check
|
make V=1 check
|
||||||
%endif
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make V=1 DESTDIR=%{buildroot} install
|
make V=1 DESTDIR=%{buildroot} install
|
||||||
@ -372,8 +374,9 @@ cp -r doc/* %{buildroot}%{rsyslog_docdir}/html
|
|||||||
rm -f %{buildroot}%{_libdir}/rsyslog/*.la
|
rm -f %{buildroot}%{_libdir}/rsyslog/*.la
|
||||||
# get rid of socket activation by default
|
# get rid of socket activation by default
|
||||||
sed -i '/^Alias/s/^/;/;/^Requires=syslog.socket/s/^/;/' %{buildroot}%{_unitdir}/rsyslog.service
|
sed -i '/^Alias/s/^/;/;/^Requires=syslog.socket/s/^/;/' %{buildroot}%{_unitdir}/rsyslog.service
|
||||||
# imdiag is only used for testing
|
# imdiag and liboverride is only used for testing
|
||||||
rm -f %{buildroot}%{_libdir}/rsyslog/imdiag.so
|
rm -f %{buildroot}%{_libdir}/rsyslog/imdiag.so
|
||||||
|
rm -f %{buildroot}%{_libdir}/rsyslog/liboverride_gethostname.so
|
||||||
|
|
||||||
%post
|
%post
|
||||||
for n in /var/log/{messages,secure,maillog,spooler}
|
for n in /var/log/{messages,secure,maillog,spooler}
|
||||||
@ -534,6 +537,14 @@ done
|
|||||||
%{_libdir}/rsyslog/omkafka.so
|
%{_libdir}/rsyslog/omkafka.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 17 2017 Jiri Vymazal <jvymazal@redhat.com> - 8.24.0-5
|
||||||
|
- new default config, using RainerScript wherever possible
|
||||||
|
resolves: rhbz#1419625
|
||||||
|
- updated testbench guard as testbench now needs explicit configuration
|
||||||
|
see: rhbz#1211194
|
||||||
|
- added patch to make chdir call after chroot
|
||||||
|
resolves: rhbz#1422542
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.24.0-4
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.24.0-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user