diff --git a/rsyslog-3.14.1.legacyOpts.patch b/rsyslog-3.14.1.legacyOpts.patch
new file mode 100644
index 0000000..2c97ba4
--- /dev/null
+++ b/rsyslog-3.14.1.legacyOpts.patch
@@ -0,0 +1,20 @@
+diff -up rsyslog-3.14.1/syslogd.c.legacyOpts rsyslog-3.14.1/syslogd.c
+--- rsyslog-3.14.1/syslogd.c.legacyOpts	2008-04-07 17:15:45.000000000 +0200
++++ rsyslog-3.14.1/syslogd.c	2008-04-07 17:15:49.000000000 +0200
+@@ -1740,6 +1740,7 @@ void legacyOptsHook(void)
+ 
+ 	while(pThis != NULL) {
+ 		if(pThis->line != NULL) {
++			errno = 0;
+ 			errmsg.LogError(NO_ERRCODE, "Warning: backward compatibility layer added to following "
+ 				        "directive to rsyslog.conf: %s", pThis->line);
+ 			conf.cfsysline(pThis->line);
+@@ -3111,7 +3112,7 @@ int realMain(int argc, char **argv)
+ 					legacyOptsEnq((uchar *) "ModLoad imuxsock");
+ 					bImUxSockLoaded = 1;
+ 				}
+-				legacyOptsEnq((uchar *) "OmitLocaLogging");
++				legacyOptsEnq((uchar *) "OmitLocalLogging");
+ 			} else {
+ 				fprintf(stderr, "error -o is no longer supported, use module imuxsock instead");
+ 			}
diff --git a/rsyslog.spec b/rsyslog.spec
index d84912a..f57965e 100644
--- a/rsyslog.spec
+++ b/rsyslog.spec
@@ -3,7 +3,7 @@
 Summary: Enhanced system logging and kernel message trapping daemons
 Name: rsyslog
 Version: 3.14.1
-Release: 4%{?dist}
+Release: 5%{?dist}
 License: GPLv3+
 Group: System Environment/Daemons
 URL: http://www.rsyslog.com/
@@ -14,6 +14,7 @@ Source3: rsyslog.sysconfig
 Patch1: rsyslog-3.11.4-undef.patch
 Patch2: rsyslog-3.14.1-segfaultExprFilt.patch
 Patch3: rsyslog-3.14.1-symbolLookup.patch
+Patch4: rsyslog-3.14.1.legacyOpts.patch
 BuildRequires: zlib-devel
 BuildRequires: autoconf automake
 Requires: logrotate >= 3.5.2
@@ -71,6 +72,7 @@ authentication.
 %patch1 -p1 -b .undef
 %patch2 -p1 -b .segfaultExprFilt
 %patch3 -p1 -b .symbolLookup
+%patch4 -p1 -b .legacyOpts
 
 %build
 %configure	--sbindir=%{sbindir} \
@@ -162,6 +164,10 @@ fi
 %{_libdir}/rsyslog/omgssapi.so
 
 %changelog
+* Tue Apr 08 2008 Peter Vrabec <pvrabec@redhat.com> 3.14.1-5
+- prevent undesired error description in legacy 
+  warning messages
+
 * Tue Apr 08 2008 Peter Vrabec <pvrabec@redhat.com> 3.14.1-4
 - adjust symbol lookup method to 2.6 kernel