- upgrade to new upstream stable version 5.6.2
- drop rsyslog-5.5.7-remove_include.patch; applied upstream - provide omsnmp module - use correct name for the lock file (#659398) - enable specification of the pid file (#579411) - init script adjustments
This commit is contained in:
parent
84ef2a141b
commit
1337b9e20d
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
rsyslog-4.6.3.tar.gz
|
||||
/rsyslog-5.5.7.tar.gz
|
||||
/rsyslog-5.6.2.tar.gz
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff --git a/runtime/nsdpoll_ptcp.c b/runtime/nsdpoll_ptcp.c
|
||||
index 5100670..bc374c6 100644
|
||||
--- a/runtime/nsdpoll_ptcp.c
|
||||
+++ b/runtime/nsdpoll_ptcp.c
|
||||
@@ -42,7 +42,6 @@
|
||||
#include "nspoll.h"
|
||||
#include "nsd_ptcp.h"
|
||||
#include "nsdpoll_ptcp.h"
|
||||
-#include "unlimited_select.h"
|
||||
|
||||
/* static data */
|
||||
DEFobjStaticHelpers
|
||||
diff --git a/runtime/unlimited_select.h b/runtime/unlimited_select.h
|
||||
index 32dadc0..3fa7eb0 100644
|
||||
--- a/runtime/unlimited_select.h
|
||||
+++ b/runtime/unlimited_select.h
|
||||
@@ -23,6 +23,7 @@
|
||||
*/
|
||||
|
||||
#ifndef UNLIMITED_SELECT_H_INCLUDED
|
||||
+#define UNLIMITED_SELECT_H_INCLUDED
|
||||
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
20
rsyslog.init
20
rsyslog.init
@ -1,7 +1,6 @@
|
||||
#!/bin/bash
|
||||
#
|
||||
# rsyslog Starts rsyslogd/rklogd.
|
||||
#
|
||||
# rsyslog Startup script for rsyslog.
|
||||
#
|
||||
# chkconfig: 2345 12 88
|
||||
# description: Syslog is the facility by which many daemons use to log \
|
||||
@ -26,21 +25,22 @@
|
||||
RETVAL=0
|
||||
PIDFILE=/var/run/syslogd.pid
|
||||
|
||||
prog=rsyslogd
|
||||
prog=rsyslog
|
||||
exec=/sbin/rsyslogd
|
||||
lockfile=/var/lock/subsys/$prog
|
||||
|
||||
# Source config
|
||||
if [ -f /etc/sysconfig/$prog ] ; then
|
||||
. /etc/sysconfig/$prog
|
||||
fi
|
||||
|
||||
start() {
|
||||
[ -x $exec ] || exit 5
|
||||
|
||||
# Source config
|
||||
if [ -f /etc/sysconfig/rsyslog ] ; then
|
||||
. /etc/sysconfig/rsyslog
|
||||
fi
|
||||
umask 077
|
||||
|
||||
echo -n $"Starting system logger: "
|
||||
daemon --pidfile="${PIDFILE}" $exec $SYSLOGD_OPTIONS
|
||||
daemon --pidfile="${PIDFILE}" $exec -i "${PIDFILE}" $SYSLOGD_OPTIONS
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && touch $lockfile
|
||||
@ -48,14 +48,14 @@ start() {
|
||||
}
|
||||
stop() {
|
||||
echo -n $"Shutting down system logger: "
|
||||
killproc $prog
|
||||
killproc -p "${PIDFILE}" $exec
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && rm -f $lockfile
|
||||
return $RETVAL
|
||||
}
|
||||
rhstatus() {
|
||||
status -p "${PIDFILE}" $prog
|
||||
status -p "${PIDFILE}" $exec
|
||||
}
|
||||
restart() {
|
||||
stop
|
||||
|
34
rsyslog.spec
34
rsyslog.spec
@ -5,7 +5,7 @@
|
||||
|
||||
Summary: Enhanced system logging and kernel message trapping daemon
|
||||
Name: rsyslog
|
||||
Version: 5.5.7
|
||||
Version: 5.6.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: System Environment/Daemons
|
||||
@ -15,9 +15,6 @@ Source1: rsyslog.init
|
||||
Source2: rsyslog.conf
|
||||
Source3: rsyslog.sysconfig
|
||||
Source4: rsyslog.log
|
||||
# remove redundant '#include' that breaks compilation
|
||||
# sent upstream
|
||||
Patch0: rsyslog-5.5.7-remove_include.patch
|
||||
|
||||
BuildRequires: zlib-devel
|
||||
Requires: logrotate >= 3.5.2
|
||||
@ -60,6 +57,12 @@ Group: System Environment/Daemons
|
||||
Requires: %name = %version-%release
|
||||
BuildRequires: gnutls-devel
|
||||
|
||||
%package snmp
|
||||
Summary: SNMP protocol support for rsyslog
|
||||
Group: System Environment/Daemons
|
||||
Requires: %name = %version-%release
|
||||
BuildRequires: net-snmp-devel
|
||||
|
||||
%description
|
||||
Rsyslog is an enhanced, multi-threaded syslog daemon. It supports MySQL,
|
||||
syslog/TCP, RFC 3195, permitted sender lists, filtering on any message part,
|
||||
@ -91,9 +94,12 @@ The rsyslog-gnutls package contains the rsyslog plugins that provide the
|
||||
ability to receive syslog messages via upcoming syslog-transport-tls
|
||||
IETF standard protocol.
|
||||
|
||||
%description snmp
|
||||
The rsyslog-snmp package contains the rsyslog plugin that provides the
|
||||
ability to send syslog messages as SNMPv1 and SNMPv2c traps.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .removeinclude
|
||||
|
||||
%build
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fpie -DSYSLOGD_PIDNAME=\\\"syslogd.pid\\\""
|
||||
@ -107,6 +113,7 @@ export LDFLAGS="-pie -Wl,-z,relro -Wl,-z,now"
|
||||
--enable-relp \
|
||||
--enable-gnutls \
|
||||
--enable-mail \
|
||||
--enable-snmp \
|
||||
--enable-unlimited-select
|
||||
make
|
||||
|
||||
@ -155,6 +162,11 @@ fi
|
||||
%triggerun -- rsyslog < 3.0.0
|
||||
/bin/kill `cat /var/run/rklogd.pid 2> /dev/null` > /dev/null 2>&1 ||:
|
||||
|
||||
%triggerun -- rsyslog < 5.6.2
|
||||
# previous versions used a different lock file, which would break condrestart
|
||||
[ -f /var/lock/subsys/rsyslogd ] || exit 0
|
||||
mv /var/lock/subsys/rsyslogd /var/lock/subsys/rsyslog
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING NEWS README ChangeLog doc/*html
|
||||
@ -211,7 +223,19 @@ fi
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/rsyslog/lmnsd_gtls.so
|
||||
|
||||
%files snmp
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/rsyslog/omsnmp.so
|
||||
|
||||
%changelog
|
||||
* Mon Dec 20 2010 Tomas Heinrich <theinric@redhat.com> 5.6.2-1
|
||||
- upgrade to new upstream stable version 5.6.2
|
||||
- drop rsyslog-5.5.7-remove_include.patch; applied upstream
|
||||
- provide omsnmp module
|
||||
- use correct name for lock file (#659398)
|
||||
- enable specification of the pid file (#579411)
|
||||
- init script adjustments
|
||||
|
||||
* Wed Oct 06 2010 Tomas Heinrich <theinric@redhat.com> 5.5.7-1
|
||||
- upgrade to upstream version 5.5.7
|
||||
- update configuration and init files for the new major version
|
||||
|
Loading…
Reference in New Issue
Block a user