- upstream bug fix release

- include html docs (#248712)
- make "-r" option compatible with sysklogd config (248982)
This commit is contained in:
Peter Vrabec 2007-07-20 10:43:39 +00:00
parent 3a56da7d5d
commit 031ec0f26a
5 changed files with 34 additions and 106 deletions

View File

@ -1,2 +1,3 @@
rsyslog-1.17.0.tar.gz
rsyslog-1.17.1.tar.gz
rsyslog.init
rsyslog.sysconfig

View File

@ -1,96 +0,0 @@
--- rsyslog-1.17.0/srUtils.c.cleanup 2007-07-17 17:02:23.000000000 +0400
+++ rsyslog-1.17.0/srUtils.c 2007-07-18 11:46:45.000000000 +0400
@@ -153,6 +153,7 @@ int makeFileParentDirs(uchar *szFile, si
*p = '/';
}
free(pszWork);
+ return 0;
}
/*
* vi:set ai:
--- rsyslog-1.17.0/Makefile.am.cleanup 2007-07-18 11:46:59.000000000 +0400
+++ rsyslog-1.17.0/Makefile.am 2007-07-18 11:47:28.000000000 +0400
@@ -1,14 +1,14 @@
-sbin_PROGRAMS=klogd rfc3195d syslogd
+sbin_PROGRAMS=rklogd rfc3195d rsyslogd
-klogd_SOURCES=klogd.c syslog.c pidfile.c ksym.c ksym_mod.c klogd.h ksyms.h pidfile.h module.h
+rklogd_SOURCES=klogd.c syslog.c pidfile.c ksym.c ksym_mod.c klogd.h ksyms.h pidfile.h module.h
rfc3195d_SOURCES=rfc3195d.c rsyslog.h
man_MANS = rfc3195d.8 rklogd.8 rsyslogd.8 rsyslog.conf.5
-syslogd_SOURCES=syslogd.c pidfile.c template.c outchannel.c stringbuf.c srUtils.c parse.c syslogd-types.h template.h outchannel.h syslogd.h stringbuf.h parse.h srUtils.h liblogging-stub.h net.h
-syslogd_CPPFLAGS=$(mysql_includes)
-syslogd_LDADD=$(mysql_libs) $(zlib_libs) $(pthreads_libs)
+rsyslogd_SOURCES=syslogd.c pidfile.c template.c outchannel.c stringbuf.c srUtils.c parse.c syslogd-types.h template.h outchannel.h syslogd.h stringbuf.h parse.h srUtils.h liblogging-stub.h net.h
+rsyslogd_CPPFLAGS=$(mysql_includes)
+rsyslogd_LDADD=$(mysql_libs) $(zlib_libs) $(pthreads_libs)
EXTRA_DIST = doc/bugs.html doc/features.html doc/generic_design.html doc/history.html doc/how2help.html doc/install.html doc/ipv6.html doc/manual.html doc/property_replacer.html doc/rsyslog_conf.html doc/rsyslog_mysql.html doc/rsyslog_packages.html doc/rsyslog_php_syslog_ng.html doc/rsyslog_recording_pri.html doc/rsyslog_stunnel.html doc/status.html doc/syslog-protocol.html doc/version_naming.html doc/contributors.html redhat/rsyslog.conf redhat/rsyslog.init redhat/rsyslog.log redhat/rsyslog.sysconfig debian/rsyslogd freebsd/rsyslogd slackware/rc.rsyslogd rfc3195d.8 rklogd.8 rsyslogd.8 rsyslog.conf.5
--- rsyslog-1.17.0/syslogd.c.cleanup 2007-07-17 18:05:52.000000000 +0400
+++ rsyslog-1.17.0/syslogd.c 2007-07-18 11:46:45.000000000 +0400
@@ -888,7 +888,7 @@ static rsRetVal AddAllowedSenderEntry(st
static rsRetVal AddAllowedSender(struct AllowedSenders **ppRoot, struct AllowedSenders **ppLast,
struct NetAddr *iAllow, uint8_t iSignificantBits)
{
- rsRetVal iRet;
+ rsRetVal iRet = RS_RET_OK;
assert(ppRoot != NULL);
assert(ppLast != NULL);
@@ -1571,7 +1571,7 @@ static void TCPSessAccept(int fd)
int iSess;
struct sockaddr_storage addr;
socklen_t addrlen = sizeof(struct sockaddr_storage);
- int lenHostName;
+ size_t lenHostName;
uchar fromHost[NI_MAXHOST];
uchar fromHostFQDN[NI_MAXHOST];
char *pBuf;
@@ -7452,7 +7452,6 @@ static int doParseOnOffOption(uchar **pp
{
char *pOptStart;
uchar szOpt[32];
- int iRet = -1;
assert(pp != NULL);
assert(*pp != NULL);
@@ -7462,7 +7461,7 @@ static int doParseOnOffOption(uchar **pp
if(getSubString(pp, (char*) szOpt, sizeof(szOpt) / sizeof(uchar), ' ') != 0) {
logerror("Invalid $-configline - could not extract on/off option");
- return;
+ return -1;
}
if(!strcmp(szOpt, "on")) {
@@ -8921,12 +8920,11 @@ static rsRetVal cfline(char *line, regis
f->f_un.f_forw.port = NULL;
if(*p == ':') { /* process port */
- register int i = 0;
uchar * tmp;
*p = '\0'; /* trick to obtain hostname (later)! */
tmp = ++p;
- for( ; *p && isdigit((int) *p) ; ++p, ++i)
+ for(i=0 ; *p && isdigit((int) *p) ; ++p, ++i)
/* SKIP AND COUNT */;
f->f_un.f_forw.port = malloc(i + 1);
if(f->f_un.f_forw.port == NULL) {
--- rsyslog-1.17.0/configure.ac.cleanup 2007-07-17 18:39:59.000000000 +0400
+++ rsyslog-1.17.0/configure.ac 2007-07-18 11:46:45.000000000 +0400
@@ -10,7 +10,9 @@ AC_CONFIG_HEADER([config.h])
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
-
+if test "$GCC" = "yes"
+then CFLAGS="$CFLAGS -W -Wall -Wshadow -Wcast-align -Wpointer-arith -Wmissing-format-attribute -g"
+fi
AC_CANONICAL_HOST
case "${host}" in

View File

@ -0,0 +1,18 @@
--- rsyslog-1.17.1/syslogd.c.rOptionCompat 2007-07-20 10:22:56.000000000 +0200
+++ rsyslog-1.17.1/syslogd.c 2007-07-20 12:34:02.000000000 +0200
@@ -9174,7 +9174,14 @@
case 'x': /* disable dns for remote messages */
DisableDNS = 1;
break;
- case '?':
+ case '?':
+ /* handle "-r" option for compatibility reasons */
+ if(optopt == 'r') {
+ opterr = 0;
+ AcceptRemote = 1;
+ LogPort = "0";
+ break;
+ }
default:
usage();
}

View File

@ -3,14 +3,15 @@
Summary: Enhanced system logging and kernel message trapping daemons
Name: rsyslog
Version: 1.17.0
Version: 1.17.1
Release: 1%{?dist}
License: GPL
Group: System Environment/Daemons
URL: http://www.rsyslog.com/
Source0: http://download.adiscon.com/rsyslog/%{name}-%{version}.tar.gz
Source1: rsyslog.init
Patch1: rsyslog-1.17.0-cleanup.patch
Source2: rsyslog.sysconfig
Patch1: rsyslog-1.17.1-rOptionCompat.patch
Conflicts: logrotate < 3.5.2
%if %{with_db}
BuildRequires: mysql-devel >= 4.0
@ -37,9 +38,7 @@ at the same time being very easy to setup for the novice user.
%prep
%setup -q
%patch1 -p1 -b .cleanup
autoreconf
%patch1 -p1 -b .rOptionCompat
%build
%configure --sbindir=%{sbindir}
@ -56,7 +55,7 @@ install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/rsyslog
install -p -m 644 redhat/rsyslog.conf $RPM_BUILD_ROOT%{_sysconfdir}/rsyslog.conf
install -p -m 644 redhat/rsyslog.log $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/rsyslog
install -p -m 644 redhat/rsyslog.sysconfig $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/rsyslog
install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/rsyslog
%clean
rm -rf $RPM_BUILD_ROOT
@ -89,7 +88,7 @@ fi
%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING INSTALL NEWS README
%doc AUTHORS COPYING INSTALL NEWS README doc
%config(noreplace) %{_sysconfdir}/rsyslog.conf
%config(noreplace) %{_sysconfdir}/sysconfig/rsyslog
%config(noreplace) %{_sysconfdir}/logrotate.d/rsyslog
@ -100,7 +99,12 @@ fi
%{_mandir}/*/*
%changelog
* Thu Jul 17 2007 Peter Vrabec <pvrabec@redhat.com> 1.17.0-1
* Fri Jul 20 2007 Peter Vrabec <pvrabec@redhat.com> 1.17.1-1
- upstream bug fix release
- include html docs (#248712)
- make "-r" option compatible with sysklogd config (248982)
* Tue Jul 17 2007 Peter Vrabec <pvrabec@redhat.com> 1.17.0-1
- feature rich upstream release
* Thu Jul 12 2007 Peter Vrabec <pvrabec@redhat.com> 1.15.1-2

View File

@ -1,2 +1,3 @@
bf138b47f6474d3c2d2320945ba9ac28 rsyslog-1.17.0.tar.gz
a5bd8983f72c836a8f2da707a28b2372 rsyslog-1.17.1.tar.gz
26932048c2b297a1fb7bbb6d0a1edb41 rsyslog.init
6cdadcfd270c58962c9fe560223acf99 rsyslog.sysconfig