Enabling upstream test suite during build rhbz#1533846
This commit is contained in:
parent
0a78243087
commit
ffcb4956de
@ -92,3 +92,56 @@ index c46a8b4..6620563 100644
|
|||||||
|
|
||||||
return open(pathname, flags | O_BINARY, mode);
|
return open(pathname, flags | O_BINARY, mode);
|
||||||
}
|
}
|
||||||
|
Index: rsync/tls.c
|
||||||
|
===================================================================
|
||||||
|
--- rsync.orig/tls.c
|
||||||
|
+++ rsync/tls.c
|
||||||
|
@@ -53,6 +53,7 @@ int preserve_perms = 0;
|
||||||
|
int preserve_executability = 0;
|
||||||
|
int preallocate_files = 0;
|
||||||
|
int inplace = 0;
|
||||||
|
+int noatime = 0;
|
||||||
|
|
||||||
|
#ifdef SUPPORT_XATTRS
|
||||||
|
|
||||||
|
Index: rsync/t_unsafe.c
|
||||||
|
===================================================================
|
||||||
|
--- rsync.orig/t_unsafe.c
|
||||||
|
+++ rsync/t_unsafe.c
|
||||||
|
@@ -33,6 +33,10 @@ int preserve_perms = 0;
|
||||||
|
int preserve_executability = 0;
|
||||||
|
short info_levels[COUNT_INFO], debug_levels[COUNT_DEBUG];
|
||||||
|
|
||||||
|
+/* This is to make syscall.o shut up. */
|
||||||
|
+int noatime = 0;
|
||||||
|
+
|
||||||
|
+
|
||||||
|
int
|
||||||
|
main(int argc, char **argv)
|
||||||
|
{
|
||||||
|
Index: rsync/wildtest.c
|
||||||
|
===================================================================
|
||||||
|
--- rsync.orig/wildtest.c
|
||||||
|
+++ rsync/wildtest.c
|
||||||
|
@@ -32,6 +32,9 @@ int fnmatch_errors = 0;
|
||||||
|
|
||||||
|
int wildmatch_errors = 0;
|
||||||
|
|
||||||
|
+/* This is to make syscall.o shut up. */
|
||||||
|
+int noatime = 0;
|
||||||
|
+
|
||||||
|
typedef char bool;
|
||||||
|
|
||||||
|
int output_iterations = 0;
|
||||||
|
Index: rsync/trimslash.c
|
||||||
|
===================================================================
|
||||||
|
--- rsync.orig/trimslash.c
|
||||||
|
+++ rsync/trimslash.c
|
||||||
|
@@ -30,6 +30,7 @@ int preserve_perms = 0;
|
||||||
|
int preserve_executability = 0;
|
||||||
|
int preallocate_files = 0;
|
||||||
|
int inplace = 0;
|
||||||
|
+int noatime = 0;
|
||||||
|
|
||||||
|
int
|
||||||
|
main(int argc, char **argv)
|
||||||
|
11
rsync.spec
11
rsync.spec
@ -9,7 +9,7 @@
|
|||||||
Summary: A program for synchronizing files over a network
|
Summary: A program for synchronizing files over a network
|
||||||
Name: rsync
|
Name: rsync
|
||||||
Version: 3.1.3
|
Version: 3.1.3
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
URL: http://rsync.samba.org/
|
URL: http://rsync.samba.org/
|
||||||
|
|
||||||
Source0: https://download.samba.org/pub/rsync/src/rsync-%{version}%{?prerelease}.tar.gz
|
Source0: https://download.samba.org/pub/rsync/src/rsync-%{version}%{?prerelease}.tar.gz
|
||||||
@ -60,8 +60,6 @@ package provides the anonymous rsync service.
|
|||||||
%setup -q -b 1
|
%setup -q -b 1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
chmod -x support/*
|
|
||||||
|
|
||||||
#Needed for compatibility with previous patched rsync versions
|
#Needed for compatibility with previous patched rsync versions
|
||||||
patch -p1 -i patches/acls.diff
|
patch -p1 -i patches/acls.diff
|
||||||
patch -p1 -i patches/xattrs.diff
|
patch -p1 -i patches/xattrs.diff
|
||||||
@ -80,6 +78,10 @@ patch -p1 -i patches/copy-devices.diff
|
|||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%check
|
||||||
|
make check
|
||||||
|
chmod -x support/*
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -116,6 +118,9 @@ install -D -m644 %{SOURCE6} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd@.service
|
|||||||
%systemd_postun_with_restart rsyncd.service
|
%systemd_postun_with_restart rsyncd.service
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 10 2019 Michal Ruprich <mruprich@redhat.com> - 3.1.3-10
|
||||||
|
- Enabling upstream test suite during build rhbz#1533846
|
||||||
|
|
||||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.3-9
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.3-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user