rebased to 3.0.7
This commit is contained in:
parent
03ea8e74e1
commit
ab51af2645
@ -1,2 +1,2 @@
|
||||
rsync-3.0.6.tar.gz
|
||||
rsync-patches-3.0.6.tar.gz
|
||||
rsync-3.0.7.tar.gz
|
||||
rsync-patches-3.0.7.tar.gz
|
||||
|
@ -1,28 +0,0 @@
|
||||
diff --git a/generator.c b/generator.c
|
||||
index 8038feb..4abe6a0 100644
|
||||
--- a/generator.c
|
||||
+++ b/generator.c
|
||||
@@ -2034,6 +2034,7 @@ static void touch_up_dirs(struct file_list *flist, int ndx)
|
||||
static int counter = 0;
|
||||
struct file_struct *file;
|
||||
char *fname;
|
||||
+ BOOL retouch_perms;
|
||||
int i, start, end;
|
||||
|
||||
if (ndx < 0) {
|
||||
@@ -2054,11 +2055,13 @@ static void touch_up_dirs(struct file_list *flist, int ndx)
|
||||
rprintf(FINFO, "touch_up_dirs: %s (%d)\n",
|
||||
NS(fname), i);
|
||||
}
|
||||
+ /* Be sure not to retouch permissions with --fake-super. */
|
||||
+ retouch_perms = !am_root && !(file->mode & S_IWUSR);
|
||||
if (!F_IS_ACTIVE(file) || file->flags & FLAG_MISSING_DIR
|
||||
- || (!need_retouch_dir_times && file->mode & S_IWUSR))
|
||||
+ || !(need_retouch_dir_times || retouch_perms))
|
||||
continue;
|
||||
fname = f_name(file, NULL);
|
||||
- if (!(file->mode & S_IWUSR))
|
||||
+ if (retouch_perms)
|
||||
do_chmod(fname, file->mode);
|
||||
if (need_retouch_dir_times) {
|
||||
STRUCT_STAT st;
|
10
rsync.spec
10
rsync.spec
@ -6,15 +6,14 @@
|
||||
|
||||
Summary: A program for synchronizing files over a network
|
||||
Name: rsync
|
||||
Version: 3.0.6
|
||||
Release: 4%{?prerelease}%{?dist}
|
||||
Version: 3.0.7
|
||||
Release: 1%{?prerelease}%{?dist}
|
||||
Group: Applications/Internet
|
||||
URL: http://rsync.samba.org/
|
||||
|
||||
Source0: ftp://rsync.samba.org/pub/rsync/rsync-%{version}%{?prerelease}.tar.gz
|
||||
Source1: ftp://rsync.samba.org/pub/rsync/rsync-patches-%{version}%{?prerelease}.tar.gz
|
||||
Source2: rsync.xinetd
|
||||
Patch0: rsync-3.0.6-permissions.patch
|
||||
BuildRequires: libacl-devel, libattr-devel, autoconf, popt-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
License: GPLv3+
|
||||
@ -48,8 +47,6 @@ patch -p1 -i patches/xattrs.diff
|
||||
#Enable --copy-devices parameter
|
||||
patch -p1 -i patches/copy-devices.diff
|
||||
|
||||
%patch0 -p1 -b .permissions
|
||||
|
||||
%build
|
||||
rm -fr autom4te.cache
|
||||
autoconf
|
||||
@ -77,6 +74,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man5/rsyncd.conf.5*
|
||||
|
||||
%changelog
|
||||
* Tue Jan 19 2010 Jan Zeleny <jzeleny@redhat.com> - 3.0.7-1
|
||||
- rebased to 3.0.7
|
||||
|
||||
* Mon Dec 07 2009 Jan Zeleny <jzeleny@redhat.com> - 3.0.6-4
|
||||
- applied patch to avoid retouching dir permissions (#542679)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user