* Wed Oct 10 2007 Simo Sorce <ssorce@redhat.com> 3.0.0-9pre1.fc9
- New Major version prerelease
This commit is contained in:
parent
faf2ed44a6
commit
8e0fadc012
@ -1,45 +0,0 @@
|
|||||||
--- rsync-2.6.9/flist.c 2007-02-18 19:25:08.000000000 -0500
|
|
||||||
+++ rsync-2.6.9.fix/flist.c 2007-02-18 19:24:38.000000000 -0500
|
|
||||||
@@ -998,7 +998,7 @@
|
|
||||||
file->mode = tweak_mode(file->mode, chmod_modes);
|
|
||||||
|
|
||||||
#ifdef SUPPORT_ACLS
|
|
||||||
- if (preserve_acls) {
|
|
||||||
+ if (preserve_acls && f >= 0) {
|
|
||||||
sx.st.st_mode = file->mode;
|
|
||||||
sx.acc_acl = sx.def_acl = NULL;
|
|
||||||
if (get_acl(fname, &sx) < 0)
|
|
||||||
@@ -1006,7 +1006,7 @@
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
#ifdef SUPPORT_XATTRS
|
|
||||||
- if (preserve_xattrs) {
|
|
||||||
+ if (preserve_xattrs && f >= 0) {
|
|
||||||
sx.xattr = NULL;
|
|
||||||
if (get_xattr(fname, &sx) < 0)
|
|
||||||
return NULL;
|
|
||||||
@@ -1021,20 +1021,20 @@
|
|
||||||
flist->files[flist->count++] = file;
|
|
||||||
send_file_entry(file, f);
|
|
||||||
#ifdef SUPPORT_ACLS
|
|
||||||
- if (preserve_acls)
|
|
||||||
+ if (preserve_acls && f >= 0)
|
|
||||||
send_acl(&sx, f);
|
|
||||||
#endif
|
|
||||||
#ifdef SUPPORT_XATTRS
|
|
||||||
- if (preserve_xattrs)
|
|
||||||
+ if (preserve_xattrs && f >= 0)
|
|
||||||
send_xattr(&sx, f);
|
|
||||||
#endif
|
|
||||||
} else {
|
|
||||||
#ifdef SUPPORT_ACLS
|
|
||||||
- if (preserve_acls)
|
|
||||||
+ if (preserve_acls && f >= 0)
|
|
||||||
free_acl(&sx);
|
|
||||||
#endif
|
|
||||||
#ifdef SUPPORT_XATTRS
|
|
||||||
- if (preserve_xattrs)
|
|
||||||
+ if (preserve_xattrs && f >= 0)
|
|
||||||
free_xattr(&sx);
|
|
||||||
#endif
|
|
||||||
}
|
|
@ -1,12 +0,0 @@
|
|||||||
--- rsync-2.6.9-orig/hlink.c 2007-06-17 11:51:28.000000000 +0200
|
|
||||||
+++ rsync-2.6.9/hlink.c 2007-06-17 11:58:22.000000000 +0200
|
|
||||||
@@ -315,6 +315,9 @@ void hard_link_cluster(struct file_struc
|
|
||||||
if (file->F_HLINDEX != SKIPPED_LINK)
|
|
||||||
continue;
|
|
||||||
hlink2 = f_name(file, NULL);
|
|
||||||
+#ifdef SUPPORT_ACLS
|
|
||||||
+ sx.acc_acl = sx.def_acl = NULL;
|
|
||||||
+#endif
|
|
||||||
statret = link_stat(hlink2, &sx.st, 0);
|
|
||||||
maybe_hard_link(file, ndx, hlink2, statret, &sx,
|
|
||||||
hlink1, &st, itemizing, code);
|
|
26
rsync.spec
26
rsync.spec
@ -1,18 +1,16 @@
|
|||||||
Summary: A program for synchronizing files over a network.
|
Summary: A program for synchronizing files over a network.
|
||||||
Name: rsync
|
Name: rsync
|
||||||
Version: 2.6.9
|
Version: 3.0.0
|
||||||
Release: 3.1%{?dist}
|
Release: 0.pre1%{?dist}
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
# TAG: for pre versions use
|
# TAG: for pre versions use
|
||||||
#Source: ftp://rsync.samba.org/pub/rsync/rsync-%{version}pre1.tar.gz
|
Source: ftp://rsync.samba.org/pub/rsync/rsync-%{version}pre1.tar.gz
|
||||||
Source: ftp://rsync.samba.org/pub/rsync/rsync-%{version}.tar.gz
|
#Source: ftp://rsync.samba.org/pub/rsync/rsync-%{version}.tar.gz
|
||||||
Source1: rsync.xinetd
|
Source1: rsync.xinetd
|
||||||
Patch1: rsync-2.6.9-acl-xattr-delete-bug.patch
|
|
||||||
Patch2: rsync-2.6.9-hlink-segv.patch
|
|
||||||
BuildRequires: libacl-devel, libattr-devel, autoconf, make, gcc, popt-devel
|
BuildRequires: libacl-devel, libattr-devel, autoconf, make, gcc, popt-devel
|
||||||
Prefix: %{_prefix}
|
Prefix: %{_prefix}
|
||||||
BuildRoot: /var/tmp/%{name}-root
|
BuildRoot: /var/tmp/%{name}-root
|
||||||
License: GPLv2+
|
License: GPLv3+
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Rsync uses a reliable algorithm to bring remote and host files into
|
Rsync uses a reliable algorithm to bring remote and host files into
|
||||||
@ -25,19 +23,18 @@ package.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
# TAG: for pre versions use
|
# TAG: for pre versions use
|
||||||
# % setup -q -n rsync-%{version}pre1
|
%setup -q -n rsync-%{version}pre1
|
||||||
%setup -q
|
#%setup -q
|
||||||
|
|
||||||
|
#Needed for compatibility with previous patched rsync versions
|
||||||
patch -p1 < patches/acls.diff
|
patch -p1 < patches/acls.diff
|
||||||
patch -p1 < patches/xattrs.diff
|
patch -p1 < patches/xattrs.diff
|
||||||
%patch1 -p1 -b .acl_xattrs_bug
|
|
||||||
%patch2 -p1 -b .hlink_segv
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
rm -fr autom4te.cache
|
rm -fr autom4te.cache
|
||||||
autoconf
|
autoconf
|
||||||
autoheader
|
autoheader
|
||||||
%configure \
|
%configure
|
||||||
--enable-acl-support --enable-xattr-support
|
|
||||||
make proto
|
make proto
|
||||||
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
|
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
|
||||||
|
|
||||||
@ -60,6 +57,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man5/rsyncd.conf.5*
|
%{_mandir}/man5/rsyncd.conf.5*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 10 2007 Simo Sorce <ssorce@redhat.com> 3.0.0-9pre1.fc9
|
||||||
|
- New Major version prerelease
|
||||||
|
|
||||||
* Wed Sep 5 2007 Simo Sorce <ssorce@redhat.com> 2.6.9-3.fc8
|
* Wed Sep 5 2007 Simo Sorce <ssorce@redhat.com> 2.6.9-3.fc8
|
||||||
- Add patch to fix crash bug with hardlinks and ACLs patches
|
- Add patch to fix crash bug with hardlinks and ACLs patches
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user