New pre-release version 3.2.4pre3
This commit is contained in:
parent
7a6a31c17e
commit
6b23e4a16d
2
.gitignore
vendored
2
.gitignore
vendored
@ -14,3 +14,5 @@ rsync-patches-3.0.8.tar.gz
|
||||
/rsync-patches-3.2.2.tar.gz
|
||||
/rsync-3.2.3.tar.gz
|
||||
/rsync-patches-3.2.3.tar.gz
|
||||
/rsync-3.2.4pre3.tar.gz
|
||||
/rsync-patches-3.2.4pre3.tar.gz
|
||||
|
@ -1,22 +0,0 @@
|
||||
From Mon Sep 17 00:00:00 2001
|
||||
From: Matt McCutchen <matt@mattmccutchen.net>
|
||||
Date: Wed, 26 Aug 2020 12:16:08 -0400
|
||||
|
||||
rsync-ssl: Verify the hostname in the certificate when using openssl.
|
||||
---
|
||||
rsync-ssl | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/rsync-ssl b/rsync-ssl
|
||||
index 8101975a..46701af1 100755
|
||||
--- a/rsync-ssl
|
||||
+++ b/rsync-ssl
|
||||
@@ -129,7 +129,7 @@ function rsync_ssl_helper {
|
||||
fi
|
||||
|
||||
if [[ $RSYNC_SSL_TYPE == openssl ]]; then
|
||||
- exec $RSYNC_SSL_OPENSSL s_client $caopt $certopt -quiet -verify_quiet -servername $hostname -connect $hostname:$port
|
||||
+ exec $RSYNC_SSL_OPENSSL s_client $caopt $certopt -quiet -verify_quiet -servername $hostname -verify_hostname $hostname -connect $hostname:$port
|
||||
elif [[ $RSYNC_SSL_TYPE == gnutls ]]; then
|
||||
exec $RSYNC_SSL_GNUTLS --logfile=/dev/null $gnutls_cert_opt $gnutls_opts $hostname:$port
|
||||
else
|
@ -1,53 +0,0 @@
|
||||
diff --git a/syscall.c b/syscall.c
|
||||
index b9c3b4ef..11d10e4a 100644
|
||||
--- a/syscall.c
|
||||
+++ b/syscall.c
|
||||
@@ -227,27 +227,35 @@ int do_open(const char *pathname, int flags, mode_t mode)
|
||||
#ifdef HAVE_CHMOD
|
||||
int do_chmod(const char *path, mode_t mode)
|
||||
{
|
||||
+ static int switch_step = 0;
|
||||
int code;
|
||||
if (dry_run) return 0;
|
||||
RETURN_ERROR_IF_RO_OR_LO;
|
||||
+ switch (switch_step) {
|
||||
#ifdef HAVE_LCHMOD
|
||||
- code = lchmod(path, mode & CHMOD_BITS);
|
||||
-#else
|
||||
- if (S_ISLNK(mode)) {
|
||||
+#include "case_N.h"
|
||||
+ if ((code = lchmod(path, mode & CHMOD_BITS)) == 0 || errno != ENOTSUP)
|
||||
+ break;
|
||||
+ switch_step++;
|
||||
+#endif
|
||||
+
|
||||
+#include "case_N.h"
|
||||
+ if (S_ISLNK(mode)) {
|
||||
# if defined HAVE_SETATTRLIST
|
||||
- struct attrlist attrList;
|
||||
- uint32_t m = mode & CHMOD_BITS; /* manpage is wrong: not mode_t! */
|
||||
+ struct attrlist attrList;
|
||||
+ uint32_t m = mode & CHMOD_BITS; /* manpage is wrong: not mode_t! */
|
||||
|
||||
- memset(&attrList, 0, sizeof attrList);
|
||||
- attrList.bitmapcount = ATTR_BIT_MAP_COUNT;
|
||||
- attrList.commonattr = ATTR_CMN_ACCESSMASK;
|
||||
- code = setattrlist(path, &attrList, &m, sizeof m, FSOPT_NOFOLLOW);
|
||||
+ memset(&attrList, 0, sizeof attrList);
|
||||
+ attrList.bitmapcount = ATTR_BIT_MAP_COUNT;
|
||||
+ attrList.commonattr = ATTR_CMN_ACCESSMASK;
|
||||
+ code = setattrlist(path, &attrList, &m, sizeof m, FSOPT_NOFOLLOW);
|
||||
# else
|
||||
- code = 1;
|
||||
+ code = 1;
|
||||
# endif
|
||||
- } else
|
||||
- code = chmod(path, mode & CHMOD_BITS); /* DISCOURAGED FUNCTION */
|
||||
-#endif /* !HAVE_LCHMOD */
|
||||
+ } else
|
||||
+ code = chmod(path, mode & CHMOD_BITS); /* DISCOURAGED FUNCTION */
|
||||
+ break;
|
||||
+ }
|
||||
if (code != 0 && (preserve_perms || preserve_executability))
|
||||
return code;
|
||||
return 0;
|
40
rsync-3.2.4-hello-test.patch
Normal file
40
rsync-3.2.4-hello-test.patch
Normal file
@ -0,0 +1,40 @@
|
||||
diff --git a/testsuite/00-hello.test b/testsuite/00-hello.test
|
||||
index a359753..ec0279a 100644
|
||||
--- a/testsuite/00-hello.test
|
||||
+++ b/testsuite/00-hello.test
|
||||
@@ -15,7 +15,7 @@ $RSYNC --info=help || test_fail '--info=help output failed'
|
||||
|
||||
$RSYNC --debug=help || test_fail '--debug=help output failed'
|
||||
|
||||
-weird_name="A weird)name"
|
||||
+weird_name="Aweirdname"
|
||||
|
||||
mkdir "$fromdir"
|
||||
mkdir "$fromdir/$weird_name"
|
||||
@@ -29,7 +29,7 @@ append_line test1
|
||||
checkit "$RSYNC -ai '$fromdir/' '$todir/'" "$fromdir" "$todir"
|
||||
|
||||
copy_weird() {
|
||||
- checkit "$RSYNC $1 \"$2$fromdir/$weird_name/\" \"$3$todir/$weird_name\"" "$fromdir" "$todir"
|
||||
+ checkit "$RSYNC $1 --rsync-path='$RSYNC' '$2$fromdir/$weird_name/' '$3$todir/$weird_name'" "$fromdir" "$todir"
|
||||
}
|
||||
|
||||
append_line test2
|
||||
@@ -47,7 +47,7 @@ copy_weird '-ais' '' 'lh:'
|
||||
echo test6
|
||||
|
||||
touch "$fromdir/one" "$fromdir/two"
|
||||
-(cd "$fromdir" && $RSYNC -ai --old-args lh:'one two' "$todir/")
|
||||
+(cd "$fromdir" && $RSYNC -ai --old-args --rsync-path="$RSYNC" lh:'one two' "$todir/")
|
||||
if [ ! -f "$todir/one" ] || [ ! -f "$todir/two" ]; then
|
||||
test_fail "old-args copy of 'one two' failed"
|
||||
fi
|
||||
@@ -55,7 +55,7 @@ fi
|
||||
echo test7
|
||||
|
||||
rm "$todir/one" "$todir/two"
|
||||
-(cd "$fromdir" && RSYNC_OLD_ARGS=1 $RSYNC -ai lh:'one two' "$todir/")
|
||||
+(cd "$fromdir" && RSYNC_OLD_ARGS=1 $RSYNC -ai --rsync-path="$RSYNC" lh:'one two' "$todir/")
|
||||
|
||||
# The script would have aborted on error, so getting here means we've won.
|
||||
exit 0
|
20
rsync.spec
20
rsync.spec
@ -1,15 +1,15 @@
|
||||
%global _hardened_build 1
|
||||
|
||||
%define isprerelease 0
|
||||
%define isprerelease 1
|
||||
|
||||
%if %isprerelease
|
||||
%define prerelease pre1
|
||||
%define prerelease pre3
|
||||
%endif
|
||||
|
||||
Summary: A program for synchronizing files over a network
|
||||
Name: rsync
|
||||
Version: 3.2.3
|
||||
Release: 14%{?dist}
|
||||
Version: 3.2.4
|
||||
Release: 1%{?prerelease}%{?dist}
|
||||
URL: https://rsync.samba.org/
|
||||
|
||||
Source0: https://download.samba.org/pub/rsync/src/rsync-%{version}%{?prerelease}.tar.gz
|
||||
@ -36,11 +36,8 @@ BuildRequires: xxhash-devel
|
||||
Provides: bundled(zlib) = 1.2.8
|
||||
License: GPLv3+
|
||||
|
||||
#Added temporarily until new rebase
|
||||
Patch0: rsync-3.2.2-ssl-verify-hostname.patch
|
||||
#Added due to rhbz#1873975 - default-acls test fail on s390x due to libacl
|
||||
Patch1: rsync-3.2.2-runtests.patch
|
||||
Patch2: rsync-3.2.3-lchmod.patch
|
||||
Patch2: rsync-3.2.4-hello-test.patch
|
||||
|
||||
%description
|
||||
Rsync uses a reliable algorithm to bring remote and host files into
|
||||
@ -74,9 +71,9 @@ package provides the anonymous rsync service.
|
||||
#Enable --copy-devices parameter
|
||||
patch -p1 -i patches/copy-devices.diff
|
||||
|
||||
%patch0 -p1 -b .verify-hostname
|
||||
#%patch0 -p1 -b .verify-hostname
|
||||
%patch1 -p1 -b .runtests
|
||||
%patch2 -p1 -b .lchmod
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -127,6 +124,9 @@ install -D -m644 %{SOURCE6} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd@.service
|
||||
%systemd_postun_with_restart rsyncd.service
|
||||
|
||||
%changelog
|
||||
* Wed Mar 16 2022 Michal Ruprich <mruprich@redhat.com> - 3.2.4-1pre3
|
||||
- New pre-release version 3.2.4pre3
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.3-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (rsync-3.2.3.tar.gz) = 48b68491f3ef644dbbbfcaec5ab90a1028593e02d50367ce161fd9d3d0bd0a3628bc57c5e5dec4be3a1d213f784f879b8a8fcdfd789ba0f99837cba16e1ae70e
|
||||
SHA512 (rsync-patches-3.2.3.tar.gz) = cd2fb128021bfad0d3d1cb1f92e0f2d726498a14a3a1c6bdc6ffad6130db84a79d20a240ea8ac3942c19af5da2f1e54a89791c9952c805c2e7e491b1da82a9ec
|
||||
SHA512 (rsync-3.2.4pre3.tar.gz) = a780069e7260bc269722a127a689d0eb2fc2afffe37b4da8aaa58ff8d226912358ee32120dd47bb606ca18a584bb40ac84ea61ca92430de388d4636419cb831f
|
||||
SHA512 (rsync-patches-3.2.4pre3.tar.gz) = 03cbda9af5b5cf743bf460290926df7664542885be057a272b73caafc83ca2142d696e5c5d81bd87097f08c98da86bbc99e08a6dffe92ac1f05610a24af4c6e2
|
||||
|
Loading…
Reference in New Issue
Block a user