New version 3.2.3
Removed upstream patches acls.diff and xattrs.diff
This commit is contained in:
parent
fe80ea9596
commit
47694dc954
2
.gitignore
vendored
2
.gitignore
vendored
@ -12,3 +12,5 @@ rsync-patches-3.0.8.tar.gz
|
|||||||
/rsync-patches-3.1.3.tar.gz
|
/rsync-patches-3.1.3.tar.gz
|
||||||
/rsync-3.2.2.tar.gz
|
/rsync-3.2.2.tar.gz
|
||||||
/rsync-patches-3.2.2.tar.gz
|
/rsync-patches-3.2.2.tar.gz
|
||||||
|
/rsync-3.2.3.tar.gz
|
||||||
|
/rsync-patches-3.2.3.tar.gz
|
||||||
|
12
rsync-3.2.2-runtests.patch
Normal file
12
rsync-3.2.2-runtests.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/runtests.sh.old b/runtests.sh
|
||||||
|
index ecb383e..1cd1d1a 100755
|
||||||
|
--- a/runtests.sh.old
|
||||||
|
+++ b/runtests.sh
|
||||||
|
@@ -276,6 +276,7 @@ do
|
||||||
|
|
||||||
|
case "$testscript" in
|
||||||
|
*hardlinks*) TESTRUN_TIMEOUT=600 ;;
|
||||||
|
+ *default-acls*) continue ;;
|
||||||
|
*) TESTRUN_TIMEOUT=300 ;;
|
||||||
|
esac
|
||||||
|
|
22
rsync-3.2.2-ssl-verify-hostname.patch
Normal file
22
rsync-3.2.2-ssl-verify-hostname.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
From Mon Sep 17 00:00:00 2001
|
||||||
|
From: Matt McCutchen <matt@mattmccutchen.net>
|
||||||
|
Date: Wed, 26 Aug 2020 12:16:08 -0400
|
||||||
|
|
||||||
|
rsync-ssl: Verify the hostname in the certificate when using openssl.
|
||||||
|
---
|
||||||
|
rsync-ssl | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/rsync-ssl b/rsync-ssl
|
||||||
|
index 8101975a..46701af1 100755
|
||||||
|
--- a/rsync-ssl
|
||||||
|
+++ b/rsync-ssl
|
||||||
|
@@ -129,7 +129,7 @@ function rsync_ssl_helper {
|
||||||
|
fi
|
||||||
|
|
||||||
|
if [[ $RSYNC_SSL_TYPE == openssl ]]; then
|
||||||
|
- exec $RSYNC_SSL_OPENSSL s_client $caopt $certopt -quiet -verify_quiet -servername $hostname -connect $hostname:$port
|
||||||
|
+ exec $RSYNC_SSL_OPENSSL s_client $caopt $certopt -quiet -verify_quiet -servername $hostname -verify_hostname $hostname -connect $hostname:$port
|
||||||
|
elif [[ $RSYNC_SSL_TYPE == gnutls ]]; then
|
||||||
|
exec $RSYNC_SSL_GNUTLS --logfile=/dev/null $gnutls_cert_opt $gnutls_opts $hostname:$port
|
||||||
|
else
|
20
rsync.spec
20
rsync.spec
@ -8,8 +8,8 @@
|
|||||||
|
|
||||||
Summary: A program for synchronizing files over a network
|
Summary: A program for synchronizing files over a network
|
||||||
Name: rsync
|
Name: rsync
|
||||||
Version: 3.2.2
|
Version: 3.2.3
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://rsync.samba.org/
|
URL: http://rsync.samba.org/
|
||||||
|
|
||||||
Source0: https://download.samba.org/pub/rsync/src/rsync-%{version}%{?prerelease}.tar.gz
|
Source0: https://download.samba.org/pub/rsync/src/rsync-%{version}%{?prerelease}.tar.gz
|
||||||
@ -27,6 +27,11 @@ BuildRequires: lz4-devel openssl-devel libzstd-devel
|
|||||||
Provides: bundled(zlib) = 1.2.8
|
Provides: bundled(zlib) = 1.2.8
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
|
|
||||||
|
#Added temporarily until new rebase
|
||||||
|
Patch0: rsync-3.2.2-ssl-verify-hostname.patch
|
||||||
|
#Added due to rhbz#1873975 - default-acls test fail on s390x due to libacl
|
||||||
|
Patch1: rsync-3.2.2-runtests.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Rsync uses a reliable algorithm to bring remote and host files into
|
Rsync uses a reliable algorithm to bring remote and host files into
|
||||||
sync very quickly. Rsync is fast because it just sends the differences
|
sync very quickly. Rsync is fast because it just sends the differences
|
||||||
@ -56,13 +61,12 @@ package provides the anonymous rsync service.
|
|||||||
%setup -q -b 1
|
%setup -q -b 1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#Needed for compatibility with previous patched rsync versions
|
|
||||||
patch -p1 -i patches/acls.diff
|
|
||||||
patch -p1 -i patches/xattrs.diff
|
|
||||||
|
|
||||||
#Enable --copy-devices parameter
|
#Enable --copy-devices parameter
|
||||||
patch -p1 -i patches/copy-devices.diff
|
patch -p1 -i patches/copy-devices.diff
|
||||||
|
|
||||||
|
%patch0 -p1 -b .verify-hostname
|
||||||
|
%patch1 -p1 -b .runtests
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
%configure --disable-xxhash
|
%configure --disable-xxhash
|
||||||
@ -112,6 +116,10 @@ install -D -m644 %{SOURCE6} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd@.service
|
|||||||
%systemd_postun_with_restart rsyncd.service
|
%systemd_postun_with_restart rsyncd.service
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 31 2020 Michal Ruprich <mruprich@redhat.com> - 3.2.3-1
|
||||||
|
- New version 3.2.3
|
||||||
|
- Removed upstream patches acls.diff and xattrs.diff
|
||||||
|
|
||||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.2-3
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.2-3
|
||||||
- Second attempt - Rebuilt for
|
- Second attempt - Rebuilt for
|
||||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (rsync-3.2.2.tar.gz) = 78107cf423e9259a7f7e9bf5527a956b648107aba72ea88b4267ae6334539342501d3c060efbc87235563b0253a12c382c4bb1f73335e68a62ff53aa905f9169
|
SHA512 (rsync-3.2.3.tar.gz) = 48b68491f3ef644dbbbfcaec5ab90a1028593e02d50367ce161fd9d3d0bd0a3628bc57c5e5dec4be3a1d213f784f879b8a8fcdfd789ba0f99837cba16e1ae70e
|
||||||
SHA512 (rsync-patches-3.2.2.tar.gz) = 1d80790e571c48d867c3ec6d9286f0920629db057a13b9106a4e8ee6648a1a27e8e8363e96d78223c45c7ed95d359f532487b0430dc534f350c5b27ee26cc481
|
SHA512 (rsync-patches-3.2.3.tar.gz) = cd2fb128021bfad0d3d1cb1f92e0f2d726498a14a3a1c6bdc6ffad6130db84a79d20a240ea8ac3942c19af5da2f1e54a89791c9952c805c2e7e491b1da82a9ec
|
||||||
|
Loading…
Reference in New Issue
Block a user