Upstream 3.1.0 pre release
Fixed: #495310 - rsync contains forked copy of zlib Fixed: #926459 - building aarch64 Fixed: bogus dates in changelog
This commit is contained in:
parent
797e5b9f3e
commit
0de59c3585
2
.gitignore
vendored
2
.gitignore
vendored
@ -2,3 +2,5 @@ rsync-3.0.8.tar.gz
|
||||
rsync-patches-3.0.8.tar.gz
|
||||
/rsync-3.0.9.tar.gz
|
||||
/rsync-patches-3.0.9.tar.gz
|
||||
/rsync-3.1.0pre1.tar.gz
|
||||
/rsync-patches-3.1.0pre1.tar.gz
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- rsync-3.0.9/flist.c 2011-08-27 23:58:04.000000000 +0200
|
||||
+++ rsync-3.0.9/flist.c 2012-10-16 13:25:30.201627611 +0200
|
||||
@@ -369,7 +369,7 @@
|
||||
pathname = dir;
|
||||
pathname_len = dirlen;
|
||||
|
||||
- if (!dir)
|
||||
+ if (!dir || (*dir=='.' && dirlen==1))
|
||||
dir = orig_dir;
|
||||
|
||||
if (!change_dir(dir, CD_NORMAL)) {
|
@ -1,22 +0,0 @@
|
||||
--- ./util.c 2011-04-23 00:51:55.000000000 +0200
|
||||
+++ ./util.c 2013-06-14 15:10:21.381102268 +0200
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
extern int verbose;
|
||||
extern int module_id;
|
||||
+extern int protect_args;
|
||||
extern int modify_window;
|
||||
extern int relative_paths;
|
||||
extern int preserve_times;
|
||||
@@ -719,6 +720,11 @@
|
||||
if (strncmp(arg, base, base_len) == 0)
|
||||
arg += base_len;
|
||||
|
||||
+ if (protect_args) {
|
||||
+ glob_expand(arg, argv_p, argc_p, maxargs_p);
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
if (!(arg = strdup(arg)))
|
||||
out_of_memory("glob_expand_module");
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- rsync-3.0.9/rsync.1 2011-09-23 18:42:26.000000000 +0200
|
||||
+++ rsync-3.0.9/rsync.1 2012-09-19 10:40:19.698802861 +0200
|
||||
@@ -438,6 +438,7 @@
|
||||
@@ -442,6 +442,7 @@
|
||||
\-o, \-\-owner preserve owner (super\-user only)
|
||||
\-g, \-\-group preserve group
|
||||
\-\-devices preserve device files (super\-user only)
|
||||
@ -8,14 +8,3 @@
|
||||
\-\-specials preserve special files
|
||||
\-D same as \-\-devices \-\-specials
|
||||
\-t, \-\-times preserve modification times
|
||||
|
||||
--- rsync-3.0.9/options.c 2012-09-18 13:33:27.085255598 +0200
|
||||
+++ rsync-3.0.9/options.c 2012-09-19 10:50:00.500816340 +0200
|
||||
@@ -432,6 +432,7 @@
|
||||
#ifdef ICONV_OPTION
|
||||
rprintf(F," --iconv=CONVERT_SPEC request charset conversion of filenames\n");
|
||||
#endif
|
||||
+ rprintf(F," --checksum-seed=NUM set block/file checksum seed (advanced)\n");
|
||||
rprintf(F," -4, --ipv4 prefer IPv4\n");
|
||||
rprintf(F," -6, --ipv6 prefer IPv6\n");
|
||||
rprintf(F," --version print version number\n");
|
||||
|
28
rsync.spec
28
rsync.spec
@ -1,4 +1,4 @@
|
||||
%define isprerelease 0
|
||||
%define isprerelease 1
|
||||
|
||||
%if %isprerelease
|
||||
%define prerelease pre1
|
||||
@ -6,8 +6,8 @@
|
||||
|
||||
Summary: A program for synchronizing files over a network
|
||||
Name: rsync
|
||||
Version: 3.0.9
|
||||
Release: 12%{?prerelease}%{?dist}
|
||||
Version: 3.1.0
|
||||
Release: 1%{?prerelease}%{?dist}
|
||||
Group: Applications/Internet
|
||||
URL: http://rsync.samba.org/
|
||||
|
||||
@ -24,9 +24,7 @@ Requires(preun): systemd-units
|
||||
Requires(postun): systemd-units
|
||||
License: GPLv3+
|
||||
|
||||
Patch0: rsync-3.0.10-lose-track.patch
|
||||
Patch1: rsync-man.patch
|
||||
Patch2: rsync-3.1.0-protect_args.patch
|
||||
Patch0: rsync-man.patch
|
||||
|
||||
%description
|
||||
Rsync uses a reliable algorithm to bring remote and host files into
|
||||
@ -57,16 +55,16 @@ patch -p1 -i patches/xattrs.diff
|
||||
#Enable --copy-devices parameter
|
||||
patch -p1 -i patches/copy-devices.diff
|
||||
|
||||
%patch0 -p1 -b .lose-track
|
||||
%patch1 -p1 -b .man
|
||||
%patch2 -p1 -b .protect_args
|
||||
%patch0 -p1 -b .man
|
||||
|
||||
|
||||
%build
|
||||
rm -fr autom4te.cache
|
||||
autoconf -o configure.sh
|
||||
autoheader && touch config.h.in
|
||||
|
||||
%configure
|
||||
%configure \
|
||||
--with-included-zlib=no
|
||||
|
||||
make proto
|
||||
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
|
||||
@ -105,6 +103,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%systemd_postun_with_restart rsyncd.service
|
||||
|
||||
%changelog
|
||||
* Wed Aug 07 2013 Michal Luscon <mluscon@redhat.com> - 3.1.0-1pre1
|
||||
- Upstream 3.1.0 pre release
|
||||
- Fixed: #495310 - rsync contains forked copy of zlib
|
||||
- Fixed: #926459 - building aarch64
|
||||
- Fixed: bogus dates in changelog
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.9-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
@ -397,10 +401,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Mon Mar 11 2003 Hardy Merrill <hmerrill@redhat.com> 2.5.6-4
|
||||
* Tue Mar 11 2003 Hardy Merrill <hmerrill@redhat.com> 2.5.6-4
|
||||
- rebuild in new build env
|
||||
|
||||
* Mon Mar 11 2003 Hardy Merrill <hmerrill@redhat.com> 2.5.6-3
|
||||
* Tue Mar 11 2003 Hardy Merrill <hmerrill@redhat.com> 2.5.6-3
|
||||
- fixed changelog comments
|
||||
|
||||
* Mon Mar 10 2003 Hardy Merrill <hmerrill@redhat.com> 2.5.6-2
|
||||
|
Loading…
Reference in New Issue
Block a user