rrdtool/rrdtool-1.4.7-ruby-2-fix.patch
Jaroslav Škarvada c26af4989f Fixed build failure
Resolves: rhbz#926037
2013-03-25 11:17:41 +01:00

21 lines
1.6 KiB
Diff

diff -up rrdtool-1.4.7/bindings/Makefile.in.origs rrdtool-1.4.7/bindings/Makefile.in
--- rrdtool-1.4.7/bindings/Makefile.in.origs 2012-01-24 11:09:10.000000000 +0100
+++ rrdtool-1.4.7/bindings/Makefile.in 2013-03-18 14:48:23.074370021 +0100
@@ -659,14 +659,12 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COM
install-data-local:
$(AM_V_GEN)test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
$(AM_V_GEN)test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
- $(AM_V_GEN)test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+ $(AM_V_GEN)test -f ruby/Makefile && $(MKDIR_P) $(DESTDIR)$(libdir)/ruby/vendor_ruby && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)" install || true
$(AM_V_GEN)test -d python/build && cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
# rules for building the ruby module
-# RUBYARCHDIR= is to work around in a makefile quirk not sure
-# it is is the right thing todo, but it makes rrdtool build on freebsd as well
ruby: Makefile
- cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) RUBYARCHDIR=
+ cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)"
# rules for building the pyton module
python: Makefile