New version
Resolves: rhbz#1328651 - Dropped lua-5.2 and arm-crash-fix patches (upstreamed) - Updated ruby-2-fix patch
This commit is contained in:
parent
2a77b2d142
commit
f4b0d26bb2
@ -1,13 +0,0 @@
|
|||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 6d74a26..6b5742c 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -248,6 +248,8 @@ AC_FUNC_VPRINTF
|
|
||||||
|
|
||||||
AC_C_BIGENDIAN
|
|
||||||
|
|
||||||
+AC_TYPE_LONG_LONG_INT
|
|
||||||
+
|
|
||||||
dnl for each function found we get a definition in config.h
|
|
||||||
dnl of the form HAVE_FUNCTION
|
|
||||||
|
|
@ -1,31 +0,0 @@
|
|||||||
diff --git a/bindings/lua/rrdlua.c b/bindings/lua/rrdlua.c
|
|
||||||
index bfbc174..b54f787 100644
|
|
||||||
--- a/bindings/lua/rrdlua.c
|
|
||||||
+++ b/bindings/lua/rrdlua.c
|
|
||||||
@@ -350,7 +350,7 @@ set_info (lua_State * L)
|
|
||||||
|
|
||||||
/**********************************************************/
|
|
||||||
|
|
||||||
-static const struct luaL_reg rrd[] = {
|
|
||||||
+static const struct luaL_Reg rrd[] = {
|
|
||||||
{"create", lua_rrd_create},
|
|
||||||
{"dump", lua_rrd_dump},
|
|
||||||
{"fetch", lua_rrd_fetch},
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 1a84037..4575f00 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -813,7 +813,12 @@ LUA_EOF
|
|
||||||
LIBS=
|
|
||||||
lua_havelib=no
|
|
||||||
LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
|
|
||||||
- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
|
|
||||||
+ if test "$lua_vndot" -ge "52"; then
|
|
||||||
+ CALL_FUNC=lua_callk
|
|
||||||
+ else
|
|
||||||
+ CALL_FUNC=lua_call
|
|
||||||
+ fi
|
|
||||||
+ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
|
|
||||||
[AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
|
|
||||||
[lua_havelib=LUA$lua_vndot],
|
|
||||||
[AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,
|
|
@ -22,5 +22,5 @@ index 54f5c23..ee85c23 100644
|
|||||||
+ $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" \
|
+ $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" \
|
||||||
+ rubyhdrdir="$(includedir)" includedir="$(includedir)" RUBYARCHDIR= )
|
+ rubyhdrdir="$(includedir)" includedir="$(includedir)" RUBYARCHDIR= )
|
||||||
|
|
||||||
# rules for building the pyton module
|
# rules for building the python module
|
||||||
python:
|
python:
|
18
rrdtool.spec
18
rrdtool.spec
@ -16,7 +16,7 @@
|
|||||||
|
|
||||||
Summary: Round Robin Database Tool to store and display time-series data
|
Summary: Round Robin Database Tool to store and display time-series data
|
||||||
Name: rrdtool
|
Name: rrdtool
|
||||||
Version: 1.5.6
|
Version: 1.6.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ with exceptions
|
License: GPLv2+ with exceptions
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
@ -26,11 +26,9 @@ Source1: php4-%{svnrev}.tar.gz
|
|||||||
Patch1: rrdtool-1.4.4-php54.patch
|
Patch1: rrdtool-1.4.4-php54.patch
|
||||||
# disable logo for php 5.5.
|
# disable logo for php 5.5.
|
||||||
Patch2: rrdtool-1.4.7-php55.patch
|
Patch2: rrdtool-1.4.7-php55.patch
|
||||||
Patch3: rrdtool-1.5.4-ruby-2-fix.patch
|
Patch3: rrdtool-1.6.0-ruby-2-fix.patch
|
||||||
Patch4: rrdtool-1.5.4-lua-5.2.patch
|
|
||||||
# enable php bindings on ppc
|
# enable php bindings on ppc
|
||||||
Patch5: rrdtool-1.4.8-php-ppc-fix.patch
|
Patch4: rrdtool-1.4.8-php-ppc-fix.patch
|
||||||
Patch6: rrdtool-1.5.3-arm-crash-fix.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: dejavu-sans-mono-fonts
|
Requires: dejavu-sans-mono-fonts
|
||||||
@ -175,9 +173,7 @@ The %{name}-lua package includes RRDtool bindings for Lua.
|
|||||||
%if %{?rhel} %{?!rhel:7} > 6
|
%if %{?rhel} %{?!rhel:7} > 6
|
||||||
%patch3 -p1 -b .ruby-2-fix
|
%patch3 -p1 -b .ruby-2-fix
|
||||||
%endif
|
%endif
|
||||||
%patch4 -p1 -b .lua-52
|
%patch4 -p1 -b .php-ppc-fix
|
||||||
%patch5 -p1 -b .php-ppc-fix
|
|
||||||
%patch6 -p1 -b .arm-crash-fix
|
|
||||||
|
|
||||||
# Fix to find correct python dir on lib64
|
# Fix to find correct python dir on lib64
|
||||||
perl -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
|
perl -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
|
||||||
@ -397,6 +393,12 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} php -n \
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 20 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 1.6.0-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1328651
|
||||||
|
- Dropped lua-5.2 and arm-crash-fix patches (upstreamed)
|
||||||
|
- Updated ruby-2-fix patch
|
||||||
|
|
||||||
* Tue Apr 19 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 1.5.6-1
|
* Tue Apr 19 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 1.5.6-1
|
||||||
- New version
|
- New version
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user