New version

Resolves: rhbz#1147901
- Dropped imginfo-check patch (upstreamed)
- De-fuzzified patches
This commit is contained in:
Jaroslav Škarvada 2014-09-30 16:05:39 +02:00
parent 8fb224e4ce
commit 5c673d27f8
7 changed files with 245 additions and 261 deletions

View File

@ -1,31 +0,0 @@
diff --git a/bindings/lua/rrdlua.c b/bindings/lua/rrdlua.c
index 690ba29..839833a 100644
--- a/bindings/lua/rrdlua.c
+++ b/bindings/lua/rrdlua.c
@@ -342,7 +342,7 @@ set_info (lua_State * L)
/**********************************************************/
-static const struct luaL_reg rrd[] = {
+static const struct luaL_Reg rrd[] = {
{"create", lua_rrd_create},
{"dump", lua_rrd_dump},
{"fetch", lua_rrd_fetch},
diff --git a/configure.ac b/configure.ac
index 2ff18a8..4993717 100644
--- a/configure.ac
+++ b/configure.ac
@@ -734,7 +734,12 @@ LUA_EOF
LIBS=
lua_havelib=no
LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
+ if test "$lua_vndot" = "52"; then
+ CALL_FUNC=lua_callk
+ else
+ CALL_FUNC=lua_call
+ fi
+ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
[AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
[lua_havelib=LUA$lua_vndot],
[AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,

View File

@ -1,68 +0,0 @@
diff -up rrdtool-1.4.8/src/rrd_graph.c.orig2 rrdtool-1.4.8/src/rrd_graph.c
--- rrdtool-1.4.8/src/rrd_graph.c.orig2 2013-05-23 09:55:07.000000000 +0200
+++ rrdtool-1.4.8/src/rrd_graph.c 2013-06-03 15:56:35.820593192 +0200
@@ -4022,6 +4022,12 @@ rrd_info_t *rrd_graph_v(
char *path;
char *filename;
+ if (bad_format_imginfo(im.imginfo)) {
+ rrd_info_free(im.grinfo);
+ im_free(&im);
+ rrd_set_error("bad format for imginfo");
+ return NULL;
+ }
path = strdup(im.graphfile);
filename = basename(path);
info.u_str =
@@ -4827,6 +4833,51 @@ int bad_format(
}
+int bad_format_imginfo(
+ char *fmt)
+{
+ char *ptr;
+ int n = 0;
+
+ ptr = fmt;
+ while (*ptr != '\0')
+ if (*ptr++ == '%') {
+
+ /* line cannot end with percent char */
+ if (*ptr == '\0')
+ return 1;
+ /* '%%' is allowed */
+ if (*ptr == '%')
+ ptr++;
+ /* '%s', '%S' are allowed */
+ else if (*ptr == 's' || *ptr == 'S') {
+ n = 1;
+ ptr++;
+ }
+
+ /* or else '% 4lu' and such are allowed */
+ else {
+ /* optional padding character */
+ if (*ptr == ' ')
+ ptr++;
+ /* This should take care of 'm' */
+ while (*ptr >= '0' && *ptr <= '9')
+ ptr++;
+ /* 'lu' must follow here */
+ if (*ptr++ != 'l')
+ return 1;
+ if (*ptr == 'u')
+ ptr++;
+ else
+ return 1;
+ n++;
+ }
+ }
+
+ return (n != 3);
+}
+
+
int vdef_parse(
struct graph_desc_t
*gdes,

View File

@ -1,18 +1,5 @@
diff --git a/configure.ac b/configure.ac
index 059ca8b..2ff18a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -772,7 +772,7 @@ LUA_EOF
done
fi
- LUA_RRD_LIBDIR="$langpref/lib/lua/$lua_vdot"
+ LUA_RRD_LIBDIR="$libdir/lua/$lua_vdot"
# if lua 5.0 can't find compat-5.1, force installation of
# compat-5.1.lua together with RRDtool.
if test "$lua_vdot" = "5.0" -a "$LUA_HAVE_COMPAT51" != "HAVE_COMPAT51"; then
diff --git a/bindings/tcl/Makefile.am b/bindings/tcl/Makefile.am
index c0e8b0f..265191d 100644
index 265191d..35ce191 100644
--- a/bindings/tcl/Makefile.am
+++ b/bindings/tcl/Makefile.am
@@ -27,8 +27,9 @@ tclpkgdir = @TCL_PACKAGE_DIR@
@ -27,3 +14,16 @@ index c0e8b0f..265191d 100644
endif
# Automake doen't like `tclrrd$(VERSION)$(TCL_SHLIB_SUFFIX)' as
diff --git a/configure.ac b/configure.ac
index 9e93459..3ef1bef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -774,7 +774,7 @@ LUA_EOF
done
fi
- LUA_RRD_LIBDIR="$langpref/lib/lua/$lua_vdot"
+ LUA_RRD_LIBDIR="$libdir/lua/$lua_vdot"
# if lua 5.0 can't find compat-5.1, force installation of
# compat-5.1.lua together with RRDtool.
if test "$lua_vdot" = "5.0" -a "$LUA_HAVE_COMPAT51" != "HAVE_COMPAT51"; then

View File

@ -1,9 +1,58 @@
diff -up rrdtool-1.4.8/doc/rrdtool.html.orig4 rrdtool-1.4.8/doc/rrdtool.html
--- rrdtool-1.4.8/doc/rrdtool.html.orig4 2013-05-23 09:55:51.000000000 +0200
+++ rrdtool-1.4.8/doc/rrdtool.html 2013-07-01 10:51:11.150276130 +0200
@@ -105,6 +105,12 @@ PHP, etc.</p>
<p>Create a graph from data stored in one or several RRDs. Apart from
generating graphs, data can also be extracted to stdout. Check <a href="././rrdgraph.html">the rrdgraph manpage</a>.</p>
diff --git a/doc/rrdtool.1 b/doc/rrdtool.1
index 0e9c3ca..10079cc 100644
--- a/doc/rrdtool.1
+++ b/doc/rrdtool.1
@@ -187,6 +187,10 @@ Operationally equivalent to \fBupdate\fR except for output. Check rrdupdate.
.IX Item "graph"
Create a graph from data stored in one or several RRDs. Apart from
generating graphs, data can also be extracted to stdout. Check rrdgraph.
+.IP "\fBgraphv\fR" 8
+.IX Item "graphv"
+Create a graph from data stored in one or several RRDs. Same as graph, but
+metadata are printed before the graph. Check rrdgraph.
.IP "\fBdump\fR" 8
.IX Item "dump"
Dump the contents of an \s-1RRD\s0 in plain \s-1ASCII.\s0 In connection with restore
@@ -202,13 +206,20 @@ uses fetch to retrieve its data from an \s-1RRD.\s0 Check rrdfetch.
.IP "\fBtune\fR" 8
.IX Item "tune"
Alter setup of an \s-1RRD.\s0 Check rrdtune.
+.IP "\fBfirst\fR" 8
+.IX Item "first"
+Find the first update time of an \s-1RRD\s0. Check rrdfirst.
.IP "\fBlast\fR" 8
.IX Item "last"
Find the last update time of an \s-1RRD.\s0 Check rrdlast.
+.IP "\fBlastupdate\fR" 8
+.IX Item "lastupdate"
+Find the last update time of an \s-1RRD\s0. It also returns the value stored for each
+datum in the most recent update. Check rrdlastupdate.
.IP "\fBinfo\fR" 8
.IX Item "info"
Get information about an \s-1RRD.\s0 Check rrdinfo.
-.IP "\fBrrdresize\fR" 8
+.IP "\fBresize\fR" 8
.IX Item "rrdresize"
Change the size of individual RRAs. This is dangerous! Check rrdresize.
.IP "\fBxport\fR" 8
@@ -217,10 +228,6 @@ Export data retrieved from one or several RRDs. Check rrdxport.
.IP "\fBflushcached\fR" 8
.IX Item "flushcached"
Flush the values for a specific \s-1RRD\s0 file from memory. Check rrdflushcached.
-.IP "\fBrrdcgi\fR" 8
-.IX Item "rrdcgi"
-This is a standalone tool for producing \s-1RRD\s0 graphs on the fly. Check
-rrdcgi.
.SS "\s-1HOW DOES RRDTOOL WORK\s0?"
.IX Subsection "HOW DOES RRDTOOL WORK?"
.IP "Data Acquisition" 8
diff --git a/doc/rrdtool.html b/doc/rrdtool.html
index 404b140..5c40029 100644
--- a/doc/rrdtool.html
+++ b/doc/rrdtool.html
@@ -59,6 +59,13 @@
<p>Create a graph from data stored in one or several RRDs. Apart from generating graphs, data can also be extracted to stdout. Check <a href="./rrdgraph.html">rrdgraph</a>.</p>
</dd>
+<dt><strong><a name="graphv" class="item"><strong>graphv</strong></a></strong></dt>
+
@ -11,22 +60,24 @@ diff -up rrdtool-1.4.8/doc/rrdtool.html.orig4 rrdtool-1.4.8/doc/rrdtool.html
+<p>Create a graph from data stored in one or several RRDs. Same as graph, but
+metadata are printed before the graph. Check <a href="././rrdgraph.html">the rrdgraph manpage</a>.</p>
+</dd>
<dt><strong><a name="dump" class="item"><strong>dump</strong></a></strong></dt>
+
<dt id="dump"><b>dump</b></dt>
<dd>
@@ -83,19 +90,31 @@
<p>Alter setup of an RRD. Check <a href="./rrdtune.html">rrdtune</a>.</p>
<dd>
@@ -128,17 +134,28 @@ uses fetch to retrieve its data from an
<dd>
<p>Alter setup of an RRD. Check <a href="././rrdtune.html">the rrdtune manpage</a>.</p>
</dd>
+<dt><strong><a name="first" class="item"><strong>first</strong></a></strong></dt>
+
+<dd>
+<p>Find the first update time of an RRD. Check <a href="././rrdfirst.html">the rrdfirst manpage</a>.</p>
+</dd>
<dt><strong><a name="last" class="item"><strong>last</strong></a></strong></dt>
<dt id="last"><b>last</b></dt>
<dd>
<p>Find the last update time of an RRD. Check <a href="././rrdlast.html">the rrdlast manpage</a>.</p>
<p>Find the last update time of an RRD. Check <a href="./rrdlast.html">rrdlast</a>.</p>
</dd>
+<dt><strong><a name="lastupdate" class="item"><strong>lastupdate</strong></a></strong></dt>
+
@ -34,33 +85,36 @@ diff -up rrdtool-1.4.8/doc/rrdtool.html.orig4 rrdtool-1.4.8/doc/rrdtool.html
+<p>Find the last update time of an RRD. It also returns the value stored for each
+datum in the most recent update. Check <a href="././rrdlastupdate.html">the rrdlastupdate manpage</a>.</p>
+</dd>
<dt><strong><a name="info" class="item"><strong>info</strong></a></strong></dt>
+
<dt id="info"><b>info</b></dt>
<dd>
<dd>
<p>Get information about an RRD. Check <a href="././rrdinfo.html">the rrdinfo manpage</a>.</p>
</dd>
-<dt><strong><a name="rrdresize" class="item"><strong>rrdresize</strong></a></strong></dt>
+<dt><strong><a name="resize" class="item"><strong>resize</strong></a></strong></dt>
<p>Get information about an RRD. Check <a href="./rrdinfo.html">rrdinfo</a>.</p>
<dd>
<p>Change the size of individual RRAs. This is dangerous! Check <a href="././rrdresize.html">the rrdresize manpage</a>.</p>
@@ -153,12 +170,6 @@ uses fetch to retrieve its data from an
<dd>
<p>Flush the values for a specific RRD file from memory. Check <a href="././rrdflushcached.html">the rrdflushcached manpage</a>.</p>
</dd>
-<dt><strong><a name="rrdcgi" class="item"><strong>rrdcgi</strong></a></strong></dt>
-
-<dt id="rrdresize"><b>rrdresize</b></dt>
+<dt id="resize"><b>rrdresize</b></dt>
<dd>
<p>Change the size of individual RRAs. This is dangerous! Check <a href="./rrdresize.html">rrdresize</a>.</p>
@@ -113,12 +132,6 @@
<p>Flush the values for a specific RRD file from memory. Check <a href="./rrdflushcached.html">rrdflushcached</a>.</p>
</dd>
-<dt id="rrdcgi"><b>rrdcgi</b></dt>
-<dd>
-<p>This is a standalone tool for producing RRD graphs on the fly. Check
-<a href="././rrdcgi.html">the rrdcgi manpage</a>.</p>
-
-<p>This is a standalone tool for producing RRD graphs on the fly. Check <a href="./rrdcgi.html">rrdcgi</a>.</p>
-
-</dd>
</dl>
<p>
</p>
diff -up rrdtool-1.4.8/doc/rrdtool.pod.orig4 rrdtool-1.4.8/doc/rrdtool.pod
--- rrdtool-1.4.8/doc/rrdtool.pod.orig4 2013-05-23 09:55:07.000000000 +0200
+++ rrdtool-1.4.8/doc/rrdtool.pod 2013-07-01 10:53:44.366207403 +0200
@@ -58,6 +58,11 @@ Operationally equivalent to B<update> ex
<h2 id="HOW-DOES-RRDTOOL-WORK">HOW DOES RRDTOOL WORK?</h2>
diff --git a/doc/rrdtool.pod b/doc/rrdtool.pod
index 14394cf..fc31478 100644
--- a/doc/rrdtool.pod
+++ b/doc/rrdtool.pod
@@ -58,6 +58,11 @@ Operationally equivalent to B<update> except for output. Check L<rrdupdate>.
Create a graph from data stored in one or several RRDs. Apart from
generating graphs, data can also be extracted to stdout. Check L<rrdgraph>.
@ -72,7 +126,7 @@ diff -up rrdtool-1.4.8/doc/rrdtool.pod.orig4 rrdtool-1.4.8/doc/rrdtool.pod
=item B<dump>
Dump the contents of an RRD in plain ASCII. In connection with restore
@@ -77,15 +82,24 @@ uses fetch to retrieve its data from an
@@ -77,15 +82,24 @@ uses fetch to retrieve its data from an RRD. Check L<rrdfetch>.
Alter setup of an RRD. Check L<rrdtune>.
@ -98,7 +152,7 @@ diff -up rrdtool-1.4.8/doc/rrdtool.pod.orig4 rrdtool-1.4.8/doc/rrdtool.pod
Change the size of individual RRAs. This is dangerous! Check L<rrdresize>.
@@ -97,11 +111,6 @@ Export data retrieved from one or severa
@@ -97,11 +111,6 @@ Export data retrieved from one or several RRDs. Check L<rrdxport>.
Flush the values for a specific RRD file from memory. Check L<rrdflushcached>.
@ -110,9 +164,10 @@ diff -up rrdtool-1.4.8/doc/rrdtool.pod.orig4 rrdtool-1.4.8/doc/rrdtool.pod
=back
=head2 HOW DOES RRDTOOL WORK?
diff -up rrdtool-1.4.8/doc/rrdtool.txt.orig4 rrdtool-1.4.8/doc/rrdtool.txt
--- rrdtool-1.4.8/doc/rrdtool.txt.orig4 2013-05-23 09:55:56.000000000 +0200
+++ rrdtool-1.4.8/doc/rrdtool.txt 2013-07-01 10:59:33.167060537 +0200
diff --git a/doc/rrdtool.txt b/doc/rrdtool.txt
index 1505291..e90d29b 100644
--- a/doc/rrdtool.txt
+++ b/doc/rrdtool.txt
@@ -48,6 +48,10 @@ DDEESSCCRRIIPPTTIIOONN
from generating graphs, data can also be extracted to stdout.
Check rrdgraph.
@ -153,78 +208,55 @@ diff -up rrdtool-1.4.8/doc/rrdtool.txt.orig4 rrdtool-1.4.8/doc/rrdtool.txt
HHOOWW DDOOEESS RRRRDDTTOOOOLL WWOORRKK??
Data Acquisition
When monitoring the state of a system, it is convenient to have
diff -up rrdtool-1.4.8/doc/rrdtool.1.orig4 rrdtool-1.4.8/doc/rrdtool.1
--- rrdtool-1.4.8/doc/rrdtool.1.orig4 2013-05-23 09:55:53.000000000 +0200
+++ rrdtool-1.4.8/doc/rrdtool.1 2013-07-01 10:51:26.645269268 +0200
@@ -178,6 +178,10 @@ Operationally equivalent to \fBupdate\fR
.IX Item "graph"
Create a graph from data stored in one or several RRDs. Apart from
generating graphs, data can also be extracted to stdout. Check rrdgraph.
+.IP "\fBgraphv\fR" 8
+.IX Item "graphv"
+Create a graph from data stored in one or several RRDs. Same as graph, but
+metadata are printed before the graph. Check rrdgraph.
.IP "\fBdump\fR" 8
.IX Item "dump"
Dump the contents of an \s-1RRD\s0 in plain \s-1ASCII\s0. In connection with restore
@@ -193,13 +197,20 @@ uses fetch to retrieve its data from an
.IP "\fBtune\fR" 8
.IX Item "tune"
Alter setup of an \s-1RRD\s0. Check rrdtune.
+.IP "\fBfirst\fR" 8
+.IX Item "first"
+Find the first update time of an \s-1RRD\s0. Check rrdfirst.
.IP "\fBlast\fR" 8
.IX Item "last"
Find the last update time of an \s-1RRD\s0. Check rrdlast.
+.IP "\fBlastupdate\fR" 8
+.IX Item "lastupdate"
+Find the last update time of an \s-1RRD\s0. It also returns the value stored for each
+datum in the most recent update. Check rrdlastupdate.
.IP "\fBinfo\fR" 8
.IX Item "info"
Get information about an \s-1RRD\s0. Check rrdinfo.
-.IP "\fBrrdresize\fR" 8
+.IP "\fBresize\fR" 8
.IX Item "rrdresize"
Change the size of individual RRAs. This is dangerous! Check rrdresize.
.IP "\fBxport\fR" 8
@@ -208,10 +219,6 @@ Export data retrieved from one or severa
.IP "\fBflushcached\fR" 8
.IX Item "flushcached"
Flush the values for a specific \s-1RRD\s0 file from memory. Check rrdflushcached.
-.IP "\fBrrdcgi\fR" 8
-.IX Item "rrdcgi"
-This is a standalone tool for producing \s-1RRD\s0 graphs on the fly. Check
-rrdcgi.
.SS "\s-1HOW\s0 \s-1DOES\s0 \s-1RRDTOOL\s0 \s-1WORK\s0?"
.IX Subsection "HOW DOES RRDTOOL WORK?"
.IP "Data Acquisition" 8
diff -up rrdtool-1.4.8/doc/rrdupdate.html.orig4 rrdtool-1.4.8/doc/rrdupdate.html
--- rrdtool-1.4.8/doc/rrdupdate.html.orig4 2013-05-23 09:55:50.000000000 +0200
+++ rrdtool-1.4.8/doc/rrdupdate.html 2013-07-01 11:01:44.550003526 +0200
@@ -41,7 +41,7 @@
<h1><a name="synopsis">SYNOPSIS</a></h1>
<p><strong>rrdtool</strong> {<strong>update</strong> | <strong>updatev</strong>} <em>filename</em>
[<strong>--template</strong>|<strong>-t</strong>&nbsp;<em>ds-name</em>[<strong>:</strong><em>ds-name</em>]...]
-[<strong>--daemon</strong>&nbsp;<em>address</em>] [<strong>--</strong>]
+[<strong>--daemon</strong>|<strong>-d</strong>&nbsp;<em>address</em>] [<strong>--</strong>]
<strong>N</strong>|<em>timestamp</em><strong>:</strong><em>value</em>[<strong>:</strong><em>value</em>...]
<em>at-timestamp</em><strong>@</strong><em>value</em>[<strong>:</strong><em>value</em>...]
[<em>timestamp</em><strong>:</strong><em>value</em>[<strong>:</strong><em>value</em>...]&nbsp;...]</p>
@@ -93,7 +93,7 @@ function. If this is done accidentally (
using the template switch), <strong>RRDtool</strong> will ignore the value specified
for the COMPUTE <strong>DST</strong>.</p>
</dd>
-<dt><strong><a name="daemon_address" class="item"><strong>--daemon</strong> <em>address</em></a></strong></dt>
+<dt><strong><a name="daemon_address" class="item"><strong>--daemon</strong>|<strong>-d</strong> <em>address</em></a></strong></dt>
diff --git a/doc/rrdupdate.1 b/doc/rrdupdate.1
index 85e19c8..6fb87b2 100644
--- a/doc/rrdupdate.1
+++ b/doc/rrdupdate.1
@@ -144,7 +144,7 @@ rrdupdate \- Store a new set of values into the RRD
.IX Header "SYNOPSIS"
\&\fBrrdtool\fR {\fBupdate\fR | \fBupdatev\fR} \fIfilename\fR
[\fB\-\-template\fR|\fB\-t\fR\ \fIds-name\fR[\fB:\fR\fIds-name\fR]...]
-[\fB\-\-daemon\fR\ \fIaddress\fR] [\fB\-\-\fR]
+[\fB\-\-daemon\fR|\fB\-d\fR\ \fIaddress\fR] [\fB\-\-\fR]
\&\fBN\fR|\fItimestamp\fR\fB:\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]
\&\fIat-timestamp\fR\fB@\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]
[\fItimestamp\fR\fB:\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]\ ...]
@@ -191,7 +191,7 @@ Do not specify a value for a \s-1COMPUTE \s0\fB\s-1DST\s0\fR in the \fBupdate\fR
function. If this is done accidentally (and this can only be done
using the template switch), \fBRRDtool\fR will ignore the value specified
for the \s-1COMPUTE \s0\fB\s-1DST\s0\fR.
-.IP "\fB\-\-daemon\fR \fIaddress\fR" 8
+.IP "\fB\-\-daemon\fR|\fB\-d\fR\ \fIaddress\fR" 8
.IX Item "--daemon address"
If given, \fBRRDTool\fR will try to connect to the caching daemon rrdcached
at \fIaddress\fR and will fail if the connection cannot be established. If the
diff --git a/doc/rrdupdate.html b/doc/rrdupdate.html
index 4f88d02..b5161e3 100644
--- a/doc/rrdupdate.html
+++ b/doc/rrdupdate.html
@@ -17,7 +17,7 @@
<h1 id="SYNOPSIS">SYNOPSIS</h1>
-<p><b>rrdtool</b> {<b>update</b> | <b>updatev</b>} <i>filename</i> <span style="white-space: nowrap;">[<b>--template</b>|<b>-t</b> <i>ds-name</i>[<b>:</b><i>ds-name</i>]...]</span> <span style="white-space: nowrap;">[<b>--daemon</b> <i>address</i>]</span> [<b>--</b>] <span style="white-space: nowrap;"><b>N</b>|<i>timestamp</i><b>:</b><i>value</i>[<b>:</b><i>value</i>...]</span> <span style="white-space: nowrap;"><i>at-timestamp</i><b>@</b><i>value</i>[<b>:</b><i>value</i>...]</span> <span style="white-space: nowrap;">[<i>timestamp</i><b>:</b><i>value</i>[<b>:</b><i>value</i>...] ...]</span></p>
+<p><b>rrdtool</b> {<b>update</b> | <b>updatev</b>} <i>filename</i> <span style="white-space: nowrap;">[<b>--template</b>|<b>-t</b> <i>ds-name</i>[<b>:</b><i>ds-name</i>]...]</span> <span style="white-space: nowrap;">[<b>--daemon</b>|<b>-d</b> <i>address</i>]</span> [<b>--</b>] <span style="white-space: nowrap;"><b>N</b>|<i>timestamp</i><b>:</b><i>value</i>[<b>:</b><i>value</i>...]</span> <span style="white-space: nowrap;"><i>at-timestamp</i><b>@</b><i>value</i>[<b>:</b><i>value</i>...]</span> <span style="white-space: nowrap;">[<i>timestamp</i><b>:</b><i>value</i>[<b>:</b><i>value</i>...] ...]</span></p>
<h1 id="DESCRIPTION">DESCRIPTION</h1>
@@ -51,7 +51,7 @@
<p>Do not specify a value for a COMPUTE <b>DST</b> in the <b>update</b> function. If this is done accidentally (and this can only be done using the template switch), <b>RRDtool</b> will ignore the value specified for the COMPUTE <b>DST</b>.</p>
</dd>
-<dt id="daemon-address"><b>--daemon</b> <i>address</i></dt>
+<dt id="daemon-address"><b>--daemon</b>|<b>-d</b> <i>address</i></dt>
<dd>
<p>If given, <strong>RRDTool</strong> will try to connect to the caching daemon <a href="././rrdcached.html">the rrdcached manpage</a>
diff -up rrdtool-1.4.8/doc/rrdupdate.pod.orig4 rrdtool-1.4.8/doc/rrdupdate.pod
--- rrdtool-1.4.8/doc/rrdupdate.pod.orig4 2013-05-23 09:55:07.000000000 +0200
+++ rrdtool-1.4.8/doc/rrdupdate.pod 2013-07-01 11:03:03.399968652 +0200
@@ -6,7 +6,7 @@ rrdupdate - Store a new set of values in
<p>If given, <b>RRDTool</b> will try to connect to the caching daemon <a href="./rrdcached.html">rrdcached</a> at <i>address</i> and will fail if the connection cannot be established. If the connection is successfully established the values will be sent to the daemon instead of accessing the files directly.</p>
diff --git a/doc/rrdupdate.pod b/doc/rrdupdate.pod
index d09e5f0..ffdbdbc 100644
--- a/doc/rrdupdate.pod
+++ b/doc/rrdupdate.pod
@@ -6,7 +6,7 @@ rrdupdate - Store a new set of values into the RRD
B<rrdtool> {B<update> | B<updatev>} I<filename>
S<[B<--template>|B<-t> I<ds-name>[B<:>I<ds-name>]...]>
@ -233,7 +265,7 @@ diff -up rrdtool-1.4.8/doc/rrdupdate.pod.orig4 rrdtool-1.4.8/doc/rrdupdate.pod
S<B<N>|I<timestamp>B<:>I<value>[B<:>I<value>...]>
S<I<at-timestamp>B<@>I<value>[B<:>I<value>...]>
S<[I<timestamp>B<:>I<value>[B<:>I<value>...] ...]>
@@ -60,7 +60,7 @@ function. If this is done accidentally (
@@ -60,7 +60,7 @@ function. If this is done accidentally (and this can only be done
using the template switch), B<RRDtool> will ignore the value specified
for the COMPUTE B<DST>.
@ -242,9 +274,10 @@ diff -up rrdtool-1.4.8/doc/rrdupdate.pod.orig4 rrdtool-1.4.8/doc/rrdupdate.pod
If given, B<RRDTool> will try to connect to the caching daemon L<rrdcached>
at I<address> and will fail if the connection cannot be established. If the
diff -up rrdtool-1.4.8/doc/rrdupdate.txt.orig4 rrdtool-1.4.8/doc/rrdupdate.txt
--- rrdtool-1.4.8/doc/rrdupdate.txt.orig4 2013-05-23 09:55:55.000000000 +0200
+++ rrdtool-1.4.8/doc/rrdupdate.txt 2013-07-01 11:05:34.620978121 +0200
diff --git a/doc/rrdupdate.txt b/doc/rrdupdate.txt
index 083c13f..dc66440 100644
--- a/doc/rrdupdate.txt
+++ b/doc/rrdupdate.txt
@@ -7,7 +7,7 @@ NNAAMMEE
SSYYNNOOPPSSIISS
@ -263,24 +296,3 @@ diff -up rrdtool-1.4.8/doc/rrdupdate.txt.orig4 rrdtool-1.4.8/doc/rrdupdate.txt
If given, RRRRDDTTooooll will try to connect to the caching daemon
rrdcached at _a_d_d_r_e_s_s and will fail if the connection cannot be
established. If the connection is successfully established the
diff -up rrdtool-1.4.8/doc/rrdupdate.1.orig4 rrdtool-1.4.8/doc/rrdupdate.1
--- rrdtool-1.4.8/doc/rrdupdate.1.orig4 2013-05-23 09:55:52.000000000 +0200
+++ rrdtool-1.4.8/doc/rrdupdate.1 2013-07-01 10:43:39.179478104 +0200
@@ -135,7 +135,7 @@ rrdupdate \- Store a new set of values i
.IX Header "SYNOPSIS"
\&\fBrrdtool\fR {\fBupdate\fR | \fBupdatev\fR} \fIfilename\fR
[\fB\-\-template\fR|\fB\-t\fR\ \fIds-name\fR[\fB:\fR\fIds-name\fR]...]
-[\fB\-\-daemon\fR\ \fIaddress\fR] [\fB\-\-\fR]
+[\fB\-\-daemon\fR|\fB\-d\fR\ \fIaddress\fR] [\fB\-\-\fR]
\&\fBN\fR|\fItimestamp\fR\fB:\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]
\&\fIat-timestamp\fR\fB@\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]
[\fItimestamp\fR\fB:\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]\ ...]
@@ -182,7 +182,7 @@ Do not specify a value for a \s-1COMPUTE
function. If this is done accidentally (and this can only be done
using the template switch), \fBRRDtool\fR will ignore the value specified
for the \s-1COMPUTE\s0 \fB\s-1DST\s0\fR.
-.IP "\fB\-\-daemon\fR \fIaddress\fR" 8
+.IP "\fB\-\-daemon\fR|\fB\-d\fR \fIaddress\fR" 8
.IX Item "--daemon address"
If given, \fBRRDTool\fR will try to connect to the caching daemon rrdcached
at \fIaddress\fR and will fail if the connection cannot be established. If the

View File

@ -0,0 +1,68 @@
diff --git a/bindings/lua/rrdlua.c b/bindings/lua/rrdlua.c
index 690ba29..839833a 100644
--- a/bindings/lua/rrdlua.c
+++ b/bindings/lua/rrdlua.c
@@ -342,7 +342,7 @@ set_info (lua_State * L)
/**********************************************************/
-static const struct luaL_reg rrd[] = {
+static const struct luaL_Reg rrd[] = {
{"create", lua_rrd_create},
{"dump", lua_rrd_dump},
{"fetch", lua_rrd_fetch},
diff --git a/configure.ac b/configure.ac
index 3ef1bef..187e127 100644
--- a/configure.ac
+++ b/configure.ac
@@ -736,7 +736,12 @@ LUA_EOF
LIBS=
lua_havelib=no
LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
+ if test "$lua_vndot" = "52"; then
+ CALL_FUNC=lua_callk
+ else
+ CALL_FUNC=lua_call
+ fi
+ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
[AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
[lua_havelib=LUA$lua_vndot],
[AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,
diff --git a/rrdtool-1.4.7-lua-5.2.patch b/rrdtool-1.4.7-lua-5.2.patch
new file mode 100644
index 0000000..f597371
--- /dev/null
+++ b/rrdtool-1.4.7-lua-5.2.patch
@@ -0,0 +1,31 @@
+diff --git a/bindings/lua/rrdlua.c b/bindings/lua/rrdlua.c
+index 690ba29..839833a 100644
+--- a/bindings/lua/rrdlua.c
++++ b/bindings/lua/rrdlua.c
+@@ -342,7 +342,7 @@ set_info (lua_State * L)
+
+ /**********************************************************/
+
+-static const struct luaL_reg rrd[] = {
++static const struct luaL_Reg rrd[] = {
+ {"create", lua_rrd_create},
+ {"dump", lua_rrd_dump},
+ {"fetch", lua_rrd_fetch},
+diff --git a/configure.ac b/configure.ac
+index 2ff18a8..4993717 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -734,7 +734,12 @@ LUA_EOF
+ LIBS=
+ lua_havelib=no
+ LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
+- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
++ if test "$lua_vndot" = "52"; then
++ CALL_FUNC=lua_callk
++ else
++ CALL_FUNC=lua_call
++ fi
++ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
+ [AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
+ [lua_havelib=LUA$lua_vndot],
+ [AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,

View File

@ -16,23 +16,21 @@
Summary: Round Robin Database Tool to store and display time-series data
Name: rrdtool
Version: 1.4.8
Release: 18%{?dist}
Version: 1.4.9
Release: 1%{?dist}
License: GPLv2+ with exceptions
Group: Applications/Databases
URL: http://oss.oetiker.ch/rrdtool/
Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
Source1: php4-%{svnrev}.tar.gz
Patch1: rrdtool-1.4.4-php54.patch
Patch2: rrdtool-1.4.7-ruby-2-fix.patch
# disable logo for php 5.5.
Patch3: rrdtool-1.4.7-php55.patch
Patch4: rrdtool-1.4.7-autoconf-fix.patch
Patch5: rrdtool-1.4.7-lua-5.2.patch
# patch merged upstream, http://github.com/oetiker/rrdtool-1.x/pull/397
Patch6: rrdtool-1.4.8-imginfo-check.patch
Patch2: rrdtool-1.4.7-php55.patch
Patch3: rrdtool-1.4.7-ruby-2-fix.patch
Patch4: rrdtool-1.4.9-autoconf-fix.patch
Patch5: rrdtool-1.4.9-lua-5.2.patch
# patch sent upstream
Patch7: rrdtool-1.4.8-doc-fix.patch
Patch7: rrdtool-1.4.9-doc-fix.patch
# enable php bindings on ppc
Patch8: rrdtool-1.4.8-php-ppc-fix.patch
@ -168,16 +166,15 @@ The %{name}-lua package includes RRDtool bindings for Lua.
%setup -q -n %{name}-%{version} %{?with_php: -a 1}
%if %{with_php}
%patch1 -p1 -b .php54
%patch3 -p1 -b .php55
%patch2 -p1 -b .php55
%endif
# Workaround for rhbz#92165
# Do not apply on RHEL-6 or lower
%if %{?rhel} %{?!rhel:7} > 6
%patch2 -p1 -b .ruby-2-fix
%patch3 -p1 -b .ruby-2-fix
%endif
%patch4 -p1 -b .autoconf-fix
%patch5 -p1 -b .lua-52
%patch6 -p1 -b .imginfo-check
%patch7 -p1 -b .doc-fix
%patch8 -p1 -b .php-ppc-fix
@ -393,6 +390,12 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} php -n \
%endif
%changelog
* Tue Sep 30 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 1.4.9-1
- New version
Resolves: rhbz#1147901
- Dropped imginfo-check patch (upstreamed)
- De-fuzzified patches
* Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.4.8-18
- Perl 5.20 rebuild

View File

@ -1,2 +1,2 @@
dbe59386db97fd2f2216729facd74ca8 rrdtool-1.4.8.tar.gz
1cea5a9efd6a48ac4035b0f9c7e336cf rrdtool-1.4.9.tar.gz
28074a9c368af013462631959ab90558 php4-r1190.tar.gz