RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/rrdtool#f33b55ff2e773bfb1b4732d606fe89b8d7138371
This commit is contained in:
parent
bc090900dd
commit
40ab99de7a
2
.gitignore
vendored
2
.gitignore
vendored
@ -0,0 +1,2 @@
|
||||
php4-r1190.tar.gz
|
||||
rrdtool-*.tar.gz
|
100
rrdtool-1.4.4-php54.patch
Normal file
100
rrdtool-1.4.4-php54.patch
Normal file
@ -0,0 +1,100 @@
|
||||
diff -up rrdtool-1.4.4/php4/rrdtool.c.php54 rrdtool-1.4.4/php4/rrdtool.c
|
||||
--- rrdtool-1.4.4/php4/rrdtool.c.php54 2011-12-29 08:57:00.790784347 +0100
|
||||
+++ rrdtool-1.4.4/php4/rrdtool.c 2011-12-29 09:00:55.960794927 +0100
|
||||
@@ -39,7 +39,7 @@
|
||||
ZEND_DECLARE_MODULE_GLOBALS(rrdtool)
|
||||
*/
|
||||
|
||||
-function_entry rrdtool_functions[] = {
|
||||
+zend_function_entry rrdtool_functions[] = {
|
||||
PHP_FE(rrd_graph, NULL)
|
||||
PHP_FE(rrd_fetch, NULL)
|
||||
PHP_FE(rrd_error, NULL)
|
||||
@@ -119,8 +119,8 @@ PHP_MINFO_FUNCTION(rrdtool)
|
||||
Creates a graph based on options passed via an array */
|
||||
PHP_FUNCTION(rrd_graph)
|
||||
{
|
||||
- pval *file, *args, *p_argc;
|
||||
- pval *entry;
|
||||
+ zval *file, *args, *p_argc;
|
||||
+ zval *entry;
|
||||
zval *p_calcpr;
|
||||
HashTable *args_arr;
|
||||
int i, xsize, ysize, argc;
|
||||
@@ -155,7 +155,7 @@ PHP_FUNCTION(rrd_graph)
|
||||
|
||||
for (i = 3; i < argc; i++)
|
||||
{
|
||||
- pval **dataptr;
|
||||
+ zval **dataptr;
|
||||
|
||||
if ( zend_hash_get_current_data(args_arr, (void *) &dataptr) == FAILURE )
|
||||
continue;
|
||||
@@ -216,9 +216,8 @@ PHP_FUNCTION(rrd_graph)
|
||||
Fetch info from an RRD file */
|
||||
PHP_FUNCTION(rrd_fetch)
|
||||
{
|
||||
- pval *file, *args, *p_argc;
|
||||
- pval *entry;
|
||||
- pval *p_start, *p_end, *p_step, *p_ds_cnt;
|
||||
+ zval *file, *args, *p_argc;
|
||||
+ zval *entry;
|
||||
HashTable *args_arr;
|
||||
zval *p_ds_namv, *p_data;
|
||||
int i, j, argc;
|
||||
@@ -254,7 +253,7 @@ PHP_FUNCTION(rrd_fetch)
|
||||
|
||||
for (i = 3; i < argc; i++)
|
||||
{
|
||||
- pval **dataptr;
|
||||
+ zval **dataptr;
|
||||
|
||||
if ( zend_hash_get_current_data(args_arr, (void *) &dataptr) == FAILURE )
|
||||
continue;
|
||||
@@ -361,7 +360,7 @@ PHP_FUNCTION(rrd_clear_error)
|
||||
Update an RRD file with values specified */
|
||||
PHP_FUNCTION(rrd_update)
|
||||
{
|
||||
- pval *file, *opt;
|
||||
+ zval *file, *opt;
|
||||
char **argv;
|
||||
|
||||
if ( rrd_test_error() )
|
||||
@@ -404,7 +403,7 @@ PHP_FUNCTION(rrd_update)
|
||||
Gets last update time of an RRD file */
|
||||
PHP_FUNCTION(rrd_last)
|
||||
{
|
||||
- pval *file;
|
||||
+ zval *file;
|
||||
unsigned long retval;
|
||||
|
||||
char **argv = (char **) emalloc(3 * sizeof(char *));
|
||||
@@ -439,8 +438,8 @@ PHP_FUNCTION(rrd_last)
|
||||
Create an RRD file with the options passed (passed via array) */
|
||||
PHP_FUNCTION(rrd_create)
|
||||
{
|
||||
- pval *file, *args, *p_argc;
|
||||
- pval *entry;
|
||||
+ zval *file, *args, *p_argc;
|
||||
+ zval *entry;
|
||||
char **argv;
|
||||
HashTable *args_arr;
|
||||
int argc, i;
|
||||
@@ -449,7 +448,7 @@ PHP_FUNCTION(rrd_create)
|
||||
rrd_clear_error();
|
||||
|
||||
if ( ZEND_NUM_ARGS() == 3 &&
|
||||
- getParameters(ht, 3, &file, &args, &p_argc) == SUCCESS )
|
||||
+ zend_get_parameters(ht, 3, &file, &args, &p_argc) == SUCCESS )
|
||||
{
|
||||
if ( args->type != IS_ARRAY )
|
||||
{
|
||||
@@ -473,7 +472,7 @@ PHP_FUNCTION(rrd_create)
|
||||
|
||||
for (i = 3; i < argc; i++)
|
||||
{
|
||||
- pval **dataptr;
|
||||
+ zval **dataptr;
|
||||
|
||||
if ( zend_hash_get_current_data(args_arr, (void *) &dataptr) == FAILURE )
|
||||
continue;
|
83
rrdtool-1.4.7-php55.patch
Normal file
83
rrdtool-1.4.7-php55.patch
Normal file
@ -0,0 +1,83 @@
|
||||
--- rrdtool-1.4.7/php4/rrdtool.c.orig 2013-03-22 14:54:18.520877577 +0100
|
||||
+++ rrdtool-1.4.7/php4/rrdtool.c 2013-03-22 14:59:23.056303502 +0100
|
||||
@@ -20,13 +20,11 @@
|
||||
|
||||
/* PHP Includes */
|
||||
#include "php.h"
|
||||
-#include "php_logos.h"
|
||||
#include "ext/standard/info.h"
|
||||
#include "SAPI.h"
|
||||
|
||||
/* rrdtool includes */
|
||||
#include "php_rrdtool.h"
|
||||
-#include "rrdtool_logo.h"
|
||||
#include <rrd.h>
|
||||
|
||||
#ifdef HAVE_CONFIG_H
|
||||
@@ -48,7 +46,6 @@
|
||||
PHP_FE(rrd_last, NULL)
|
||||
PHP_FE(rrd_create, NULL)
|
||||
PHP_FE(rrdtool_info, NULL)
|
||||
- PHP_FE(rrdtool_logo_guid, NULL)
|
||||
{NULL, NULL, NULL}
|
||||
};
|
||||
|
||||
@@ -83,8 +80,6 @@
|
||||
/* {{{ PHP_MINIT_FUNCTION */
|
||||
PHP_MINIT_FUNCTION(rrdtool)
|
||||
{
|
||||
- php_register_info_logo(RRDTOOL_LOGO_GUID , "image/gif", rrdtool_logo , sizeof(rrdtool_logo));
|
||||
-
|
||||
return SUCCESS;
|
||||
}
|
||||
/* }}} */
|
||||
@@ -92,8 +87,6 @@
|
||||
/* {{{ PHP_MSHUTDOWN_FUNCTION */
|
||||
PHP_MSHUTDOWN_FUNCTION(rrdtool)
|
||||
{
|
||||
- php_unregister_info_logo(RRDTOOL_LOGO_GUID);
|
||||
-
|
||||
return SUCCESS;
|
||||
}
|
||||
/* }}} */
|
||||
@@ -102,11 +95,6 @@
|
||||
PHP_MINFO_FUNCTION(rrdtool)
|
||||
{
|
||||
php_info_print_box_start(1);
|
||||
- PUTS("<a href=\"http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/\" target=\"rrdtool\"><img border=\"0\" src=\"");
|
||||
- if (SG(request_info).request_uri) {
|
||||
- PUTS(SG(request_info).request_uri);
|
||||
- }
|
||||
- PUTS("?="RRDTOOL_LOGO_GUID"\" alt=\"ClamAV logo\" /></a>\n");
|
||||
php_printf("<h1 class=\"p\">rrdtool Version %s</h1>\n", PHP_RRD_VERSION_STRING);
|
||||
php_info_print_box_end();
|
||||
php_info_print_table_start();
|
||||
@@ -548,11 +536,6 @@
|
||||
PUTS("<body><div class=\"center\">\n");
|
||||
|
||||
php_info_print_box_start(1);
|
||||
- PUTS("<a href=\"http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/\" target=\"rrdtool\"><img border=\"0\" src=\"");
|
||||
- if (SG(request_info).request_uri) {
|
||||
- PUTS(SG(request_info).request_uri);
|
||||
- }
|
||||
- PUTS("?="RRDTOOL_LOGO_GUID"\" alt=\"ClamAV logo\" /></a>\n");
|
||||
php_printf("<h1 class=\"p\">rrdtool Version %s</h1>\n", PHP_RRD_VERSION_STRING);
|
||||
php_info_print_box_end();
|
||||
php_info_print_table_start();
|
||||
@@ -590,16 +573,6 @@
|
||||
}
|
||||
/* }}} */
|
||||
|
||||
-PHP_FUNCTION(rrdtool_logo_guid)
|
||||
-{
|
||||
- if (ZEND_NUM_ARGS() != 0) {
|
||||
- WRONG_PARAM_COUNT;
|
||||
- }
|
||||
-
|
||||
- RETURN_STRINGL(RRDTOOL_LOGO_GUID, sizeof(RRDTOOL_LOGO_GUID)-1, 1);
|
||||
-}
|
||||
-/* }}} */
|
||||
-
|
||||
#endif /* HAVE_RRDTOOL */
|
||||
|
||||
/*
|
11
rrdtool-1.4.8-php-ppc-fix.patch
Normal file
11
rrdtool-1.4.8-php-ppc-fix.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/php4/ltconfig 2014-08-11 13:01:13.020065855 +0000
|
||||
+++ a/php4/ltconfig 2014-08-11 13:01:23.870060274 +0000
|
||||
@@ -1939,7 +1939,7 @@
|
||||
else
|
||||
# Only the GNU ld.so supports shared libraries on MkLinux.
|
||||
case "$host_cpu" in
|
||||
- powerpc*) dynamic_linker=no ;;
|
||||
+# powerpc*) dynamic_linker=no ;;
|
||||
*) dynamic_linker='Linux ld.so' ;;
|
||||
esac
|
||||
fi
|
26
rrdtool-1.6.0-ruby-2-fix.patch
Normal file
26
rrdtool-1.6.0-ruby-2-fix.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
|
||||
index 54f5c23..ee85c23 100644
|
||||
--- a/bindings/Makefile.am
|
||||
+++ b/bindings/Makefile.am
|
||||
@@ -35,8 +35,9 @@ install-data-local:
|
||||
&& $(MAKE) install ) \
|
||||
|| true
|
||||
$(AM_V_GEN)test -f ${builddir}/ruby/Makefile \
|
||||
- && ( cd ${builddir}/ruby \
|
||||
- && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install ) \
|
||||
+ && ( $(MKDIR_P) $(DESTDIR)$(libdir)/ruby/vendor_ruby && cd ${builddir}/ruby \
|
||||
+ && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) \
|
||||
+ hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)" install ) \
|
||||
|| true
|
||||
$(AM_V_GEN)test -d ${builddir}/python/build \
|
||||
&& ( cd ${builddir}/python \
|
||||
@@ -57,7 +58,8 @@ ruby:
|
||||
EPREFIX=$(exec_prefix) \
|
||||
ABS_TOP_SRCDIR=${abs_top_srcdir} \
|
||||
ABS_TOP_BUILDDIR=${abs_top_builddir} \
|
||||
- $(RUBY_MAKE_OPTIONS) RUBYARCHDIR= )
|
||||
+ $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" \
|
||||
+ rubyhdrdir="$(includedir)" includedir="$(includedir)" RUBYARCHDIR= )
|
||||
|
||||
# rules for building the python module
|
||||
python:
|
1089
rrdtool.spec
Normal file
1089
rrdtool.spec
Normal file
File diff suppressed because it is too large
Load Diff
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
||||
SHA512 (rrdtool-1.7.2.tar.gz) = 453230efc68aeb4a12842d20a9d246ba478a79c2f6bfd9693a91837c1c1136abe8af177be64fe29aa40bf84ccfce7f2f15296aefe095e89b8b62aef5a7623e29
|
||||
SHA512 (php4-r1190.tar.gz) = 5fe8f3798abe50553a825ca8358c0d44af389ce5e5ae219c26da70e39f982fce95ad49ef620d03dd4a4a575e7a75d2f569c2013a250f2bcd16c3b2a5322a8eb7
|
Loading…
Reference in New Issue
Block a user