New version

Resolves: rhbz#1672309
Dropped fix-configure-parameters patch (upstreamed)
This commit is contained in:
Jaroslav Škarvada 2019-02-05 15:10:39 +01:00
parent 6a3b69076d
commit 04e7eabbab
3 changed files with 11 additions and 55 deletions

View File

@ -1,49 +0,0 @@
--- ./configure.ac.orig 2017-05-16 10:32:11.000000000 +0200
+++ ./configure.ac 2018-01-05 14:00:09.261806009 +0100
@@ -512,7 +512,11 @@
have_libdbi=no
-AC_ARG_ENABLE(libdbi,AS_HELP_STRING([--disable-libdbi],[do not build in support for libdbi]),[],[
+AC_ARG_ENABLE(libdbi,AS_HELP_STRING([--disable-libdbi],[do not build in support for libdbi]),
+[],
+[enable_libdbi=yes])
+
+AS_IF([test "x$enable_libdbi" != xno], [
AC_CHECK_HEADER(dbi/dbi.h, [
AC_CHECK_LIB(dbi, dbi_initialize, [
AC_DEFINE(HAVE_LIBDBI,[1],[have got libdbi installed])
@@ -526,7 +530,11 @@
have_librados=no
-AC_ARG_ENABLE(librados,AS_HELP_STRING([--disable-librados],[do not build in support for librados]),[],[
+AC_ARG_ENABLE(librados,AS_HELP_STRING([--disable-librados],[do not build in support for librados]),
+[],
+[enable_librados=yes])
+
+AS_IF([test "x$enable_librados" != xno], [
AC_CHECK_HEADER(rados/librados.h, [
AC_DEFINE(HAVE_LIBRADOS,[1],[have got librados installed])
LIBS="${LIBS} -lrados"
@@ -538,7 +546,11 @@
have_libwrap=no
-AC_ARG_ENABLE(libwrap, AS_HELP_STRING([--disable-libwrap], [do not build in support for libwrap (tcp wrapper)]),[],[
+AC_ARG_ENABLE(libwrap, AS_HELP_STRING([--disable-libwrap], [do not build in support for libwrap (tcp wrapper)]),
+[],
+[enable_libwrap=yes])
+
+AS_IF([test "x$enable_libwrap" != xno], [
AC_CHECK_HEADER(tcpd.h,[
AC_CHECK_FUNCS(hosts_access, [
AC_DEFINE(HAVE_LIBWRAP,[1],[have got libwrap installed])
@@ -554,7 +566,6 @@
])
])
-
AM_CONDITIONAL(BUILD_LIBWRAP,[test $have_libwrap != no])
AM_CONDITIONAL(BUILD_RRDGRAPH,[test $enable_rrd_graph != no])

View File

@ -23,8 +23,8 @@
Summary: Round Robin Database Tool to store and display time-series data
Name: rrdtool
Version: 1.7.0
Release: 21%{?dist}
Version: 1.7.1
Release: 1%{?dist}
License: GPLv2+ with exceptions
URL: http://oss.oetiker.ch/rrdtool/
Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
@ -35,8 +35,8 @@ Patch2: rrdtool-1.4.7-php55.patch
Patch3: rrdtool-1.6.0-ruby-2-fix.patch
# enable php bindings on ppc
Patch4: rrdtool-1.4.8-php-ppc-fix.patch
# https://github.com/oetiker/rrdtool-1.x/issues/861
Patch5: rrdtool-1.7.0-fix-configure-parameters.patch
# https://github.com/oetiker/rrdtool-1.x/pull/960
Patch5: rrdtool-1.7.1-compile-fix.patch
Requires: dejavu-sans-mono-fonts
Requires(post): systemd
@ -195,7 +195,7 @@ The %{name}-lua package includes RRDtool bindings for Lua.
%patch3 -p1 -b .ruby-2-fix
%endif
%patch4 -p1 -b .php-ppc-fix
%patch5 -p1 -b .fix-configure-parameters
%patch5 -p1 -b .compile-fix
# Fix to find correct python dir on lib64
perl -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
@ -455,6 +455,11 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} php -n \
%endif
%changelog
* Tue Feb 5 2019 Jaroslav Škarvada <jskarvad@redhat.com> - 1.7.1-1
- New version
Resolves: rhbz#1672309
- Dropped fix-configure-parameters patch (upstreamed)
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

View File

@ -1,2 +1,2 @@
SHA512 (rrdtool-1.7.1.tar.gz) = ee5c9ff234493442ccd9bfc7031700483011de3e05c01e026509b699cb0d7d3e286e2046357c5fff5807f3e709043c8f218b48b43f8b126a23e228a3927d7b14
SHA512 (php4-r1190.tar.gz) = 5fe8f3798abe50553a825ca8358c0d44af389ce5e5ae219c26da70e39f982fce95ad49ef620d03dd4a4a575e7a75d2f569c2013a250f2bcd16c3b2a5322a8eb7
SHA512 (rrdtool-1.7.0.tar.gz) = 36d979561601135d74622eaf183701de15cba5e25118f7a308926a695ba84ecb33c3d16511bf4bc80cff055853e2eb85065bc4ed8aef19fc0277c6430ecd319f