Tool for checking common errors in RPM packages
Go to file
Michel Alexandre Salim 43b8a7e220 Filter out postin-without-install-info
Fedora no longer requires install-info scriptlets, and we already filter out some rpmlint rules (`info-files-without-install-info-postin` and `info-files-without-install-info-postun`).

Some packages (like `emacs-slime`) still has `%post` for other reasons, though, and if they also ship info files this triggers an extraneous rpmlint error.

Filter out `postin-without-install-info` in addition to the existing two rules.

Test case:
```
~/src/fedora/pkgs-others/rpmlint master*
❯ diff -u <(rpmlint /var/lib/mock/fedora-32-x86_64/result/emacs-slime-2.24-1.fc32.noarch.rpm) <(rpmlint -f ./rpmlint.config /var/lib/mock/fedora-32-x86_64/result/emacs-slime-2.24-1.fc32.noarch.rpm)
--- /proc/self/fd/12    2020-04-28 18:24:01.774132790 -0700
+++ /proc/self/fd/13    2020-04-28 18:24:01.775132781 -0700
@@ -1,6 +1,4 @@
 emacs-slime.noarch: E: incorrect-fsf-address /usr/share/common-lisp/source/slime/lib/hyperspec.el
 emacs-slime.noarch: E: incorrect-fsf-address /usr/share/common-lisp/source/slime/swank/clisp.lisp
 emacs-slime.noarch: E: incorrect-fsf-address /usr/share/emacs/site-lisp/slime/lib/hyperspec.el
-emacs-slime.noarch: E: postin-without-install-info /usr/share/info/slime.info.gz
-emacs-slime.noarch: E: postin-without-install-info /usr/share/info/slime.info.gz
-1 packages and 0 specfiles checked; 5 errors, 0 warnings.
+1 packages and 0 specfiles checked; 3 errors, 0 warnings.
```
2020-04-28 18:31:55 -07:00
.gitignore Simplify and improve git ignore rules 2018-05-04 00:46:14 -04:00
rpmlint-1.10-suppress-locale-error.patch Suppress locale error in order to work in default mock (#1668400) 2019-03-10 12:19:03 +01:00
rpmlint-1.11-rpm4.15.patch Make it build 2019-07-04 01:14:11 +02:00
rpmlint-CHANGES.package.old - Update to 0.91; fixes #513811, #515185, #516492, #519694, and #521630. 2009-09-13 22:15:36 +00:00
rpmlint-etc.config - Apply upstream patch to load all *config from /etc/rpmlint. 2008-10-30 22:01:09 +00:00
rpmlint.config Filter out postin-without-install-info 2020-04-28 18:31:55 -07:00
rpmlint.spec - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild 2020-01-30 17:53:23 +00:00
sources 1.11 2019-06-21 10:49:39 -04:00