- Update to 0.94; rpm >= 4.8.0 spec file check fix included upstream.
- Sync Fedora license list with Wiki revision 1.65 (#559156).
This commit is contained in:
parent
43fef61643
commit
e6cf082307
@ -1 +1 @@
|
||||
rpmlint-0.93.tar.bz2
|
||||
rpmlint-0.94.tar.bz2
|
||||
|
@ -1,19 +0,0 @@
|
||||
Index: SpecCheck.py
|
||||
===================================================================
|
||||
--- SpecCheck.py (revision 1719)
|
||||
+++ SpecCheck.py (working copy)
|
||||
@@ -526,7 +526,13 @@
|
||||
# errors logged above already
|
||||
pass
|
||||
if spec_obj:
|
||||
- for src in spec_obj.sources():
|
||||
+ try:
|
||||
+ # rpm < 4.8.0
|
||||
+ sources = spec_obj.sources()
|
||||
+ except TypeError:
|
||||
+ # rpm >= 4.8.0
|
||||
+ sources = spec_obj.sources
|
||||
+ for src in sources:
|
||||
(url, num, flags) = src
|
||||
(scheme, netloc) = urlparse(url)[0:2]
|
||||
if flags & 1: # rpmspec.h, rpm.org ticket #123
|
@ -40,7 +40,7 @@ setOption("DanglingSymlinkExceptions", (
|
||||
setOption("ValidLicenses", (
|
||||
# These are the short names for all of the Fedora approved licenses.
|
||||
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
||||
# Last synced with revision "1.64, 15 Jan 2010" of that page.
|
||||
# Last synced with revision "1.65, 26 Jan 2010" of that page.
|
||||
'AAL',
|
||||
'Adobe',
|
||||
'ADSL',
|
||||
@ -89,6 +89,7 @@ setOption("ValidLicenses", (
|
||||
'EPL',
|
||||
'ERPL',
|
||||
'EU Datagrid',
|
||||
'EUPL 1.1',
|
||||
'Eurosym',
|
||||
'Fair',
|
||||
'FTL',
|
||||
|
11
rpmlint.spec
11
rpmlint.spec
@ -1,6 +1,6 @@
|
||||
Name: rpmlint
|
||||
Version: 0.93
|
||||
Release: 2%{?dist}
|
||||
Version: 0.94
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for checking common errors in RPM packages
|
||||
|
||||
Group: Development/Tools
|
||||
@ -10,8 +10,6 @@ Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
||||
Source1: %{name}.config
|
||||
Source2: %{name}-CHANGES.package.old
|
||||
Source3: %{name}-etc.config
|
||||
# Upstream post-0.93
|
||||
Patch0: %{name}-0.93-rpm-4.8.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildArch: noarch
|
||||
@ -41,7 +39,6 @@ and source packages as well as spec files can be checked.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0
|
||||
sed -i -e /MenuCheck/d Config.py
|
||||
cp -p config config.example
|
||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||
@ -81,6 +78,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Feb 1 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.94-1
|
||||
- Update to 0.94; rpm >= 4.8.0 spec file check fix included upstream.
|
||||
- Sync Fedora license list with Wiki revision 1.65 (#559156).
|
||||
|
||||
* Tue Jan 26 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.93-2
|
||||
- Apply upstream patch to fix spec file check with rpm >= 4.8.0.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user